Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

error when run the LDV simulator

Status
Not open for further replies.

wateror

Member level 4
Joined
Aug 26, 2007
Messages
79
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,286
Activity points
1,733
Hi, everyone.
I used the nclaunch to simulate the design. But it had a error as follows:
ncsim: error while loading shared libraries: libudm.so: cannot open shared object file: No such file or directory
I had already set the LIB_PATH to /tools.lnx86 which contains the libudm.so file. the bashrc file content islisted below:
#for ldv
export PATH=$PATH:/eda/ldv/tools.lnx86/bin
export LM_LICENSE_FILE=/eda/ldv/ldv.dat:$LM_LICENSE_FILE
export PATH=$PATH:/eda/ldv/tools.lnx86/dfII/bin
export PATH=$PATH:/eda/ldv/tools.lnx86/verity/bin
export LDVDIR=/eda/ldv
export LDV_ROOT=/eda/ldv
export LDV_INSTALL_DIR=/eda/ldv
export LDV_LIB_PATH=/eda/ldv/tools.lnx86/lib:$LDV_LIB_PATH
export LDV_LIB_PATH=/lib:/usr/lib:/usr/dt/lib:$LDV_LIB_PATH
export PATH=$PATH:/eda/ldv/tools.lnx86/vtools/vfault/bin
export PATH=$PATH:/eda/ldv/tools.lnx86/verilog/bin
export PATH=$PATH:/eda/ldv/tools.lnx86/nclaunch/bin
export PATH=$PATH:/eda/ldv/tools.lnx86/simvision/bin
export PATH=$PATH:/eda/ldv/tools.lnx86/systemc/bin
export PATH=$PATH:/eda/ldv/tools.lnx86/spectre/bin
 

meitolake

Full Member level 3
Joined
Oct 7, 2007
Messages
154
Helped
30
Reputation
60
Reaction score
5
Trophy points
1,298
Activity points
1,894
Did you make the link tools to tools.lnx86?
 

wateror

Member level 4
Joined
Aug 26, 2007
Messages
79
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,286
Activity points
1,733
yes. I did as the following command:
ln -s tools.lnx86 tools
 

meitolake

Full Member level 3
Joined
Oct 7, 2007
Messages
154
Helped
30
Reputation
60
Reaction score
5
Trophy points
1,298
Activity points
1,894
Did you set the directory which contains the libudm.so file in the environment variable LD_LIBRARY_PATH?
 

beta0

Member level 5
Joined
Nov 24, 2003
Messages
88
Helped
7
Reputation
14
Reaction score
2
Trophy points
1,288
Activity points
393
You need to point it at the cadence tools library (e.g. $CDS_INST_DIR/tools/lib)as well as your own library directory(e.g. EXPORT LD_LIBRARY_PATH=$ LD_LIBRARY_PATH:/home/xxx/xx/, the directory is your local directory which contain file libudm.so)
 

Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top