Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Register Log in

Error (no response) when import layout instance into cadence virtuoso layout

Status
Not open for further replies.

kalahara

Newbie level 6
Joined
Dec 20, 2006
Messages
14
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,372
no response when I enter the key "i" on keyboard
for importing existing cell into current cell in cadence vituoso
layout.

show up that:
*Error* putprop : first arg must be either symbol, list, defstruct or user type -nil.
 

dick_freebird

Advanced Member level 5
Joined
Mar 4, 2008
Messages
7,036
Helped
2,055
Reputation
4,114
Reaction score
1,903
Trophy points
1,393
Location
USA
Activity points
56,399
Are you sure your bindkey means, what you think it means?
Look at the CDS.log file, for clues.
 

jimito13

Advanced Member level 1
Joined
Nov 17, 2008
Messages
470
Helped
130
Reputation
262
Reaction score
122
Trophy points
1,323
Location
Greece
Activity points
4,929
In addition check the icfb/virtuoso window (the first small window that opens when you initialize the tool) to see more details
about the error.
As dick_freebird said most probably you are using custom bindkeys that are different from the usual.You can ask your
CAD-PDK administrator to solve this or debug by yourself by digging into the bindkeys files and see the counterparts of every
keyboard key.
 

kalahara

Newbie level 6
Joined
Dec 20, 2006
Messages
14
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,372
thank you for your advice.
I'm quite sure the bindkey would not be the problem.
my bindkey for instance("i") is "3".
It is not default bindkey.
I write it as "i", in order to underdstandable for others.(default bindkey users)
I am gonna check the CDS.log file.
icfb show up the massegae I mentioned above.
 

Teddy

Advanced Member level 1
Joined
Sep 15, 2004
Messages
461
Helped
103
Reputation
206
Reaction score
62
Trophy points
1,308
Activity points
3,861
you mean you have bindkey defined like this : hiSetBindKey("Layout" "<Key>3" "leHiCreateInst()")
If that gives you error you might have bigger issue....
 

Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top