Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Register Log in

Electric Motorcycle Drive & Hall Effect Sensor Ringing

Status
Not open for further replies.

jegues

Member level 3
Joined
May 29, 2011
Messages
58
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,286
Activity points
1,921
Evening gents,

We've built the following circuit in the lab for our DC-DC converter for an electric motorcycle.

The blocks from left to right are,

  1. High speed optoisolator
  2. IR2110 Gate driver IC
  3. MOSFET Power buffer circuit
  4. MOSFET Power Module
  5. PMDC Motor
  6. ~48V Lead acid battery bank
  7. Hall effect sensor
HallEffectSensorRinging.PNG
Also note the circuit operates with two isolated grounds, one being the signal ground(i.e. ground for microcontroller), and the other the power ground. (i.e. negative of battery bank)

When operating this circuit, we measured the voltage at the gate of the bottom power MOSFET within our power module with respect to the power ground (yellow signal on the oscilloscope) as well as the output voltage of our hall effect sensor with respect to the signal ground.(blue signal on the oscilloscope)

We are using the hall effect sensor to monitor the current passing through motor and to relay this information back to our microcontroller which will take appropriate action if the current is deemed to be outside of acceptable ranges.

Please see the schematic above, as well as the following youtube video: http://youtu.be/9R0xHGUImaM

As seen in the video, we observe some ringing on both the yellow and blue waveforms that seems to be somewhat synchronized, as if the cause of the ringing was from the same source, or at least somehow related.

You'll also note some more erratic high frequency ringing fading in and out of both signals. I'm fairly certain this erratic high frequency ringing fading in and out is simply due to triggering issues within the oscilloscope when the video was taken, but can't say for sure.

Does anyone have any idea what the cause of this sort of ringing could be? Or any further tests we can do to narrow down the cause of the problem?

Our goal is to obtain a "acceptable" signal from the hall effect sensor which will then be filtered and passed to our microcontroller for analog to digital conversion. It must be "acceptable" in the sense that the filtered version of the signal that is passed to the microcontroller still contains all the information that the microcontroller may need. In other words, the microcontroller should be able to distinguish between a 100A current and 150A current within a couple peroids of the switching frequency. (which for us is 20kHz)

I look forward to any advice, suggestions, or comments you may have me.

Thanks again!
 

BradtheRad

Super Moderator
Staff member
Joined
Apr 1, 2011
Messages
13,569
Helped
2,688
Reputation
5,372
Reaction score
2,599
Trophy points
1,393
Location
Minneapolis, Minnesota, USA
Activity points
101,389
On occasion I have noticed inexplicable ringing, when I draw pulsed high current from lead-acid batteries, to power loads which have a certain amount of inductance.

Right now it occurs to me to wonder, how much capacitance there is between the lead plates of the battery? Either within a cell, or between neighboring cells.

There would be a low resistance between the plates, making the capacitance difficult to detect and measure... but it might account for ringing in cases where resonance should not be happening.
 

chuckey

Advanced Member level 5
Joined
Dec 26, 2010
Messages
4,863
Helped
1,308
Reputation
2,622
Reaction score
1,281
Trophy points
1,393
Location
Southampton and holiday cottage in Wensleydale (UK
Activity points
31,695
I have been told by a battery rep. that there is sufficient capacitance across/between the plates that charging batteries with a high frequency ripple content DC, because of the unequal current distribution causes premature battery failure.
Frank
 

jegues

Member level 3
Joined
May 29, 2011
Messages
58
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,286
Activity points
1,921
If assume the capacitance present is sufficient, what's the solution to the problem? Add inductance?
 

chuckey

Advanced Member level 5
Joined
Dec 26, 2010
Messages
4,863
Helped
1,308
Reputation
2,622
Reaction score
1,281
Trophy points
1,393
Location
Southampton and holiday cottage in Wensleydale (UK
Activity points
31,695
I do not believe its anything to do with the motor circuit, when the transistors are switched on there is a big current pulse. This can cause ringing, which is a burst of high frequency BUT it always has an exponential envelope, i.e. it decays. Your high frequency is almost constant in envelope. I think its a problem with some switched mode power supply which is running constantly, but is taking its input current in bursts and is causing a spurious voltage to appear on the "signal" earth.
I would now start of at some point you can designate as "signal" earth and see if you can see this high frequency on the signal power supplies for a start, then see if it appears on other low voltage line. The signal earth might need to be decoupled with a selection of capacitors to the motorbikes frame, like wise the motor circuits.
Frank
 

Status
Not open for further replies.
Toggle Sidebar

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top