Continue to Site

Welcome to

Welcome to our site! is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Cadence License problem

Not open for further replies.


Newbie level 6
Jan 13, 2009
Reaction score
Trophy points
Activity points
My previous license list in .cshrc is:
setenv LM_LICENSE_FILE /usr/commercial/cadence/license/tools.sun4v/license/license.dat
Cadence worked well before. But the license was expired, I cannot edit or simulate circuit.

Then following the Unix administrator's instruction, I changed the list for the new licence:
But with the new license, I only can edit the circuit schematic and layout. When running Virtuoso Analog Design Environment, I can not add a simulation job, and it shows from Cadence:

*WARNING* feature Analog_Design_Environment_L: ERROR (LM -30): license server ("") does not support feature "Analog_Design_Environment_L" (run 'lic_error -30' for more information)
*WARNING* feature 34510: ERROR (LM -30): license server ("") does not support feature "34510" (run 'lic_error -30' for more information)
*WARNING* Unable to annotate simulation results.
*WARNING* A check-out of the Artist simulation environment feature failed.
Suggestion: [1] Check your license file.
[2] Ask a current user of the feature to exit the Artist simulation environment.

The Unix administrator told me it looks fine from the license side.
Anybody knows what's the problem? What should we do to find the problem?

Thank you!

That indeed seems like a license problem, the warning about the missing "Analog_Design_Environment_L" feature seems to be quite common but usually there are higher tiered features in the license file that can be used.

Check your .cdsenv for anything that may seem to be preventing the software to try to get a higher tiered license.

If you have access to the executable lmutil you can try the following to see the features your license server provides

./lmutil lmstat -a -c 28006(at)

this will show you all the features the server provides, how many of each feature there is and how many have been checked out.
To filter the output to something more manageable do this

./lmutil lmstat -a -c 28006(at) | grep -i analog

You can replace analog for any part of a feature name such as 34510

Without the license server log there isn't much more I can say, try to solve the problem on your side, if things still don't work then talk with the admin again.


    Points: 2
    Helpful Answer Positive Rating

Tried that, it seems there is a higher feature called XL and GXL (as you mentioned), but it still complains...

Users of Analog_Design_Environment_GXL: (Total of xxxx licenses available)
Users of Analog_Design_Environment_XL: (Total of xxx licenses available)

Any ideas ?

Usually if the license supports the higher tiered features, it should support low features, right? But for me, it seems that it does NOT support low feature: Analog_Design_Environment_L

What should I and Unix administrator do?

Before I forgot to leave the link to another post about a somewhat similar problem but here it is #1195147

It's about what you may have in your .cdsenv (or other file) that may be preventing ADE from getting a higher tiered license.

One thing you can try is to trick virtuoso to use another folder as your home (so you can try a clean home directory, if you look through your home directory you will see how many files there are related to eda software).

Assuming you are using tcsh as your shell this is what I would try:

mkdir test_dir
cd test_dir
setenv HOME `pwd`
source all_configs.cshrc
icfb (or virtuoso if you are using IC6, which you seem to be using)

Then create a simple schematic and try to simulate it, if it works then the problem is caused by something on your machine, if it doesn't work then ... I have no ideas.

Try to checkout those higher tiered licenses and see if it works, if it does then the license server should be working fine.

Not open for further replies.

Part and Inventory Search

Welcome to