Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Register Log in

Buildgates and Verilog-XL problem...

Status
Not open for further replies.

denexp

Newbie level 5
Joined
Jul 6, 2005
Messages
9
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,387
cds_root: not found

....Hi there.I have this annoying program. I am running all my IC software on a SuSE 9.0 machine. I am trying to run the low power synthesis tutorial of buildgates (run_no_lps.tcl). When i reach this line of the script "verilog -f $sim_dir/sim_no_lps.opt" i get the following error "Error! lps_pli.so: cannot open shared object file: No such file or directory". The thing is that these files are located under .../Buildgates/lib/archive/lnx86. My profile looks something like this

##########################################
# CADENSE SETUP #
##########################################

PATH="$PATH:/usr/cadence/IC5_0_32/tools/bin"
export PATH
PATH="$PATH:/usr/cadence/IC5_0_32/tools/dfII/bin"
export PATH
PATH="$PATH:/usr/cadence/IC5_0_32/tools/plot/bin"
export PATH
PATH="$PATH:/usr/cadence/IC5_0_32/tools/dracula/bin"
export PATH
PATH="$PATH:/usr/soc/tools/bin"
export PATH


#ASSURAHOME="/usr/cadence/ASSURA312"
#export ASSURAHOME
#PATH="$PATH:$ASSURAHOME:/tools/bin"
#export PATH
#PATH="$PATH:$ASSURAHOME:/tools/assura/bin"
#export PATH

ASSURAHOME="/usr/cadence/ASSURA30"
export ASSURAHOME
PATH="$PATH:$ASSURAHOME/tools/bin"
export PATH
PATH="$PATH:$ASSURAHOME/tools/assura/bin"
export PATH


LDV="/usr/cadence/LDV_5.1"
export LDV
PATH="$PATH:$LDV/tools/bin"
export PATH
LD_LIBRARY_PATH="$LDV/tools/lib"
export LD_LIBRARY_PATH


#SPR="/usr/cadence/SOC_3.3/BuildGates"
#export SPR
#PATH="$PATH:$SPR/version/bin"
#export PATH


export SOC_HOME=/usr/cadence/SOC_3.3
export BINDIR=/usr/cadence/SOC_3.3/tools/bin
export FEBINDIR=/usr/cadence/SOC_3.3/bin
export CDS_PLAT=/usr/cadence/SOC_3.3/tools/bin/cds_plat
export ENCOUNTER=/usr/cadence/SOC_3.3
export SE_HOME=/usr/cadence/SOC_3.3
export PKS_HOME=/usr/cadence/SOC_3.3/BuildGates/version
export PLATO_HOME=/usr/cadence/SOC_3.3/tools/plato
export CADMOSHOME=/usr/cadence/SOC_3.3/tools/fe/celtic


#ENCOUNTER="/usr/cadence/SOC_3.3/"
#export ENCOUNTER
#TCL_LIBRARY="$ENCOUNTER/tools/plato/lib/tcl8.3"
#export TCL_LIBRARY
#TK_LIBRARY="ENCOUNTER/tools/plato/lib/tk8.3"
#export TK_LIBRARY
#PATH="$PATH:$ENCOUNTER/tools/bin"
#export PATH



CDSDIR=/usr/cadence/IC5_0_32
export CDSDIR
CDSHOME=/usr/cadence/IC5_0_32
export CDSHOME
CDS_ROOT=/usr/cadence/IC5_0_32/tools
export CDS_ROOT
CDS_ROOT=/usr/cadence/LDV_5.1/tools
export CDS_ROOT
CDS_INST_DIR=/usr/cadence/IC5_0_32
export CDS_INST_DIR
CDS_INSTALL_DIR=/usr/cadence/IC5_0_32/tools/dfII
export CDS_INSTALL_DIR

LM_LICENSE_FILE=/usr/cadence/SOC_3.3/tools/bin/license.dat
export LM_LICENSE_FILE

CDS_LIC_FILE=/usr/cadence/SOC_3.3/tools/bin/license.dat
export CDS_LIC_FILE

# PCI SETUP

PCI="/root/PCI_BRIDGE32_1.0"
export PCI

GSCLib="/usr/PDK/"
export GSCLib

CDS_Netlisting_Mode=Analog
export CDS_Netlisting_Mode



Please can you help me? Thanks in advance.
 

zhustudio

Advanced Member level 4
Joined
Jul 15, 2002
Messages
102
Helped
8
Reputation
16
Reaction score
2
Trophy points
1,298
Location
China
Activity points
1,049
cds_root not found

set LD_LIBRARY_PATH to the file lps_pli.so, it is an pli function library which must be set in LD_LIBRARY_PATH environment variable. good luck :)
 

denexp

Newbie level 5
Joined
Jul 6, 2005
Messages
9
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,387
set path cadence verilog

Thx for the solution. It worked just fine. But now i came up with another problem. The thing is that i got the error i posted above when i was trying to execute the "verilog -f $sim_dir/sim_no_lps.opt" command in a shell box. Now that i tried to execute the same command in the bgx_shell(GUI) command line i get the following error "'cds_root' not found in the path. Pls correct your path child process exited abnormally". I tried to change the CDS_ROOT variable from "/usr/cadence/IC5_0_33/tools" to "/usr/cadence/IC5_0_33/" but with no luck. Any suggestions?
 

zhustudio

Advanced Member level 4
Joined
Jul 15, 2002
Messages
102
Helped
8
Reputation
16
Reaction score
2
Trophy points
1,298
Location
China
Activity points
1,049
cds_root: command not found

you have set CDS_ROOT twice.
CDS_ROOT=/usr/cadence/IC5_0_32/tools
export CDS_ROOT
CDS_ROOT=/usr/cadence/LDV_5.1/tools
export CDS_ROOT

if you use buildgate, try to set your CDS_ROOT to encounter directory. not IC or LDV. good luck
 

darkside720

Newbie level 1
Joined
Jan 12, 2009
Messages
1
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,284
can not find cds_root

I read your post and am having the same issue when trying to run cds_root. CDS_ROOT is set corrently, but I still get the error cds_root: command not found...
 

Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top