Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Bluetooth Module AUBTM 20

Status
Not open for further replies.

soham28408

Newbie level 3
Joined
Mar 5, 2012
Messages
4
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Location
Mumbai
Activity points
1,325
I'm using AUBTM 20 module for bluetooth communication with PC in SPP.... For this I pair the Module with PC and then open the corresponding Com port in PC which results in a communication between the two..... Now the problem is how do I disconnect the module from PC ?.. If I disconnect terminal in PC side I am not able to reconnect again.....It shows CANNOT OPEN COM 5.... neither the module responds to any AT Commands from...... actually I think the module hangs....please can anyone help me regarding the same.... Thanks in advance
 

nirmala h

Member level 1
Joined
Jan 18, 2011
Messages
36
Helped
6
Reputation
12
Reaction score
6
Trophy points
1,288
Location
Bangalore, India
Activity points
1,530
I'm using AUBTM 20 module for bluetooth communication with PC in SPP.... For this I pair the Module with PC and then open the corresponding Com port in PC which results in a communication between the two..... Now the problem is how do I disconnect the module from PC ?.. If I disconnect terminal in PC side I am not able to reconnect again.....It shows CANNOT OPEN COM 5.... neither the module responds to any AT Commands from...... actually I think the module hangs....please can anyone help me regarding the same.... Thanks in advance

hi,

First close the Bluetooth tabs on the PC side & also close the hyperterminal & remove the power cable from Bluetooth module & start all over again.Before Bluetooth powerup open hyperterminal & do the settings(properties,settings,ascii setup,enable everything except Force incoming data).Then powerup if it receives ok then give enter then LLL then enter & AT which lists all the AT commands.
 

soham28408

Newbie level 3
Joined
Mar 5, 2012
Messages
4
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Location
Mumbai
Activity points
1,325
But once I make the product that won't be a feasible option....
 

tahertinu

Member level 4
Joined
Jun 11, 2011
Messages
74
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,286
Location
Ahmedabad
Activity points
1,752
hi soham would you please tell me how to communicate through AUBTM-20 Bluetooth module from PC? i am connecting my BT module to pc using UART. it gives OK. but when i entered any command is not responding. please help me
 

nirmala h

Member level 1
Joined
Jan 18, 2011
Messages
36
Helped
6
Reputation
12
Reaction score
6
Trophy points
1,288
Location
Bangalore, India
Activity points
1,530
hi soham would you please tell me how to communicate through AUBTM-20 Bluetooth module from PC? i am connecting my BT module to pc using UART. it gives OK. but when i entered any command is not responding. please help me

Hi tahertinu,

After connecting Bluetooth to PC with UART, open Hyperterminal, select the COM port, Baudrate(9600)..
Do the Hyperterminal settings ie. File-->Properties-->Settings-->ASCII setup (check the image attached).

https://images.elektroda.net/36_1333605276.jpg

Now you powerup the Bluetooth it should respond OK,then send LLL enter(Receive OK),send AT enter(Receive OK),send AT? enter which lists all the AT commands..

Any doubt comeback...
 

tahertinu

Member level 4
Joined
Jun 11, 2011
Messages
74
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,286
Location
Ahmedabad
Activity points
1,752
Hi tahertinu,

After connecting Bluetooth to PC with UART, open Hyperterminal, select the COM port, Baudrate(9600)..
Do the Hyperterminal settings ie. File-->Properties-->Settings-->ASCII setup (check the image attached).

https://images.elektroda.net/36_1333605276.jpg

Now you powerup the Bluetooth it should respond OK,then send LLL enter(Receive OK),send AT enter(Receive OK),send AT? enter which lists all the AT commands..

Any doubt comeback...

i have done this still not responding. please tell me what can be the reason for this?
 

nirmala h

Member level 1
Joined
Jan 18, 2011
Messages
36
Helped
6
Reputation
12
Reaction score
6
Trophy points
1,288
Location
Bangalore, India
Activity points
1,530
i have done this still not responding. please tell me what can be the reason for this?

Only properties changes i made then it started working...actually if all these are done then should work..
when you connect is it giving OK after you type LLL & enter..till what step it is working...
 

tahertinu

Member level 4
Joined
Jun 11, 2011
Messages
74
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,286
Location
Ahmedabad
Activity points
1,752
Only properties changes i made then it started working...actually if all these are done then should work..
when you connect is it giving OK after you type LLL & enter..till what step it is working...

it shows OK but it is not responding to any ATcommands. please give me solution
 

soham28408

Newbie level 3
Joined
Mar 5, 2012
Messages
4
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Location
Mumbai
Activity points
1,325
it shows OK but it is not responding to any ATcommands. please give me solution

Check out the parameters

Baudrate 9600, Data Bit: 8, Parity: None,StopBit: One, Handshaking : None

try this terminal.....:its better you can see the HEX data add CR+LF

https://www.ddrservice.net/download/Software/tools/Terminal/Terminal.exe.html

---------- Post added at 08:19 ---------- Previous post was at 08:15 ----------

I have found the solution.... moment the module gets disconnected as it sends +DCON,OK we need to send an LLL to it. this prevents it from hanging......
 

tahertinu

Member level 4
Joined
Jun 11, 2011
Messages
74
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,286
Location
Ahmedabad
Activity points
1,752
hi soham. i am using AUBTM-20 BT module. it is interfaced with ATmega8 using UART. AUBTM-20 work well with PC(on hyper terminal),but when i program it for the same it give error. i am giving AT-commands from ATmega8 and showing response on LCD display. it gives error for every command except LLL. please give me a better solution for this.
thank you
 

kunal123

Advanced Member level 4
Joined
Jan 24, 2011
Messages
105
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,296
Location
mumbai
Activity points
1,961
hi nirala h,
i am using aubtm-20 bluetooth module connected to my controller, which receive data from another bluetooth module & send to my controller, i face problem in sending at command to aubtm-20, it not responds to any at commands, set hyperterminal with desired setting, please help me.
 
Last edited:

nirmala h

Member level 1
Joined
Jan 18, 2011
Messages
36
Helped
6
Reputation
12
Reaction score
6
Trophy points
1,288
Location
Bangalore, India
Activity points
1,530
hi nirala h,
i am using aubtm-20 bluetooth module connected to my controller, which receive data from another bluetooth module & send to my controller, i face problem in sending at command to aubtm-20, it not responds to any at commands, set hyperterminal with desired setting, please help me.

hi kunal123,

Two things tobe done
1. Set the properties correctly (baud rate,ascii setup,etc..attachment you can see)
2. After every command give enter (when you are connecting to hyperterminal it gives OK then give ENTER then type LLL & ENTER then AT commands..)
try this..
 

kunal123

Advanced Member level 4
Joined
Jan 24, 2011
Messages
105
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,296
Location
mumbai
Activity points
1,961
OK, i will checked my hyper terminal settings,
thanks nirmala h

- - - Updated - - -

hi everyone,
my query is, if i configured Bluetooth module for particular application, next time if i want to use this application, then is it necessary to set configuration again in Bluetooth module & one more thing if i want configured make connection with another Bluetooth module, how i can do this, please help me.

thanks
 
Last edited:

nirmala h

Member level 1
Joined
Jan 18, 2011
Messages
36
Helped
6
Reputation
12
Reaction score
6
Trophy points
1,288
Location
Bangalore, India
Activity points
1,530
OK, i will checked my hyper terminal settings,
thanks nirmala h

- - - Updated - - -

hi everyone,
my query is, if i configured Bluetooth module for particular application, next time if i want to use this application, then is it necessary to set configuration again in Bluetooth module & one more thing if i want configured make connection with another Bluetooth module, how i can do this, please help me.

thanks

Hi

As long as you are running the same application then no need of changing configuration else its required to change as per application. If you want connect two bluetooths then use AT+BDISCMODE=3,0 command so bluetooth discoverable mode is enabled(you can search in your mobile this device can be found). Give AT+INQ which lists all the near by bluetooths, using AT+CON you can make the connection then data can be transferred. All you need to do is Read the AUBTM-20 AT COMMANDS datasheet. Once you know all the commands then you can work easily :)
 

kunal123

Advanced Member level 4
Joined
Jan 24, 2011
Messages
105
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,296
Location
mumbai
Activity points
1,961
hi everyone,
thanks all of u for guidence for configuring bluetooth module.
how can i drive led by arduino i.e. turn ON & OFF after every five second increment in my pc time.

thanks
 

nirmala h

Member level 1
Joined
Jan 18, 2011
Messages
36
Helped
6
Reputation
12
Reaction score
6
Trophy points
1,288
Location
Bangalore, India
Activity points
1,530
hi everyone,
thanks all of u for guidence for configuring bluetooth module.
how can i drive led by arduino i.e. turn ON & OFF after every five second increment in my pc time.

thanks

Arduino website all the codes are given in Learning tab..
Check www.arduino.cc
 

shree4u

Junior Member level 3
Joined
Nov 11, 2009
Messages
29
Helped
1
Reputation
2
Reaction score
1
Trophy points
1,283
Location
mumbai
Activity points
1,435

shree4u

Junior Member level 3
Joined
Nov 11, 2009
Messages
29
Helped
1
Reputation
2
Reaction score
1
Trophy points
1,283
Location
mumbai
Activity points
1,435
I am using aubtm-20 . when i connect with hyper terminal it receiving OK.and after word i typed LLL dan i received ok. other than these two commands if i type any AT commands i am getting ERROR for each and evry command. what was the problem...my module having serial com connection and ...please post ur ans


Thanx in advance
 

nirmala h

Member level 1
Joined
Jan 18, 2011
Messages
36
Helped
6
Reputation
12
Reaction score
6
Trophy points
1,288
Location
Bangalore, India
Activity points
1,530
I am using aubtm-20 . when i connect with hyper terminal it receiving OK.and after word i typed LLL dan i received ok. other than these two commands if i type any AT commands i am getting ERROR for each and evry command. what was the problem...my module having serial com connection and ...please post ur ans


Thanx in advance

Hello shree4u,

If you receiving OK after LLL its fine, after this you should give ENTER before typing any command (Ex. AT, AT+MODE) & after typing also ENTER command is required...you may be missing out this...try it once...
 

shree4u

Junior Member level 3
Joined
Nov 11, 2009
Messages
29
Helped
1
Reputation
2
Reaction score
1
Trophy points
1,283
Location
mumbai
Activity points
1,435
Hello shree4u,

If you receiving OK after LLL its fine, after this you should give ENTER before typing any command (Ex. AT, AT+MODE) & after typing also ENTER command is required...you may be missing out this...try it once...


Thanks nirmala for replying

i done USing enter after typing AT,AT+MODE, but it shows error. i set default baud rate 9600, zero parity, hardware control:none, ..etc, but i don't know where was the Problem....i used serial communication cable between aubtm-20 and comport of PC, how i need to enable command mode using aubtm-20..
 

Status
Not open for further replies.

Similar threads

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top