Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Register Log in

avrisp mkii clone firmware working on PC but not in Laptop

Status
Not open for further replies.

shamikrudra

Full Member level 5
Joined
Nov 16, 2009
Messages
263
Helped
21
Reputation
42
Reaction score
18
Trophy points
1,308
Location
Kolkata, India
Activity points
2,657
I am using AvrMini avrisp mkii clone firmware in usbasp hardware
it is working fine on my desktop but not working on my laptop
laptop identifies the device as avrisp mkii but avrstudio not able to communicate with it
but same hardware is working on my laptop when using usbasp farmware.
can anybody pls identify the problem?
what is the defrence in communication in avrisp mkii and usbasp?
 

wp100

Advanced Member level 5
Joined
May 15, 2009
Messages
3,056
Helped
883
Reputation
1,781
Reaction score
736
Trophy points
113
Location
Prime Meridian
Activity points
0
Hi,

Peope with the Pickit2 programmer using a laptop sometimes have a similar problem.

Its usually caused by the USB voltage on a laptop being too low, the solution is to use an externally powered USB hub so the programmer gets a good 5v
 

nandhu015

Advanced Member level 5
Joined
Feb 11, 2006
Messages
1,965
Helped
300
Reputation
600
Reaction score
224
Trophy points
1,353
Location
India
Activity points
9,825
I am using AvrMini avrisp mkii clone firmware in usbasp hardware
it is working fine on my desktop but not working on my laptop
laptop identifies the device as avrisp mkii but avrstudio not able to communicate with it
but same hardware is working on my laptop when using usbasp farmware.
can anybody pls identify the problem?
what is the defrence in communication in avrisp mkii and usbasp?
Are you sure both laptop and desktop have the same version of AVRSTUDIO installed.

Better try reinstalling the AVR Studio in the laptop
 

shamikrudra

Full Member level 5
Joined
Nov 16, 2009
Messages
263
Helped
21
Reputation
42
Reaction score
18
Trophy points
1,308
Location
Kolkata, India
Activity points
2,657
Avrstudio version is same on both 4.18 With sp3 also tried with 4.17 result are same
I can not blame the hardware because same is working with usbasp farmware.
after study i found that bulk transfer can fail on laptops.
can I change any thing in code to try in laptop? if yes where bulk transfer code is in V-USB.
 

shamikrudra

Full Member level 5
Joined
Nov 16, 2009
Messages
263
Helped
21
Reputation
42
Reaction score
18
Trophy points
1,308
Location
Kolkata, India
Activity points
2,657
Can any one tell me from where 68 ohms value comes for usb data lines? it is current limiting resistance? what is the formula for this value?
 

Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top