Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

APC UPS ES 500 keeps on beeping

Status
Not open for further replies.

dark_ages

Member level 1
Joined
Jan 8, 2011
Messages
39
Helped
1
Reputation
2
Reaction score
1
Trophy points
1,288
Location
Koronadal City, Philippines
Activity points
1,577
hello there, I am working in one of the company here in the phil. they have this APC ES 500 UPS and when it is turned on after 5 seconds it will keep on beeping. I've tried to disconnect the battery and tested it via multitester and it still has around 12 V on it. I mounted the battery again, connect it to the outlet, turned in on, tested the outputs of the UPS and it works fine. The only thing that is abnormal is it keeps on beeping after 5 sec. after it has turned on.....HELP please!
 

kalimuthu

Member level 5
Joined
Aug 27, 2010
Messages
86
Helped
8
Reputation
16
Reaction score
8
Trophy points
1,288
Location
india
Activity points
1,800
Hi,
can you tell me ,when it's turn on display coming or not? if not means it's a memory problem.if display OK but beep sound coming means it may be keyboard key problem.try to run memory test first.take out all your important data's before........8O:oops:
 

dark_ages

Member level 1
Joined
Jan 8, 2011
Messages
39
Helped
1
Reputation
2
Reaction score
1
Trophy points
1,288
Location
Koronadal City, Philippines
Activity points
1,577
what memory/display?.....i am talking about uninterruptible power supply(UPS).
when i turned on the UPS the green light indicator is ok then after about 5 seconds it keeps on flashing together with the beeping.
 
Last edited:

santucj

Newbie level 3
Joined
Nov 12, 2011
Messages
3
Helped
1
Reputation
2
Reaction score
1
Trophy points
1,283
Location
INDIA GUWAHATI
Activity points
1,292
hello your prob will be solved by replacing eeprom ic in apc which is of 24cxx smd component.after that it will give 4 beeps at perfect intervals.
 

Raza

Advanced Member level 3
Joined
Feb 10, 2002
Messages
829
Helped
265
Reputation
528
Reaction score
258
Trophy points
1,343
Location
PAK
Activity points
4,486
There is no memory inside this UPS. It is normal fault with APC inverters. And this beep, when decoded, gives imbalance of battery charge. If you have diagram, locate the series resistor for sensing the charging and current. Thats the only problem. I have came across this fault in about more than 10 inverters.
I am attaching here one schematic of APC UPS 500, though it may not be exact model but can help you. Give one try by replacing LM339.
View attachment APC UPS500.pdf

Good Luck.
 
Last edited:

anas_xrt

Newbie level 3
Joined
Feb 16, 2013
Messages
4
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,307
There is no memory inside this UPS. It is normal fault with APC inverters. And this beep, when decoded, gives imbalance of battery charge. If you have diagram, locate the series resistor for sensing the charging and current. Thats the only problem. I have came across this fault in about more than 10 inverters.
I am attaching here one schematic of APC UPS 500, though it may not be exact model but can help you. Give one try by replacing LM339.
View attachment 65310

Good Luck.

Hi Raza, I have the problem as following detail, I am not sure that it is the same problem indicator that I can use your solutions, could you help?

1. When never open APC ES-500 (model BE500R-AS) with plug-in to outlet (220V) it will have the continues Beepppppppppppppppppp with the Green LED blinking. In during Beepppppppppppppppppp Alam, I still able to plug my load and use it as normal. (only Beeppppppppppppppp is very annoying)

2. When I un-plug outlet (220v) the Beepppppppppppppppppppppp is gone but only, normal state of using battery as 4 Beep and Geen LED suspend once during Beep sound.

3. When I open the PCB, I could not find the IC LM339 as you suggestion (I understand that difference Schematic to be refer) but I found only LM324AN as link of image capture below. So I am not sure, if I change this IC the problem would be solve as the same as you mention above?

Image of PCB and IC for your reference
1. https://www.dropbox.com/s/io6v0cakovpa8uv/2013-02-16 11.27.39.jpg
2. https://www.dropbox.com/s/fgp9n1ywv2h0iwb/2013-02-16 11.32.17.jpg

Please advise and Thank in Advance.

Regards,
 

Raza

Advanced Member level 3
Joined
Feb 10, 2002
Messages
829
Helped
265
Reputation
528
Reaction score
258
Trophy points
1,343
Location
PAK
Activity points
4,486
I saw the PCB, it is different model. LM339 and LM324 are quad OPAMPS with little difference in design. This beep seems to be indicationg battery over charge alarm (a false one) and leads to a bad LM324. If visually no indication of any damage, I can suggest only (without physically examining) try changing the LM324 and see the result. If problem gone Enjoy and if not please tell me.

- - - Updated - - -

I saw the PCB, it is different model. LM339 and LM324 are quad OPAMPS with little difference in design. This beep seems to be indicating battery over charge alarm (a false one) and leads to a bad LM324. If visually no indication of any damage, I can suggest only (without physically examining) try changing the LM324 and see the result. If problem gone Enjoy and if not please tell me.
 

anas_xrt

Newbie level 3
Joined
Feb 16, 2013
Messages
4
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,307
Hi Raza,

Yes, I will test it on coming holiday, and I will let you know the result.

Thank you every much,
 

anas_xrt

Newbie level 3
Joined
Feb 16, 2013
Messages
4
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,307
Hi Raza,

After I have replace the LM324AN as per advised, now it works. I can repair it now. Just for you info. I replace the LM324AN with LM324N. It still work find. I have look into the IC specification, what was difference is the Current - Supply. LM324AN is 1.5mA but LM324N is 1mA.

If it broken again, I will note to change the same IC number :)

Thank you very much. It was very grateful advise
Also Thank you EDABOARD.com as well for the place to meet the kindness and guru people here
 

anas_xrt

Newbie level 3
Joined
Feb 16, 2013
Messages
4
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,307
I saw the PCB, it is different model. LM339 and LM324 are quad OPAMPS with little difference in design. This beep seems to be indicationg battery over charge alarm (a false one) and leads to a bad LM324. If visually no indication of any damage, I can suggest only (without physically examining) try changing the LM324 and see the result. If problem gone Enjoy and if not please tell me.

- - - Updated - - -

I saw the PCB, it is different model. LM339 and LM324 are quad OPAMPS with little difference in design. This beep seems to be indicating battery over charge alarm (a false one) and leads to a bad LM324. If visually no indication of any damage, I can suggest only (without physically examining) try changing the LM324 and see the result. If problem gone Enjoy and if not please tell me.

Hi Raza,

Today, after I have changed LM324 for a week, now the problem is back again. What is cause the LM324 damage, could you give me an idea or solutions, pls.:-?
 

nnaveli

Member level 2
Joined
Jun 18, 2013
Messages
49
Helped
5
Reputation
10
Reaction score
5
Trophy points
1,288
Activity points
1,531
hi, i think your prob is on the sensing circuit,try changing resistors to low tolerence and consider temperature change may affect sen circuits.the design also locate heat producing component and add maybe a cooling fan ,good luck
 

poweraces

Member level 3
Joined
Jan 28, 2013
Messages
61
Helped
7
Reputation
14
Reaction score
7
Trophy points
1,288
Activity points
1,601
hi try to replace the Adjustable Micropower Voltage Regulators...i done this many times..hope it helps
 

boydacks23

Newbie level 1
Joined
Jul 8, 2013
Messages
1
Helped
0
Reputation
0
Reaction score
0
Trophy points
1
Activity points
3
sir I think we have the same problem sir.
 

ALERTLINKS

Advanced Member level 4
Joined
Dec 13, 2003
Messages
1,259
Helped
395
Reputation
784
Reaction score
379
Trophy points
1,363
Location
Pakistan
Activity points
7,263
If there ae some variable resistors, change them with new ones.
 

Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top