Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Any experience about pre-route delay calculation & Astro

Status
Not open for further replies.

w1yu77

Newbie level 3
Joined
Apr 7, 2010
Messages
3
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,309
I think this question may be more suitable for this board.

I'm a beginner user of Astro. Just after placement, I outputed timing report, and also exported SPEF file. I found an interesting problem regarding the interconnect delay calculation, i.e. for a simple one-sink net, the delay is not calculated with the Elmore algorithm! Below I attach the net, and ask for the reason. What's algorithm is used in Astro for delay calculation (the timing model has been set to "low effort")?

Spef:
*D_NET U_MMC_FIFO_RX/n170 0.0013153
*CONN
*I U_MMC_FIFO_RX/U15:A I *L 0.0046250 *C 1336.66 1296.71
*I U_MMC_FIFO_RX/U23:Y O *L 0.0000000 *C 1329.49 1292.55 *D XOR2XL
*CAP
0 U_MMC_FIFO_RX/U15:A 0.0002449
1 U_MMC_FIFO_RX/U23:Y 0.0004127
2 U_MMC_FIFO_RX/n170:3 0.0006576
*RES
0 U_MMC_FIFO_RX/U23:Y U_MMC_FIFO_RX/n170:3 0.0122671
1 U_MMC_FIFO_RX/n170:3 U_MMC_FIFO_RX/U15:A 0.0112291
*END
With Elmore, the delay should be:
Delay=(0.0046250+0.0002449+0.0006576)*0.0122671+(0.0046250+0.0002449)*0.0112291
=0 .0001224 ns

But in timing report, the net delay is 0.4739 ps.

What's the reason?

Many thanks!
 

Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top