Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

[SOLVED] Altium - get traces to take on net of connected copper

Status
Not open for further replies.

Jester

Full Member level 6
Joined
Aug 18, 2012
Messages
377
Helped
7
Reputation
14
Reaction score
7
Trophy points
1,298
Location
.
Activity points
4,754
I'm wondering if there is an easier way to do this:

Situation:

I have a circuit that is complete in both the schematic and PCB. I now want to clone this.

If I do a copy and paste of the schematic the designators for the clone are all set to _1, so no problem select them and reset them and then assign new designators.

I can also clone the PCB layout aspect, when I pull in the netlist I can then replace the cloned footprints with the actual ones however the connected copper does not take on the new net assignments forcing me to now replace the existing cloned traces. This method is faster and more consistent than starting from scratch, however I'm guessing there must be a better way?

Any hints?
 

SHABU

Advanced Member level 4
Joined
Feb 29, 2012
Messages
118
Helped
29
Reputation
58
Reaction score
27
Trophy points
1,308
Location
INDIA
Activity points
1,860
Hi,

Refer the attached documentation. This will solve your Issue.

Shabu
 

Attachments

  • Online Documentation for Altium Products - Client_Pnl-Snippets((Snippets))_AD - 2013-12-30.pdf
    421.4 KB · Views: 12
  • Like
Reactions: Jester

    Jester

    Points: 2
    Helpful Answer Positive Rating

Jester

Full Member level 6
Joined
Aug 18, 2012
Messages
377
Helped
7
Reputation
14
Reaction score
7
Trophy points
1,298
Location
.
Activity points
4,754
Hi,

Refer the attached documentation. This will solve your Issue.

Shabu

Shabu,

I tried the snippet method and it acts just like a copy and paste, except the designators are not reset. I did fine the solution though....Configure physical nets, works like magic, what a great program:)
 
Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top