Continue to Site

Welcome to

Welcome to our site! is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

ADS 2015 design kit problems

Not open for further replies.

M. Spock

Newbie level 5
Apr 2, 2015
Reaction score
Trophy points
Activity points
I've been a long time user of ADS 2008 and the Murata LC design kit. It worked well. We just recently (finally) upgraded to ADS 2015.01 and I installed the new Murata DK that requires the new format. When using the optimizer I immediately found a problem.

When you set the component nominal, min, and max values to optimize over they get lost as soon as you close the dialog box. That is, when you set them and then re-edit the component all the values are set back to defaults. The value field never shows up either, only the part numbers. This makes the DK virtually unusable.

Has anyone else noticed this or know of a fix? I've not yet contacted Agilent.


On this type of component based on real parts you cannot change the components value or any other intrinsic parameter for the device. A 10pF capacitor for example will always be 10pF (+/- a toleratnce range) but can never have a different nominal value. You can change or swap the component to a different available nominal value though. These library parts are set up to do descrete optimization exactly for this circumstance.

When you want to do optimization edit the PartNumber parameter to be "Discrete Optimize setting" (at the bottom of the list). Once that is set you can then set the Nominal, Minimum and Maximum Value components from the same style part number list. So for example the nominal could be the 10pF part with min and max set to 4.7pF and 22pF respectively. Discrete optimization with now select the component from the available values between 4.7pF and 22pF that gives the 'best' results.

Thanks for replying. Sorry, I must not have been clear about what I'm doing.

When setting up a component optimization you set the Parameter Entry Mode to Discrete Optimize setting, then set the Nominal Value to something that is between the Minimum Value and Maximum value that you think is best. The optimizer then tries to find the best (nominal) value that is between the Minimum and Maximum. All good there.

The problem I have is that once I setup these component parameters they don't "stick". When I setup the value and click OK (or apply) and then close the dialog box the values are all back to defaults when I try and edit the part again. Additionally several of the parameters in the big left box don't fill in. In the case of a Murata inductor I'm talking about the Type, Size, Value, and Tolerance. Only the part number updates, but then reverts back to all defaults when I re-edit the component.

The more I think about this it reminds me of my early experiences with Windows 8 and file permissions. In W8 an administrator does not, buy default, have full modify privileges. If you edited files in a program folder they would not really change. You have to right click the top folder, go to the security tab, and give yourself full modify privileges to make edits stick.

I'm running windows 10 (its the same in this regard), so I better check this...

I confirmed this problem exists in no matter what I do. The AVX design kit does it too. Windows 7 and 10 both do it. Its not a lack of administration rights or file/directory permissions.

Looks like a bug in ADS 2015.01. Guess I have to contact Keysight support.

I would contact MuRata before Keysight. The issue is more likely a consequence of the Design Kit rather that the platform. In normal operation the parameter values you are concerned with, Type, Value, Tolerance, RatedCurrent and FreqRange, are values displayed in the schematic but not used for simulation (there are not in the netlist). These values appear to be extracted by a parameter callback from the PartNumber parameter form values. When you select a part the list shows a comma separated string and it is these entriesonce separated that are output against the displayed parameters.

I suspect that this callback either works correctly for the normal constant form (single) values for the PartNumber parameter but was not implemented correctly for the current release of ADS (post ADS 2011) to be able to read an appropriate value when the discrete optimization compound form is selected and simply outputs empty values or was implemented to only show empty values when the discrete optimization compound form is selected.

FYI to anyone else who experiences this ADS problem. It was fixed in ADS2015 HotFix release 1. However they only half fixed it. It runs, but there are problems. The schematic is now full of unnecessary ugly text. Not happy.

Not open for further replies.

Part and Inventory Search

Welcome to