+ Post New Thread
Results 1 to 8 of 8
  1. #1
    Newbie level 3
    Points: 207, Level: 2

    Join Date
    Dec 2018
    Posts
    3
    Helped
    0 / 0
    Points
    207
    Level
    2

    LM5642 buck converter not work

    Hello to all !
    getting some info from AN1292 (Texas application for LM5642 ),I made dc-dc converter to use at a solar controller. At test with no load the converter not work . no output, no pulses 200khz to drive mosfets. it seems to be disable ( on/ss pins below 2volts ). I was checked hardware for errors many times , but I don't find something. The measurements shows that ic is ok , but something disable output. Any idea for possible reasons ?AN1292-LM5642 EVAL. BOARD.pdfLM5642.pdf

    •   AltAdvertisement

        
       

  2. #2
    Super Moderator
    Points: 80,117, Level: 69
    Achievements:
    7 years registered
    Awards:
    Most Frequent Poster 3rd Helpful Member

    Join Date
    Apr 2014
    Posts
    16,261
    Helped
    3686 / 3686
    Points
    80,117
    Level
    69

    Re: LM5642 buck converter not work

    Hi,

    Dataheet says:
    PCB Layout Considerations
    To produce an optimal power solution with the LM5642 series, good layout and design of the PCB are as
    important as the component selection. The following are several guidelines to aid in creating a good layout.
    ...and a lot more on page #28.

    Thus, please show us your PCB layout and give the exact partnames (type, vendor) of the critical parts.
    Additional photos could be helpful, too.

    Klaus
    Please don´t contact me via PM, because there is no time to respond to them. No friend requests. Thank you.



  3. #3
    Super Moderator
    Points: 53,441, Level: 56

    Join Date
    Apr 2011
    Location
    Minneapolis, Minnesota, USA
    Posts
    13,052
    Helped
    2598 / 2598
    Points
    53,441
    Level
    56

    Re: LM5642 buck converter not work

    Quote Originally Posted by SILVESTROS9 View Post
    At test with no load the converter not work.
    Sometimes a load is needed in order to get any sort of normal operation. Try a resistive load whose value draws 5 or 10 percent of your intended current.



    •   AltAdvertisement

        
       

  4. #4
    Newbie level 3
    Points: 207, Level: 2

    Join Date
    Dec 2018
    Posts
    3
    Helped
    0 / 0
    Points
    207
    Level
    2

    Re: LM5642 buck converter not work

    no output with a light load. pcb was replicated from AN1292 Texas application.
    below are some components that I use in demo board.

    LM5642 , TEXAS INSTR. vendor FARNELL code : 8181772
    PSMN4R5-40BS , NEXPERIA vendor FARNELL, code : 2114728
    RLF12560T-4R2N100 , TDK vendor FARNELL , code : 1669981

    Click image for larger version. 

Name:	LM5642-PCB-DEMO-1.png 
Views:	3 
Size:	301.6 KB 
ID:	156760



  5. #5
    Super Moderator
    Points: 80,117, Level: 69
    Achievements:
    7 years registered
    Awards:
    Most Frequent Poster 3rd Helpful Member

    Join Date
    Apr 2014
    Posts
    16,261
    Helped
    3686 / 3686
    Points
    80,117
    Level
    69

    Re: LM5642 buck converter not work

    Hi,

    so you used the eval-board?

    and you modified it?

    Why not step by step modify it back until it works again?

    Klaus
    Please don´t contact me via PM, because there is no time to respond to them. No friend requests. Thank you.



  6. #6
    Super Moderator
    Points: 263,643, Level: 100
    Awards:
    1st Helpful Member

    Join Date
    Jan 2008
    Location
    Bochum, Germany
    Posts
    46,001
    Helped
    13989 / 13989
    Points
    263,643
    Level
    100

    Re: LM5642 buck converter not work

    Connection of KSx and Ilimx is wrong in your schematic. Probably only a drawing error.

    As your measurement shows, the chip is hold in shutdown. May be due to previous OVP or UVP fault.


    1 members found this post helpful.

    •   AltAdvertisement

        
       

  7. #7
    Newbie level 3
    Points: 207, Level: 2

    Join Date
    Dec 2018
    Posts
    3
    Helped
    0 / 0
    Points
    207
    Level
    2

    Re: LM5642 buck converter not work

    its a drawing error. my doubt remains ..according to block diagram there is a delay to OVP, UVP ..a possible reason is mosfets bad drive . I check mosfets for damage but nothing found. I replace them , but chip remains in shutdown. maybe inductance of power inductors are wrong. unfortunately Texas Webench Power Designer not support LM5642 for simulation. I think that the only way to find something is the simulation...is there some simulator that can do that ?



  8. #8
    Super Moderator
    Points: 53,441, Level: 56

    Join Date
    Apr 2011
    Location
    Minneapolis, Minnesota, USA
    Posts
    13,052
    Helped
    2598 / 2598
    Points
    53,441
    Level
    56

    Re: LM5642 buck converter not work

    Your schematic appears to be twin interleaved, buck type, synchronous operated.

    Try starting out with a single basic buck converter. Use just one mosfet and one diode (asynchronous operation). See if your control IC operates properly. If it does, then add another section of your design.

    At 200 kHz your smoothing capacitor can be 1 uF. (It reaches output voltage fast as compared to your values totaling 2,000 uF).

    If you get no output, then try driving the mosfet manually from a pulse generator. Gate voltage needs to reach more than 12V, so that it can turn on an N-device at the high side (N-device placed close to positive rail).



--[[ ]]--