Greetings ... tell you that a couple of days ago I have a project in Vivado 2017.3, which correctly implemented it from the cygwin terminal with a python script using Vivado 2017.3.
Now the problem I have is that I can't implement the same project using Vivado 2018.3. I already tried to follow the recommendation of the following link https://www.xilinx.com/support/answers/70668.html but I still have the same error shown in the attached image.

Click image for larger version. 

Name:	imp_error.png 
Views:	8 
Size:	129.7 KB 
ID:	155097

Can someone please help me solve this problem. I leave the python script (implement.py) attached.