+ Post New Thread
Results 1 to 7 of 7
  1. #1
    Newbie level 1
    Points: 39, Level: 1

    Join Date
    Jul 2019
    Posts
    3
    Helped
    0 / 0
    Points
    39
    Level
    1

    LM741 Amplifier not working with IR2110 IC [PROTUES]

    Im trying to amplify arduino output for Mosfet gate driver, but whenever I connect to Output terminal to amplifier the HI pin doesnot accept amplifier output idk why. But when I connect arduino directly with the HI pin, the small flash light about it blinks and it shows output too. Also when I connect amplifier with a voltmeter, its shows the input is amplified but it doesnt work with HI pin when i connect to it.Please help me determine the issue here. Circuit shown below.

    Click image for larger version. 

Name:	Screenshot (81).png 
Views:	18 
Size:	62.0 KB 
ID:	154476

    •   AltAdvertisement

        
       

  2. #2
    Super Moderator
    Points: 29,644, Level: 41
    andre_teprom's Avatar
    Join Date
    Nov 2006
    Location
    Brazil
    Posts
    8,863
    Helped
    1115 / 1115
    Points
    29,644
    Level
    41
    Blog Entries
    9

    Re: LM741 Amplifier not working with IR2110 IC [PROTUES]

    With the above value at VDD of IR2110, the HIN pin allows input varying from approximately 0v to 12v, but the 741 has differential supplies ranging from -10v to +10v.
    --------------------------------------------------------------------------------------------------
    Part of the world that you live in, You are the part that you're giving ( Renaissance )



  3. #3
    Advanced Member level 5
    Points: 39,762, Level: 48

    Join Date
    Mar 2008
    Location
    USA
    Posts
    6,423
    Helped
    1876 / 1876
    Points
    39,762
    Level
    48

    Re: LM741 Amplifier not working with IR2110 IC [PROTUES]

    I think you'd be much better off with a simple level-shifter
    logic gate (believe IR2110 accepts standard 5V "TTL" inputs).

    Op amp like 741 will have very slow output slew rate and
    there might be some issues with that. Driving a "100nS"
    part with a "10uS" risetime is asking for trouble especially
    when you have close-coupled, high dV/dt, high dI/dt
    goings-on. Although Schmitt inputs are depicted, there
    is no mention of attributes (hysteresis, or min input dV/dt
    or max risetime).



    •   AltAdvertisement

        
       

  4. #4
    Super Moderator
    Points: 77,851, Level: 68
    Achievements:
    7 years registered
    Awards:
    Most Frequent Poster 3rd Helpful Member

    Join Date
    Apr 2014
    Posts
    15,774
    Helped
    3592 / 3592
    Points
    77,851
    Level
    68

    Re: LM741 Amplifier not working with IR2110 IC [PROTUES]

    Hi,

    The arduino output is "digital", and so is the IR2110 input.
    But the Opamp is an "analog" circuit.
    Don't mix analog and digital this way.

    The circuit simply is not suitable.

    Why do you try to re invent the wheel (while you don't have the knowledge for it ) ... why don't you use one of the thousands (or millions) proven circuits you can find here in the forum and in the internet?

    The most reliable informations with a lot of explanations ( in datasheets, application notes) you will find at the semiconductor manufacturers.
    For example they tell you what capacitors and diodes to use (and why not to use electrolytics capacitors and 1N4007)


    Klaus
    Please don´t contact me via PM, because there is no time to respond to them. No friend requests. Thank you.



  5. #5
    Super Moderator
    Points: 260,253, Level: 100
    Awards:
    1st Helpful Member

    Join Date
    Jan 2008
    Location
    Bochum, Germany
    Posts
    45,445
    Helped
    13828 / 13828
    Points
    260,253
    Level
    100

    Re: LM741 Amplifier not working with IR2110 IC [PROTUES]

    The design fault is to connect VDD to 12V, with 5V supply, the IR2110 logic inputs can be driven by processor signals directly.



    •   AltAdvertisement

        
       

  6. #6
    Member level 3
    Points: 1,989, Level: 10
    Achievements:
    7 years registered

    Join Date
    May 2010
    Location
    Coimbatore, Tamil Nadu, India
    Posts
    65
    Helped
    6 / 6
    Points
    1,989
    Level
    10

    Re: LM741 Amplifier not working with IR2110 IC [PROTUES]

    Hi,
    what is the maximum duty cycle of the drive signal from arduino?
    first you have to turn on the low side MOSFET in order allow the bootstrap capacitor to charge and then only it will work properly.



  7. #7
    Super Moderator
    Points: 260,253, Level: 100
    Awards:
    1st Helpful Member

    Join Date
    Jan 2008
    Location
    Bochum, Germany
    Posts
    45,445
    Helped
    13828 / 13828
    Points
    260,253
    Level
    100

    Re: LM741 Amplifier not working with IR2110 IC [PROTUES]

    Something between 95 and 99%. There's no big advantage of increasing it above 95%.



--[[ ]]--