+ Post New Thread
Results 1 to 19 of 19
  1. #1
    Full Member level 4
    Points: 885, Level: 6

    Join Date
    May 2019
    Location
    Roskilde, Denmark
    Posts
    199
    Helped
    9 / 9
    Points
    885
    Level
    6

    Simple Power Supply with Noise Problems

    Hi Friends,

    I've got this simple power supply with clean sinusoidal input, but after the bridge rectifier some noise is introduced and I have no idea why, maybe you have some suggestions?

    As you can see on the left there is a bog standard ZVS driver running at about 40KHz and two secondary windings with bridge rectifier and a smoothing cap on the output..

    Click image for larger version. 

Name:	hv-supply.png 
Views:	31 
Size:	12.8 KB 
ID:	153605

    Here is the output of the secondary winding

    Click image for larger version. 

Name:	SDS00053.PNG 
Views:	11 
Size:	55.8 KB 
ID:	153608

    Here is the output noise of the positive side

    Click image for larger version. 

Name:	SDS00049.PNG 
Views:	25 
Size:	38.6 KB 
ID:	153606

    Here is a closer look at the peak noise

    Click image for larger version. 

Name:	SDS00050.PNG 
Views:	17 
Size:	26.7 KB 
ID:	153607

  2. #2
    Super Moderator
    Points: 29,544, Level: 41
    andre_teprom's Avatar
    Join Date
    Nov 2006
    Location
    Brazil
    Posts
    8,813
    Helped
    1114 / 1114
    Points
    29,544
    Level
    41
    Blog Entries
    9

    Re: Simple Power Supply with Noise Problems

    It seems a perfectly plausible artifact considering the presence of inductors and capacitors at the output stage performing a tank circuit capable of sustaining an oscillation during the recharge of the capacitors. By the way, it would be more clarifying if you added some resistive load to the output, so you would see how much that ringing 'noise' would remain in the face of the peak current in the capacitor recharge (ripple) in the secondary side of transformer.
    --------------------------------------------------------------------------------------------------
    Part of the world that you live in, You are the part that you're giving ( Renaissance )



  3. #3
    Full Member level 4
    Points: 885, Level: 6

    Join Date
    May 2019
    Location
    Roskilde, Denmark
    Posts
    199
    Helped
    9 / 9
    Points
    885
    Level
    6

    Re: Simple Power Supply with Noise Problems

    Hi Andre!

    Thank you for your reply.

    Quote Originally Posted by andre_teprom View Post
    It seems a perfectly plausible artifact considering the presence of inductors and capacitors at the output stage performing a tank circuit capable of sustaining an oscillation during the recharge of the capacitors.
    So you are saying this is normal? Is there anything I could try to diminish it? e.g. larger caps, other diodes?

    Quote Originally Posted by andre_teprom View Post
    By the way, it would be more clarifying if you added some resistive load to the output, so you would see how much that ringing 'noise' would remain in the face of the peak current in the capacitor recharge (ripple) in the secondary side of transformer.
    Yes you are right, I used a resistive voltage divider (1Meg/1K) to measure the output voltage, would that qualify as a resistve load in this context?



    •   AltAdvertisement

        
       

  4. #4
    Super Moderator
    Points: 29,544, Level: 41
    andre_teprom's Avatar
    Join Date
    Nov 2006
    Location
    Brazil
    Posts
    8,813
    Helped
    1114 / 1114
    Points
    29,544
    Level
    41
    Blog Entries
    9

    Re: Simple Power Supply with Noise Problems

    Even for 600Vdc, 1MΩ is almost no load in the context of a power supply (360mW) for that magnitude. Add something not greater than 10KΩ at the output stage, or even smaller; this would make waveforms more realistic during circuit working under normal operation. Anyway, I would agree with you that increasing capacitances would somehow attenuate these spikes.
    --------------------------------------------------------------------------------------------------
    Part of the world that you live in, You are the part that you're giving ( Renaissance )


    1 members found this post helpful.

  5. #5
    Advanced Member level 3
    Points: 5,477, Level: 17

    Join Date
    Feb 2014
    Posts
    776
    Helped
    253 / 253
    Points
    5,477
    Level
    17

    Re: Simple Power Supply with Noise Problems

    The noise is at 40khz and your switching is at 40khz so it's switching noise correct?

    First figure out of its 'real' by tying your scope probe to ground and see if its scope noise or common mode pickup.

    If not then try more/better capcitors, diode snubbers, and/or a post LC filter.


    1 members found this post helpful.

    •   AltAdvertisement

        
       

  6. #6
    Advanced Member level 5
    Points: 9,879, Level: 23

    Join Date
    Aug 2015
    Posts
    1,613
    Helped
    579 / 579
    Points
    9,879
    Level
    23

    Re: Simple Power Supply with Noise Problems

    Yup the noise is at 40kHz intervals - so it is switching noise - most likely from the o/p diodes - put snubbers across all.

    - - - Updated - - -

    yes - those diodes are 300nS recovery - so they carry reverse current when they turn off - they are really designed for lower frequencies than 40kHz, I see you have tried to mitigate this with a sine wave source - however they will need snubbers - or use faster & better 600V diodes - now with smaller snubbers ...


    1 members found this post helpful.

    •   AltAdvertisement

        
       

  7. #7
    Full Member level 4
    Points: 885, Level: 6

    Join Date
    May 2019
    Location
    Roskilde, Denmark
    Posts
    199
    Helped
    9 / 9
    Points
    885
    Level
    6

    Re: Simple Power Supply with Noise Problems

    Quote Originally Posted by asdf44 View Post
    The noise is at 40khz and your switching is at 40khz so it's switching noise correct?

    First figure out of its 'real' by tying your scope probe to ground and see if its scope noise or common mode pickup.

    If not then try more/better capcitors, diode snubbers, and/or a post LC filter.
    Hi asdf44!

    The noise is 'real' - grounding does nothing.

    I tried doubling up on the caps - does nothing special.

    Changed diodes to UF1007 which have 75nS Trr - that reduced noise amplitude with about 60% at 1Mohm load.
    Click image for larger version. 

Name:	SDS00187.PNG 
Views:	5 
Size:	24.7 KB 
ID:	153619

    I will try with some diode snubbers now, would a couple of nF be fine?

    - - - Updated - - -

    Quote Originally Posted by Easy peasy View Post
    Yup the noise is at 40kHz intervals - so it is switching noise - most likely from the o/p diodes - put snubbers across all.

    - - - Updated - - -

    yes - those diodes are 300nS recovery - so they carry reverse current when they turn off - they are really designed for lower frequencies than 40kHz, I see you have tried to mitigate this with a sine wave source - however they will need snubbers - or use faster & better 600V diodes - now with smaller snubbers ...
    Hi Easy peasy!

    I did as you and asdf44 suggested, please see my post #7.



  8. #8
    Advanced Member level 5
    Points: 9,879, Level: 23

    Join Date
    Aug 2015
    Posts
    1,613
    Helped
    579 / 579
    Points
    9,879
    Level
    23

    Re: Simple Power Supply with Noise Problems

    at a guess 330ohm and 220pF ( 1 or 2kV ) across each diode.

    a small LC post filter will do a lot to remove noise too ... esp for a low C choke ...



  9. #9
    Full Member level 4
    Points: 885, Level: 6

    Join Date
    May 2019
    Location
    Roskilde, Denmark
    Posts
    199
    Helped
    9 / 9
    Points
    885
    Level
    6

    Re: Simple Power Supply with Noise Problems

    Quote Originally Posted by Easy peasy View Post
    at a guess 330ohm and 220pF ( 1 or 2kV ) across each diode.

    a small LC post filter will do a lot to remove noise too ... esp for a low C choke ...
    Hi Easy peasy!

    On the diodes, tried with 1nf up to 22nf - but could not register any significant change.

    LC filter, in the uF HV range I only had a 50uF/800V so I tried that in combination with several different coils just to see if any change could be registered e.g. 50uF/10mH I get Fc=7KHz, but no significant change could be registered.



  10. #10
    Advanced Member level 3
    Points: 5,477, Level: 17

    Join Date
    Feb 2014
    Posts
    776
    Helped
    253 / 253
    Points
    5,477
    Level
    17

    Re: Simple Power Supply with Noise Problems

    Wait, let's be really clear. When you say "The noise is 'real' - grounding does nothing" does that mean you still saw the noise after grounding the probe tip?

    I meant you should leave your probe ground connected and clip or touch the probe to its own ground lead. This should obviously show a perfect 0V. If you still see noise then its scope pickup and isn't actually on your output. The scope pickup may be worth trying to solve...but its a different problem.



  11. #11
    Full Member level 4
    Points: 885, Level: 6

    Join Date
    May 2019
    Location
    Roskilde, Denmark
    Posts
    199
    Helped
    9 / 9
    Points
    885
    Level
    6

    Re: Simple Power Supply with Noise Problems

    Quote Originally Posted by asdf44 View Post
    Wait, let's be really clear. When you say "The noise is 'real' - grounding does nothing" does that mean you still saw the noise after grounding the probe tip?

    I meant you should leave your probe ground connected and clip or touch the probe to its own ground lead. This should obviously show a perfect 0V. If you still see noise then its scope pickup and isn't actually on your output. The scope pickup may be worth trying to solve...but its a different problem.
    Hi asdf44!

    I think I misunderstood what you said, I thought you meant 'ground' as in 'earth'. My mind was elsewhere as I have been blowing up half a dozen of scope power supplies while working with HV, the galvanic isolation was non-existent (but now I'm using a separation trafo).

    Anyway I did as you said, and the noise is now 'unreal'. I still see noise, bit different wave form but same amplitude, when connecting the the probe to it's ground clip.



  12. #12
    Advanced Member level 5
    Points: 9,879, Level: 23

    Join Date
    Aug 2015
    Posts
    1,613
    Helped
    579 / 579
    Points
    9,879
    Level
    23

    Re: Simple Power Supply with Noise Problems

    LC filter, in the uF HV range I only had a 50uF/800V so I tried that in combination with several different coils just to see if any change could be registered e.g. 50uF/10mH I get Fc=7KHz, but no significant change could be registered.
    this likely means that you are picking up only CM noise on your scope - taking noise measurements at low levels is an art, try looping your scope probe as many times as you can thru a high mu toroid - this will reduce CM pickup ...

    using caps only as a snubber is counter productive ...

    - - - Updated - - -

    for a post filter you need a low capacitance choke - say 100uH, and a low ESR/ESL cap ( i.e. no long leads ) to get attenuation at the noise freq, say 220nF, film/foil.


    1 members found this post helpful.

  13. #13
    Full Member level 4
    Points: 885, Level: 6

    Join Date
    May 2019
    Location
    Roskilde, Denmark
    Posts
    199
    Helped
    9 / 9
    Points
    885
    Level
    6

    Re: Simple Power Supply with Noise Problems

    Quote Originally Posted by Easy peasy View Post
    this likely means that you are picking up only CM noise on your scope - taking noise measurements at low levels is an art, try looping your scope probe as many times as you can thru a high mu toroid - this will reduce CM pickup ...
    "taking noise measurements at low levels is an art" - yes indeed, and taking measurements at high levels is also an art of a different kind, and performing both at the same time is black magic I have a little hi mu toroid, so I will try your suggestion.

    Quote Originally Posted by Easy peasy View Post
    for a post filter you need a low capacitance choke - say 100uH, and a low ESR/ESL cap ( i.e. no long leads ) to get attenuation at the noise freq, say 220nF, film/foil.
    Will try that too, thank you very much. This calculator says Fc=34KHz with the suggested values (R=10k) would that be correct?

    Quote Originally Posted by Easy peasy View Post
    using caps only as a snubber is counter productive ...
    In this context or generally? because I see many technical documents with caps only 'snubbers'.



  14. #14
    Advanced Member level 5
    Points: 9,879, Level: 23

    Join Date
    Aug 2015
    Posts
    1,613
    Helped
    579 / 579
    Points
    9,879
    Level
    23

    Re: Simple Power Supply with Noise Problems

    1) "at low levels of noise" esp in the presence of CM radiation

    2) not good to believe everything you stumble across on the internet -

    3) generally, and refer to 2) above.


    1 members found this post helpful.

  15. #15
    Advanced Member level 5
    Points: 32,316, Level: 43
    Achievements:
    7 years registered

    Join Date
    Sep 2008
    Location
    cambridge
    Posts
    6,732
    Helped
    488 / 488
    Points
    32,316
    Level
    43

    Re: Simple Power Supply with Noise Problems

    i think OP has problem with "pickup" in his scope lead, as many others here have suggested.
    You can use a coaxial probe (you have to make it yourself), which doesnt have the ground clip.

    When i worked at a major telco company, 4 graduates were given a "tail chasing" job where they were asked to solve the pickup problem on a power supply .......they were led to believe that the pickup was noise that was "infecting" the microcontrollers...and told to solve the pickup...they couldnt solve it, as they kept using the "dangling gnd clip" probe.

    After a full 2 days, the gaffer went back to them and told them it was just "pickup" and that he had just wanted to make them look stupid for 2 days.



  16. #16
    Full Member level 4
    Points: 885, Level: 6

    Join Date
    May 2019
    Location
    Roskilde, Denmark
    Posts
    199
    Helped
    9 / 9
    Points
    885
    Level
    6

    Re: Simple Power Supply with Noise Problems

    Hi treez.

    Quote Originally Posted by treez View Post
    i think OP has problem with "pickup" in his scope lead, as many others here have suggested.
    You can use a coaxial probe (you have to make it yourself), which doesnt have the ground clip.
    That sounds interesting, but I couldn't find any pertinent refs on the interwebs to the "coaxial probe" other than "open ended coaxial probes" is that what you mean?


    1 members found this post helpful.

    •   AltAdvertisement

        
       

  17. #17
    Advanced Member level 5
    Points: 32,316, Level: 43
    Achievements:
    7 years registered

    Join Date
    Sep 2008
    Location
    cambridge
    Posts
    6,732
    Helped
    488 / 488
    Points
    32,316
    Level
    43

    Re: Simple Power Supply with Noise Problems

    coaxial probe is just a piece of coaxial cable, with a BNC connector on one end, and the other end you splay out to get you the ground and centre conductor to solder to your circuit.

    You usually have to buy it as a pice of 1 metre (or so) coax with a BNC at each end...you then cut one BNC off, and then roll the gnd conductor into a wire so you can solder it.

    Its a home made kind of thing



  18. #18
    Full Member level 2
    Points: 1,919, Level: 10

    Join Date
    Feb 2014
    Location
    Russia
    Posts
    136
    Helped
    73 / 73
    Points
    1,919
    Level
    10

    Re: Simple Power Supply with Noise Problems

    to remove noise pickup use probe with spring https://electronics.stackexchange.co...f-oscilloscope



  19. #19
    Full Member level 4
    Points: 885, Level: 6

    Join Date
    May 2019
    Location
    Roskilde, Denmark
    Posts
    199
    Helped
    9 / 9
    Points
    885
    Level
    6

    Re: Simple Power Supply with Noise Problems

    Quote Originally Posted by Velkarn View Post
    to remove noise pickup use probe with spring https://electronics.stackexchange.co...f-oscilloscope
    Hi Velkarn

    Thank it's nice, perhaps that was also the intention with treez's coax suggestion i.e. minimizing ground loop.



--[[ ]]--