+ Post New Thread
Results 1 to 4 of 4
  1. #1
    Newbie level 5
    Points: 48, Level: 1

    Join Date
    Apr 2019
    Posts
    9
    Helped
    0 / 0
    Points
    48
    Level
    1

    Impedance matching in ADS encountering error!

    I'm trying to do the impedance matching of a rectifier. However, it always show

    ERROR: (stdcmds.ael line 282, column 5)
    Error generating netlist for "MyFirstWorkspace_lib:cell_1:schematic": Failed to create netlist:
    There is no corresponding terminal for `P1' in the netlisted view `MyFirstWorkspace_lib:DA_LCEllMatch_cell_1:schemat icClick image for larger version. 

Name:	捕获.JPG 
Views:	11 
Size:	106.4 KB 
ID:	152235

    What is P1? There is no P1 in the picture! How to solve this problem? Is there any reference for doing impedance matching for rectifer by ADS? Thanks

    •   AltAdvertisment

        
       

  2. #2
    Member level 1
    Points: 791, Level: 6

    Join Date
    Jan 2016
    Posts
    35
    Helped
    3 / 3
    Points
    791
    Level
    6

    Re: Impedance matching in ADS encountering error!

    I'm having exactly the same question... What the hell is P1?



    •   AltAdvertisment

        
       

  3. #3
    Advanced Member level 5
    Points: 12,926, Level: 27

    Join Date
    Apr 2014
    Posts
    2,000
    Helped
    817 / 817
    Points
    12,926
    Level
    27

    Re: Impedance matching in ADS encountering error!

    From the symbol at the nodes, you can see that the diode model is not properly connected in schematic. Not sure why - user mistake or possibly mistake in definition of the symbol, but anyway: there is no connection.

    Regarding possibly unconnected nets, have a look at the netlist: Simulate > Generate Netlist

    P1: I think this is required for impedance matching, you need to have an S-parameter simulation and corresponding "Term" element defined for the input port. That is missing in your schematic.



    •   AltAdvertisment

        
       

  4. #4
    Advanced Member level 5
    Points: 28,991, Level: 41
    BigBoss's Avatar
    Join Date
    Nov 2001
    Location
    Turkey
    Posts
    4,201
    Helped
    1270 / 1270
    Points
    28,991
    Level
    41

    Re: Impedance matching in ADS encountering error!

    There are few errors..
    Diodes are connected as "Models" not Diodes, therefore They don't have Pins to be connected.. Change them with Diodes..
    There is no simulation controller as I see..
    Matching circuit here has no sense at all because your Vsin Generator hasn't any Internal Impedance.Instead, you should use Psin Generator with Internal Impedance for both small signal simulations and transient simulations.



--[[ ]]--