+ Post New Thread
Results 1 to 4 of 4
  1. #1
    Junior Member level 2
    Points: 262, Level: 3

    Join Date
    Apr 2018
    Posts
    23
    Helped
    0 / 0
    Points
    262
    Level
    3

    EM model Harmonic balance simulation

    I simulate a single balanced mixer in ADS and i am using harmonic balance for gain.
    At the output i have a low pass filter.
    When i simulate the mixer with "ideal filter" (lumped element filter) everything seems ok. But when i draw the layout of the filter and then i create the EM model, I insert the model in the schematic and the gain is much more different. Why is this happening?
    When i simulate only the 2 filters with s-parameters simulation the results are quite close.

    RF,LO freq: 5-8 GHz
    IF freq: 200Mhz-1.2 Ghz
    Filter: Low pass cut off frequency 1.2 GHz

    •   AltAdvertisement

        
       

  2. #2
    Advanced Member level 5
    Points: 30,659, Level: 42
    BigBoss's Avatar
    Join Date
    Nov 2001
    Location
    Turkey
    Posts
    4,494
    Helped
    1355 / 1355
    Points
    30,659
    Level
    42

    Re: EM model Harmonic balance simulation

    The loss maybe higher than expected or there may be a mismatch between filter and the circuit.
    Have you ever checked the practical filter with its layout ( Momentum+Components) ?



    •   AltAdvertisement

        
       

  3. #3
    Junior Member level 2
    Points: 262, Level: 3

    Join Date
    Apr 2018
    Posts
    23
    Helped
    0 / 0
    Points
    262
    Level
    3

    Re: EM model Harmonic balance simulation

    Yes i create the em model and i put the capacitors and inductors that i use and for the filter alone the s parameters simulation is almost the same with thefilter with only components!
    when i do the harmonic balance simulation i see a problem in the gain



    •   AltAdvertisement

        
       

  4. #4
    Advanced Member level 5
    Points: 14,284, Level: 28

    Join Date
    Apr 2014
    Posts
    2,239
    Helped
    894 / 894
    Points
    14,284
    Level
    28

    Re: EM model Harmonic balance simulation

    Quote Originally Posted by Kooky613 View Post
    and then i create the EM model, I insert the model in the schematic and the gain is much more different. Why is this happening?
    It seems that something is wrong with your EM simulation. In your EM setup, have you included frequency range down to DC, and up to the harmonics that you specify in HB?



--[[ ]]--