+ Post New Thread
Results 1 to 5 of 5
  1. #1
    Newbie level 3
    Points: 1,640, Level: 9
    Achievements:
    7 years registered

    Join Date
    Aug 2009
    Location
    brežice
    Posts
    3
    Helped
    0 / 0
    Points
    1,640
    Level
    9

    SIMCOM SIM808 - Network registration denied problem

    Hello,
    I have problems with ma SIM808 GSM/GPS module. I have a custom made PCB where i am using SIM808 module to send some data to my web server.
    I have produced around 100 pcs of PCB.
    On a few pieces of PCB i have a problem that after some period of time (6 months - 1 year), the module can not (or it is very hard, must reset few times or wait for few minutes) register to the GSM network anymore.
    -I have put module to fully functional mode AT+CFUN=1,
    -modul can not go to sleep mode AT+CSCLK=0,
    -sim card is detected and no password need: AT+CPIN: READY,
    -gsm signal is OK: AT+CSQ: 14,0.

    After i power on the module, module starts to search for the operator (AT+CREG: 0,2) after 1 or 2 minutes module stops searching for a network and go to state Registration denied (AT+CREG: 0,3).
    Even if some times the module still manage to register to the network it lost GSM registration after a few minutes (NETLIGHT led is start blinking fast).
    -I have measured voltage levels on sim card and it seems to be stable:
    SIM_VDD: 1,8V
    SIM_RST: 1,8V
    SIM_CLK: 0V
    SIM:DATA: 1,79V

    I have 2.8V level on RX/TX lines UART communication.

    I really have any other idea what should be wrong.
    If anybody had some kind of the same problems with this simcom module i would be really great full if it can help me to solve this problem.
    Thank you guys for any kind of help.

    •   AltAdvertisment

        
       

  2. #2
    Super Moderator
    Points: 27,344, Level: 40
    andre_teprom's Avatar
    Join Date
    Nov 2006
    Location
    Brazil
    Posts
    8,182
    Helped
    1034 / 1034
    Points
    27,344
    Level
    40
    Blog Entries
    5

    Re: SIMCOM SIM808 - Network registration denied problem

    Did you see this thread that mentions location constraints regarding the module release? In some countries, IMEIs that are not approved by the local telecommunication agency are blocked to register: https://www.edaboard.com/showthread....ration-problem

    Anyway, I think your problem may be more related to the data plan of your SIMcard in the mobile telephony company, is it really activated?

    In addition, are you using this application to test the Modem?
    http://m2msupport.net/m2msupport/dow...ommand-tester/
    --------------------------------------------------------------------------------------------------
    Part of the world that you live in, You are the part that you're giving ( Renaissance )



    •   AltAdvertisment

        
       

  3. #3
    Newbie level 3
    Points: 1,640, Level: 9
    Achievements:
    7 years registered

    Join Date
    Aug 2009
    Location
    brežice
    Posts
    3
    Helped
    0 / 0
    Points
    1,640
    Level
    9

    Re: SIMCOM SIM808 - Network registration denied problem

    I have tried sim cards from two different operators and nothing helps...
    Very strange thing to me is that, sometimes module manage to register to the network. Yesterday it could connect in any way but today the module is connecting pretty normal few times but then again it did not manage to connect. An anotther strange thing is that, the device worked for 1,5 year without any problems...

    I have contact mobile operator about blacklisting my IMEI and they send me an answer that the did not blacklist my IMEI and that device should register to their GSM network.
    For the power supply i am using 2.5A DC-DC switching regulator. Very near the VBAT pins of the module i have one electrolit 220uF capacitor and one 100nF ceramic capacitor.
    Do you think i should add another one small capacitor to prevent more high frequency noise?
    What about the RF pin? should i also add some small capacitor? (30pF)?



    •   AltAdvertisment

        
       

  4. #4
    Super Moderator
    Points: 27,344, Level: 40
    andre_teprom's Avatar
    Join Date
    Nov 2006
    Location
    Brazil
    Posts
    8,182
    Helped
    1034 / 1034
    Points
    27,344
    Level
    40
    Blog Entries
    5

    Re: SIMCOM SIM808 - Network registration denied problem

    I believe the problem is related to the registering process. I have dealt with a system that not rarely worked only in the morning, and with enormeous difficulty in the afternoon, even with the signal of the antenna being Ok, and nobody was able to find out the why in the whole lifetime of the product.

    Anyway, some of the most common tips to, at least, work around that issue are:
    • Upgrade firmware to an up to date version
    • Deactivate/Activate SIM card
    • Send an AT command to reboot system (or just restart power)

    At the time this error happens, did you check if there are still any operator available? (AT+COPS=?) or if the operators available are the same when the module worked fine ?
    --------------------------------------------------------------------------------------------------
    Part of the world that you live in, You are the part that you're giving ( Renaissance )



  5. #5
    Newbie level 3
    Points: 1,640, Level: 9
    Achievements:
    7 years registered

    Join Date
    Aug 2009
    Location
    brežice
    Posts
    3
    Helped
    0 / 0
    Points
    1,640
    Level
    9

    Re: SIMCOM SIM808 - Network registration denied problem

    The problem is that, this device is already a production made product and i don't have debug USB connector to upgrade firmware of the module?
    Do you know if it possible to upgrade firmware of the module through my micro controller UART connection?
    When the module does not register (AT+CREG: 0,3), command AT+COPS=? returns nothing, but i didn't try what does this command return when module is registered to the network.
    I am in the area where GSM network is very good, so when the module can not register AT+CSQ command return me 14, 0 and when the module register to the network AT+CSQ command returns me 24,0 (full signal quality).
    Well i am starting to believe that this is all happening because the lack of the quality of this simcom modules and it would be better to buy some more expensive module which is stable (telit)...



--[[ ]]--