+ Post New Thread
Results 1 to 10 of 10
  1. #1
    Member level 2
    Points: 1,072, Level: 7

    Join Date
    Oct 2013
    Posts
    45
    Helped
    2 / 2
    Points
    1,072
    Level
    7

    Puzzled by OPA and output noise

    Hi, all
    I use OPA376 and OPA344 to build a two stage high-pass non-inverting amplifier circuit, and a 4th low-pass filter.
    I made a two layers PCB. All the signals and Powers is on the top layer, the bottom layer is a ground plane.
    In this PCB Layout, the purple trace(20 mils) is power line. Two stage high-pass non-inverting amplifier circuit is located at the top side of the board. The 4th low-pass filter is located at the right of the board.
    Something I should mention is that: there is no ground plane on the top layer.

    Problem 1
    I use TINA to simulate the total noise output of the circuit.
    The result shows:
    1.the total noise of OPA376 at 20MEG-Hz is 296uVrms.
    2.the total noise of OPA344 at 20MEG-Hz is 458uVrms.

    Then, I use the oscilloscope(Rigol DS1054) to measure the circuit (AC test, Bandwidth is 0~20MEG Hz, measure the first stage high-pass non-inverting amplifier's output).
    The result shows:
    1.the output of OPA376 is 10.7mVrms and 34.1mVp_p.
    2.the output of OPA344 is 1.08mVrms and 3.92mVp_p.

    I think that the difference between simulation and measurement maybe caused by the Test equipment and the environment.
    But Why the output of OPA376 is much larger than OPA344's in the test? It doesn't make sense...

    Problem 2
    a.
    I found that when I put my finger close to the first stage high-pass non-inverting amplifier, the 50Hz noise on my output of the first stage increase significantly.
    I guess that phenomenon is caused by R1(4.7M ohm), so I used a 10 ohm resistor instead of 4.7M for R1. Then I tested it again, I can rarely see the 50Hz noise.
    b.
    I have did second test(R1 = 4.7M ohm): I connect a wire(0.5mm^2) to my PCB ground. When I held the copper of the wire, the 50Hz Noise reduced significantly.
    Does it mean that my PCB ground connect to the earth ground through my body, and 50Hz noise bypassed?
    In my thought: 50Hz noise comes from the space, and this 50Hz noise induce current or voltage on R1.
    If PCB ground does not connect to the earth ground through my body, then the induced current or voltage will go into OPA.
    Finally the 50Hz noise will return to the earth ground through the capacitor between PCB and the earth ground. Am I right?
    If PCB ground connectto the earth ground through my body, then a small part of the induced current and voltage will go into OPA, other part will return to the earth ground through my body directly. Am I right?
    But how does the induce current or voltage on R1 go to my PCB ground directly, not through OPA? Where is the return path?
    How can I explain this phenomenon systemly and clearly?
    How to use some model to explain this Phenomenon?
    How to find the return path of the 50Hz Noise?
    To be honest, I am puzzled.

    c.
    I have did third test(R1 = 4.7MEG ohm): I touch the bottom layer which is under the first stage high-pass non-inverting amplifier, 50Hz noise does not increase.
    Does it mean that I should use some conductor to enclose the sensitive circuit?
    Click image for larger version. 

Name:	OPA344_Noise.PNG 
Views:	13 
Size:	59.1 KB 
ID:	147220
    Click image for larger version. 

Name:	OPA376_Noise.PNG 
Views:	7 
Size:	71.8 KB 
ID:	147221
    Click image for larger version. 

Name:	Top_Layer.png 
Views:	7 
Size:	59.0 KB 
ID:	147222
    Click image for larger version. 

Name:	Bottom_Layer.png 
Views:	3 
Size:	29.0 KB 
ID:	147223

    •   AltAdvertisment

        
       

  2. #2
    Super Moderator
    Points: 65,813, Level: 62
    Achievements:
    7 years registered
    Awards:
    Most Frequent Poster 3rd Helpful Member

    Join Date
    Apr 2014
    Posts
    13,386
    Helped
    3090 / 3090
    Points
    65,813
    Level
    62

    Re: Puzzled by OPA and output noise

    Hi,

    1.the output of OPA376 is 10.7mVrms and 34.1mVp_p.
    The values show: Itīs not dominated by random noise, but by a single sinewave. What you see is influenced externally, that isnīt included in the TINA simulation.
    PP-value for single pure sinewave: 10.7mV x 2 x sqrt(2) = 30.3mV
    If there is a second frequency with just 5.5mV RMS you already are at the 34.1mVpp

    ***
    I donīt understand the concept of your design at all. I see some issues:
    * Why do you use the "noisy" OPA344 at the first stage. And the lownoise ones later. You need to use the lowest noise OPAMP at the first stage.
    * R1 noise: I see no use of R1 = 4.7M. It just acts to decrease overall performance.: Increase in noise, decrease frequency response, increase offset.... --> short circuit it or use 100 Ohms.
    * R1 high impedance: The high impedance at the non inverting input of the first OPAMP stage makes it prone to pick up any noise around. --> short circuit it or use 100 Ohms.
    * C1: From the size it seems this is a ceramic capacitor. Every noise generated by this capacitor will degrade overall performance. Ceramic capacitors have piezo effect, this means they act as microphones, they pick up mechanical and acoustic noise. --> replace it with a foil capacitor. Or modify the circuit in a way that you can omit it at all.
    * the same applies for C3, but has minor influence on overall performance.
    * For best performance all capacitors in the signal path should be foil type.

    ***

    * C1 noise pickup test: use a scope to measure the output signal: Then use a plastic stick (pencil) and slightly knock on the PCB with it.

    I assume your extra wire to the PCB_GND has more mechanical influence (to reduce vibration) than electrical. But for a detailed analysis we need to see a photo of your thest circuit.

    Klaus
    Please donīt contact me via PM, because there is no time to respond to them. No friend requests. Thank you.


    1 members found this post helpful.

  3. #3
    Member level 2
    Points: 1,072, Level: 7

    Join Date
    Oct 2013
    Posts
    45
    Helped
    2 / 2
    Points
    1,072
    Level
    7

    Re: Puzzled by OPA and output noise

    Quote Originally Posted by KlausST View Post
    Hi,


    The values show: Itīs not dominated by random noise, but by a single sinewave. What you see is influenced externally, that isnīt included in the TINA simulation.
    PP-value for single pure sinewave: 10.7mV x 2 x sqrt(2) = 30.3mV
    If there is a second frequency with just 5.5mV RMS you already are at the 34.1mVpp

    ***
    I donīt understand the concept of your design at all. I see some issues:
    * Why do you use the "noisy" OPA344 at the first stage. And the lownoise ones later. You need to use the lowest noise OPAMP at the first stage.
    * R1 noise: I see no use of R1 = 4.7M. It just acts to decrease overall performance.: Increase in noise, decrease frequency response, increase offset.... --> short circuit it or use 100 Ohms.
    * R1 high impedance: The high impedance at the non inverting input of the first OPAMP stage makes it prone to pick up any noise around. --> short circuit it or use 100 Ohms.
    * C1: From the size it seems this is a ceramic capacitor. Every noise generated by this capacitor will degrade overall performance. Ceramic capacitors have piezo effect, this means they act as microphones, they pick up mechanical and acoustic noise. --> replace it with a foil capacitor. Or modify the circuit in a way that you can omit it at all.
    * the same applies for C3, but has minor influence on overall performance.
    * For best performance all capacitors in the signal path should be foil type.

    ***

    * C1 noise pickup test: use a scope to measure the output signal: Then use a plastic stick (pencil) and slightly knock on the PCB with it.

    I assume your extra wire to the PCB_GND has more mechanical influence (to reduce vibration) than electrical. But for a detailed analysis we need to see a photo of your thest circuit.

    Klaus
    Hi, Klaus

    Picture 1 is my PCB.
    Picture 2 is the first stage OPAMP circuit.
    Picture 3 shows that I use the scope probe to measure the output of the first OPAMP.
    Picture 4,5,6 shows the output of the first stage OPAMP, OPAMP is OPA379.
    Picture 7 shows the output of the first stage OPAMP, OPAMP is OPA344.

    In Picture 2, VG2 and C4 is my sensor's output model. So in this first stage, I have to use a large resistor just like R1(4.7M ohm).
    Here in my all test, the sensor has not be connected.
    I konw that I should use OPA376 at the first stage. Why I use OPA344 in the first stage is that I find OPA376's output is much much larger than the simulation, so i'd like to see if I use the "noisy" OPA344, how the output looks like.
    In Picture 4 and 5, you see OPA376's output is 10mVrms. I can't find some specific frequency in it. So I think this is not reasonable.
    In picture 7, you see OPA344's ouput is 1.12mVrms. I can find 50Hz frequency signal. So I think it's much more reasonable.
    But I still can't find out why OPA376's output is more noisy. Do you have any ideas?

    I have did the C1 noise pickup test. you are rihgt. When I use a pencil to knock the PCB, I can see a small spark in the output signal.
    This PCB is designed for a wearable equipment, the space of PCB is limited. So I have to choose small size caps. Do you have any advice?
    I can find less information about foil capacitors, would you like to recommend me some details about foil capacitors?

    Click image for larger version. 

Name:	Picture 1.jpg 
Views:	5 
Size:	37.1 KB 
ID:	147346Click image for larger version. 

Name:	Picture 2.png 
Views:	4 
Size:	15.1 KB 
ID:	147347Click image for larger version. 

Name:	Picture 3.png 
Views:	4 
Size:	298.4 KB 
ID:	147348
    Click image for larger version. 

Name:	Picture 4.jpg 
Views:	4 
Size:	38.0 KB 
ID:	147349Click image for larger version. 

Name:	Picture 5.jpg 
Views:	3 
Size:	46.6 KB 
ID:	147350
    Click image for larger version. 

Name:	Picture 7.jpg 
Views:	6 
Size:	58.9 KB 
ID:	147351



    •   AltAdvertisment

        
       

  4. #4
    Super Moderator
    Points: 248,053, Level: 100
    Awards:
    1st Helpful Member

    Join Date
    Jan 2008
    Location
    Bochum, Germany
    Posts
    43,142
    Helped
    13126 / 13126
    Points
    248,053
    Level
    100

    Re: Puzzled by OPA and output noise

    The waveform count doesn't fit, only 6 rather than 7 images attached.

    What's connected in place of VG2, a ground short?


    Are the OPA344 and OPA376 setups identical in each regard?


    Why are you measuring input noise with 20MHz bandwidth although the used signal bandwidth is < 1 kHz?


    1 members found this post helpful.

    •   AltAdvertisment

        
       

  5. #5
    Super Moderator
    Points: 65,813, Level: 62
    Achievements:
    7 years registered
    Awards:
    Most Frequent Poster 3rd Helpful Member

    Join Date
    Apr 2014
    Posts
    13,386
    Helped
    3090 / 3090
    Points
    65,813
    Level
    62

    Re: Puzzled by OPA and output noise

    Hi,

    in addition to what FvM wrote:

    So I have to choose small size caps. Do you have any advice?
    if you want to use ceramic capacitors then a 3 side milling cut around the capacitor will reduce, but not avoid this "mechanically generated noise".
    Or use COG ceramics only.

    I can find less information about foil capacitors, would you like to recommend me some details about foil capacitors?
    All detailed informations about a film capacitor will fill a book.
    Film capacitors donīt suffer from the piezoelectirc effect.

    Klaus
    Please donīt contact me via PM, because there is no time to respond to them. No friend requests. Thank you.


    1 members found this post helpful.

  6. #6
    Member level 2
    Points: 1,072, Level: 7

    Join Date
    Oct 2013
    Posts
    45
    Helped
    2 / 2
    Points
    1,072
    Level
    7

    Re: Puzzled by OPA and output noise

    Quote Originally Posted by FvM View Post
    The waveform count doesn't fit, only 6 rather than 7 images attached.

    What's connected in place of VG2, a ground short?


    Are the OPA344 and OPA376 setups identical in each regard?


    Why are you measuring input noise with 20MHz bandwidth although the used signal bandwidth is < 1 kHz?

    Hi, FvM

    Thank you for reply!

    I connected sensor positve input to the PCB-GND. But it doesn't be connected to the V+ of the first stage OPAMP. I'm sorry for the missing information of schematic. Please see picture 8, R19 is not connected.

    I used one board to do the test. I just change the IC(OPA376 & OPA344) on this board, so I think the condition is same.

    I still can't find out what makes the huge deferent performance between OPA376 and OPA344 on my PCB, But I'm still trying to find it out, it's a very interesting thing.

    I used scope to measure the output of the first stage OPAMP with 20MHz bandwidth limitation, so I think I will see the noise within 20MHz. Then I measure the noise with 20MHz in the simulation. I'm not sure whether my opinion is right or not?

    I think maybe I should talk about Problem 1 first here, and picture 1,2,3,4,5,7 are related to Problem 1. So I haven't posted picture 6. I'm sorry for that I haven't explained it before.

    Please check picture 6 here. Picture 6 shows the waveform when I putted my finger close to R1(4.7M ohm), the 50Hz noise incresed significantly on the output of the first stage OPAMP(OPA376).

    I'm going to buy some copper foil in order to enclose my board. I'm not sure whether this method would work or not. So do you have any advice? Please see Picture 9.

    Click image for larger version. 

Name:	Picture 8.png 
Views:	5 
Size:	19.5 KB 
ID:	147363
    Click image for larger version. 

Name:	Picture 9.png 
Views:	2 
Size:	125.5 KB 
ID:	147364



  7. #7
    Advanced Member level 5
    Points: 37,044, Level: 47

    Join Date
    Mar 2008
    Location
    USA
    Posts
    5,978
    Helped
    1732 / 1732
    Points
    37,044
    Level
    47

    Re: Puzzled by OPA and output noise

    If you care about microvolts of noise then I'd be powering
    the article off a battery stack, and probably testing within
    a copper box grounded to the 'scope (maybe even use an
    op amp gain block located with the article, to boost signal
    before your 50/50Hz ambient steps all over it).

    A spectrum analyzer would be a good way to look at things
    (once you get enough gain / buffering to drive a 50-ohm
    load without ruining operation). The impinging frequencies
    will stand out so you can identify them, maybe mitigate.
    Some 'scope have a FFT capability if you don't have a
    spectrum analyzer.


    1 members found this post helpful.

  8. #8
    Super Moderator
    Points: 65,813, Level: 62
    Achievements:
    7 years registered
    Awards:
    Most Frequent Poster 3rd Helpful Member

    Join Date
    Apr 2014
    Posts
    13,386
    Helped
    3090 / 3090
    Points
    65,813
    Level
    62

    Re: Puzzled by OPA and output noise

    Hi,

    Please see picture 8, R19 is not connected.
    Then the input of the Opamp is very high impedance and prone to pick up any noise around.
    For further tests I recommend to short (AC) this node to GND with the shown series capacitor.

    I used one board to do the test. I just change the IC(OPA376 & OPA344) on this board, so I think the condition is same.
    With your high impedance input ... any solder residuals my harm the test result regarding noise.
    I recommend to use ultrasonic cleaning, wait until the PCB has room temperature (not still hot from soldering) and power them up for several minutes before you start the test.

    If you're interested in 1kHz bandwidth only, then install an appropriate RC low pass filter. As well for the test as for the real application.

    Copper foil: First do your tests with the capacitor to GND, this will decrease 50Hz input impedance by a factor of 40. ... and thus reduce noise pickup.

    Klaus
    Please donīt contact me via PM, because there is no time to respond to them. No friend requests. Thank you.


    1 members found this post helpful.

  9. #9
    Member level 2
    Points: 1,072, Level: 7

    Join Date
    Oct 2013
    Posts
    45
    Helped
    2 / 2
    Points
    1,072
    Level
    7

    Re: Puzzled by OPA and output noise

    Quote Originally Posted by KlausST View Post
    Hi,

    in addition to what FvM wrote:


    if you want to use ceramic capacitors then a 3 side milling cut around the capacitor will reduce, but not avoid this "mechanically generated noise".
    Or use COG ceramics only.


    All detailed informations about a film capacitor will fill a book.
    Film capacitors donīt suffer from the piezoelectirc effect.

    Klaus
    Hi, Klaus

    Thank you for reply!

    I was on a business trip last week.

    I can't understand "3 side milling cut around the capacitor" in english, I know you want to tell me how to layout the PCB with the ceramic capacitors.

    Would you please show me some picture to let me understand what means "3 side milling cut around the capacitor"?

    Thank you so much!



    •   AltAdvertisment

        
       

  10. #10
    Super Moderator
    Points: 65,813, Level: 62
    Achievements:
    7 years registered
    Awards:
    Most Frequent Poster 3rd Helpful Member

    Join Date
    Apr 2014
    Posts
    13,386
    Helped
    3090 / 3090
    Points
    65,813
    Level
    62

    Re: Puzzled by OPA and output noise

    Hi,

    https://www.******.com/blog/Engineer...apacitors.html
    In figure 2 you see two slots.
    With a third slot you may further mechanically decouple the capacitor from the rest of the pcb.

    Klaus
    Please donīt contact me via PM, because there is no time to respond to them. No friend requests. Thank you.


    1 members found this post helpful.

--[[ ]]--