+ Post New Thread
Results 1 to 9 of 9
  1. #1
    Junior Member level 2
    Points: 398, Level: 4

    Join Date
    May 2016
    Posts
    20
    Helped
    1 / 1
    Points
    398
    Level
    4

    Problem using vpwlf with reference other than GND

    Hi everyone!

    I am using vpwlf as an arbitrary source in cadence. I simulated my circuit using this source without any problem. Then, to consider some parasitics, I added an inductance in series with GND. Now I get the error: "no such file or directory". I know the problem is using a reference for the vpwlf source other than GND, but I don't know how to solve it. Could anyone please help me?

    Thank you so much!

    •   Alt10th January 2018, 09:24

      advertising

        
       

  2. #2
    Advanced Member level 1
    Points: 4,850, Level: 16
    Achievements:
    7 years registered

    Join Date
    Feb 2008
    Posts
    462
    Helped
    153 / 153
    Points
    4,850
    Level
    16

    Re: Problem using vpwlf with reference other than GND

    Can you show your schematic or netlist?



  3. #3
    Junior Member level 2
    Points: 398, Level: 4

    Join Date
    May 2016
    Posts
    20
    Helped
    1 / 1
    Points
    398
    Level
    4

    Re: Problem using vpwlf with reference other than GND

    Thank you so much for answering Timof.

    "screenshot.png" shows the file which works without any problem. When I change it as "screenshot1.png" an error is shown saying no such file or directory. I tried wiring the negative node of the source to CHIP_GND directly. But nothing changed.

    Click image for larger version. 

Name:	screenshot.png 
Views:	9 
Size:	69.8 KB 
ID:	143882
    Click image for larger version. 

Name:	screenshot1.png 
Views:	11 
Size:	70.3 KB 
ID:	143883



    •   Alt10th January 2018, 23:22

      advertising

        
       

  4. #4
    Advanced Member level 1
    Points: 4,850, Level: 16
    Achievements:
    7 years registered

    Join Date
    Feb 2008
    Posts
    462
    Helped
    153 / 153
    Points
    4,850
    Level
    16

    Re: Problem using vpwlf with reference other than GND

    The snapshots seem to be identical...



    •   Alt11th January 2018, 00:10

      advertising

        
       

  5. #5
    Member level 4
    Points: 868, Level: 6

    Join Date
    Jun 2015
    Posts
    78
    Helped
    13 / 13
    Points
    868
    Level
    6

    Re: Problem using vpwlf with reference other than GND

    They are not identical.

    Your problem is pretty strange. Could you change the path of the voltage source from "(...)bit strings(...)" to "(...)bit_strings(...)" and try?



  6. #6
    Junior Member level 2
    Points: 398, Level: 4

    Join Date
    May 2016
    Posts
    20
    Helped
    1 / 1
    Points
    398
    Level
    4

    Re: Problem using vpwlf with reference other than GND

    Thank you for answering t4_v.

    It didn't work. I agree that it's strange! Maybe because I'm using an old version. Have you ever used this source with reference other than GND?



  7. #7
    Member level 4
    Points: 868, Level: 6

    Join Date
    Jun 2015
    Posts
    78
    Helped
    13 / 13
    Points
    868
    Level
    6

    Re: Problem using vpwlf with reference other than GND

    That's does not calculate. You delete gnd symbol and connect nodes by "CHIP_GND" and the error is "no such file or directory"?



    •   Alt11th January 2018, 18:04

      advertising

        
       

  8. #8
    Advanced Member level 1
    Points: 4,850, Level: 16
    Achievements:
    7 years registered

    Join Date
    Feb 2008
    Posts
    462
    Helped
    153 / 153
    Points
    4,850
    Level
    16

    Re: Problem using vpwlf with reference other than GND

    Maybe this might help?:

    Cadence seems to read the PWL file at
    the instance that the schematic is saved
    – So if you generate a new PWL file, then you
    need to resave your schematic before starting
    a new simulation.



  9. #9
    Advanced Member level 5
    Points: 35,658, Level: 46

    Join Date
    Mar 2008
    Location
    USA
    Posts
    5,728
    Helped
    1659 / 1659
    Points
    35,658
    Level
    46

    Re: Problem using vpwlf with reference other than GND

    The error ought to include information on -which- file or
    directory is not found. Perhaps it is indeed about the
    vpwlf. But -what- about that element, is a question.
    Maybe the schematic ended up in a different library
    and relative path to the vpwlf file was used, now
    busted, or something.

    You could let the vpwlf be ground referred and use
    vcvs to impose the same voltage anywhere you like,
    if it truly relates to topology and not filesystem.



--[[ ]]--