+ Post New Thread
Results 1 to 5 of 5
  1. #1
    Full Member level 2
    Points: 1,313, Level: 8

    Join Date
    Nov 2014
    Location
    Saudi Arabia
    Posts
    120
    Helped
    0 / 0
    Points
    1,313
    Level
    8

    74LS10 3-input NAND gate not working!

    I was working on my project with logic, sequential and combinational ICs.

    And, wanted to test the 74LS10 3-input NAND gate and it wasn't working!!

    All other ICs are working, NOR, 2-input NAND, counter, 555 timer.

    I've other 74LS10, if they all not working then I'd combine 2-input NAND and one AND gates to get 3-input NAND gate.

    I just want to know why it's not working?

    •   AltAdvertisment

        
       

  2. #2
    Super Moderator
    Points: 251,556, Level: 100
    Awards:
    1st Helpful Member

    Join Date
    Jan 2008
    Location
    Bochum, Germany
    Posts
    43,804
    Helped
    13320 / 13320
    Points
    251,556
    Level
    100

    Re: 74LS10 3-input NAND gate not working!

    Wrong pin mapping?



    •   AltAdvertisment

        
       

  3. #3
    Full Member level 2
    Points: 1,313, Level: 8

    Join Date
    Nov 2014
    Location
    Saudi Arabia
    Posts
    120
    Helped
    0 / 0
    Points
    1,313
    Level
    8

    Re: 74LS10 3-input NAND gate not working!

    Quote Originally Posted by FvM View Post
    Wrong pin mapping?
    It should run on default, and provide 5V on every output pin.

    As the 2-input NAND gate, it have 5V default on output pins.

    And the inverter is the same principle.



    •   AltAdvertisment

        
       

  4. #4
    Super Moderator
    Points: 69,598, Level: 64
    Achievements:
    7 years registered
    Awards:
    Most Frequent Poster 3rd Helpful Member

    Join Date
    Apr 2014
    Posts
    14,212
    Helped
    3248 / 3248
    Points
    69,598
    Level
    64

    Re: 74LS10 3-input NAND gate not working!

    HI,

    * schematic?
    * input signals?
    * output signals?

    Klaus



  5. #5
    Advanced Member level 5
    Points: 15,446, Level: 29

    Join Date
    Nov 2012
    Posts
    2,844
    Helped
    674 / 674
    Points
    15,446
    Level
    29

    Re: 74LS10 3-input NAND gate not working!

    Try with another IC? Perhaps this one has gone bad?



--[[ ]]--