+ Post New Thread
Results 1 to 5 of 5
  1. #1
    Full Member level 3
    Points: 1,745, Level: 9

    Join Date
    Nov 2014
    Location
    Saudi Arabia
    Posts
    176
    Helped
    1 / 1
    Points
    1,745
    Level
    9

    74LS10 3-input NAND gate not working!

    I was working on my project with logic, sequential and combinational ICs.

    And, wanted to test the 74LS10 3-input NAND gate and it wasn't working!!

    All other ICs are working, NOR, 2-input NAND, counter, 555 timer.

    I've other 74LS10, if they all not working then I'd combine 2-input NAND and one AND gates to get 3-input NAND gate.

    I just want to know why it's not working?

    •   AltAdvertisement

        
       

  2. #2
    Super Moderator
    Points: 264,236, Level: 100
    Awards:
    1st Helpful Member

    Join Date
    Jan 2008
    Location
    Bochum, Germany
    Posts
    46,168
    Helped
    14041 / 14041
    Points
    264,236
    Level
    100

    Re: 74LS10 3-input NAND gate not working!

    Wrong pin mapping?



    •   AltAdvertisement

        
       

  3. #3
    Full Member level 3
    Points: 1,745, Level: 9

    Join Date
    Nov 2014
    Location
    Saudi Arabia
    Posts
    176
    Helped
    1 / 1
    Points
    1,745
    Level
    9

    Re: 74LS10 3-input NAND gate not working!

    Quote Originally Posted by FvM View Post
    Wrong pin mapping?
    It should run on default, and provide 5V on every output pin.

    As the 2-input NAND gate, it have 5V default on output pins.

    And the inverter is the same principle.



    •   AltAdvertisement

        
       

  4. #4
    Super Moderator
    Points: 81,102, Level: 69
    Achievements:
    7 years registered
    Awards:
    Most Frequent Poster 3rd Helpful Member

    Join Date
    Apr 2014
    Posts
    16,449
    Helped
    3731 / 3731
    Points
    81,102
    Level
    69

    Re: 74LS10 3-input NAND gate not working!

    HI,

    * schematic?
    * input signals?
    * output signals?

    Klaus



  5. #5
    Advanced Member level 5
    Points: 18,454, Level: 32
    Achievements:
    7 years registered

    Join Date
    Nov 2012
    Posts
    3,269
    Helped
    816 / 816
    Points
    18,454
    Level
    32

    Re: 74LS10 3-input NAND gate not working!

    Try with another IC? Perhaps this one has gone bad?



--[[ ]]--