+ Post New Thread
Results 1 to 6 of 6
  1. #1
    Full Member level 5
    Points: 3,276, Level: 13

    Join Date
    Jan 2005
    Location
    Asia
    Posts
    311
    Helped
    23 / 23
    Points
    3,276
    Level
    13

    Oscillator troubles !

    Its been almost 2 weeks ,
    7 posts ,
    9 different designs ,
    But ...i am still unable to make my oscillator Oscillate.

    So anyone here with a tested circuit for 12 Mhz Crystal Oscillator ?
    Can some one help me troubleshoot ?

    Tell me what can be wrong ?

    I tested each component,its all fine.

    Transistors are biased properly and feedback is proper too.

    SOME ONE PLEASE HELP !!!! I am stuck over here for my whole project.

    In the mean time ..i'll keep trying.
    Goodbye !!!

    •   AltAdvertisement

        
       

  2. #2
    Member level 3
    Points: 1,812, Level: 9

    Join Date
    Sep 2004
    Posts
    55
    Helped
    0 / 0
    Points
    1,812
    Level
    9

    Re: Oscillator troubles !

    can u post your schematics up so we can see what is wrong with your oscillator?



    •   AltAdvertisement

        
       

  3. #3
    Full Member level 5
    Points: 3,276, Level: 13

    Join Date
    Jan 2005
    Location
    Asia
    Posts
    311
    Helped
    23 / 23
    Points
    3,276
    Level
    13

    Re: Oscillator troubles !

    Actually i've tried many schematics but i am not able to get oscillaotions and i think i have a common problem in all.
    Anyways...i'll attaching one schematic for you !

    Thanks !bye



    •   AltAdvertisement

        
       

  4. #4
    Advanced Member level 1
    Points: 4,719, Level: 16

    Join Date
    Sep 2004
    Posts
    461
    Helped
    103 / 103
    Points
    4,719
    Level
    16

    Re: Oscillator troubles !

    I do not have rar.
    post your schematic as picture/pdf/zip and include also what simulator you are using + options for analysis + analysis type, schematic of xtal model - in other words some more info would help.

    Oscillators take some time to buildup oscillation. (see other posts about XOSC) .
    Run simulation at least for 20ms or more.
    Add small current spike at the beginning of simulation to kick-start it.
    and do not give up. And as bonus - even that it works in simulator does not mean that works on silicon :)



  5. #5
    Advanced Member level 5
    Points: 12,565, Level: 26
    Borber's Avatar
    Join Date
    Jan 2000
    Location
    on third flor
    Posts
    1,602
    Helped
    240 / 240
    Points
    12,565
    Level
    26

    Re: Oscillator troubles !

    Place 30p-50p capacitor between base of transistor and ground. Place 10n capacitor accross emiter resistor.



    •   AltAdvertisement

        
       

  6. #6
    Advanced Member level 5
    Points: 74,061, Level: 66

    Join Date
    Oct 2004
    Location
    West Coast
    Posts
    7,942
    Helped
    2329 / 2329
    Points
    74,061
    Level
    66

    Re: Oscillator troubles !

    Remove 100pF from collector LC-tank and put it between base and 0V.

    And for more info here is a link to a site on how to design pierce oscillator:
    http://pr.erau.edu/~lyallj/ee412/pierce_exp.html



--[[ ]]--