+ Post New Thread
Results 1 to 2 of 2
  1. #1
    Newbie level 2
    Points: 27, Level: 1

    Join Date
    Nov 2015
    Posts
    2
    Helped
    0 / 0
    Points
    27
    Level
    1

    CST EXport Macro not working

    Hi everyone,
    I'm simulating an antenna in CST and I want to export the results of a planar near field scan to a text file in order to read it with Matlab. To do so, I've set up a field monitor( e-field (f=2;z=10) ) on the desired plane and I don't have any problem exporting the results manually once the simulation has finished (Post Processing\Exchange\Import/Export\Plot Data (ASCII). However I'm trying to do this automatically with a script running the following Macro

    Click image for larger version. 

Name:	Captura.PNG 
Views:	45 
Size:	139.0 KB 
ID:	123429

    As you can see it gives me an error and I don't have any idea why I get this. Can somebody explain me how can I fix this? If I try to export any other result, like the e-field of the port modes it works, so I don't understand what's happening.
    Thanks

    •   AltAdvertisment

        
       

  2. #2
    Newbie level 2
    Points: 27, Level: 1

    Join Date
    Nov 2015
    Posts
    2
    Helped
    0 / 0
    Points
    27
    Level
    1

    Re: CST EXport Macro not working

    It turned out to be that I was typing the name of the tree item wrong. In my case there was a missing space between (f=2;z=10) and [1] which was difficult to see in the navigation tree. So it gave me that error because that command was doing nothing and after that, the macro was trying to use ASCII Export with another item selected ("Anchor points", as you can see in my picture). Although I managed to make it work, when CST exports the fields I only get zeros in all points. I don't know if I'm setting the parameters correctly. I also tried to export it manually with different values of Dx or Nx but I get the same zeros



--[[ ]]--