+ Post New Thread
Results 1 to 4 of 4
  1. #1
    Member level 1
    Points: 222, Level: 2

    Join Date
    Jan 2015
    Location
    coimbatore
    Posts
    34
    Helped
    1 / 1
    Points
    222
    Level
    2

    problem in lcd4bit...hardware

    hi..pic16f877a with lcd 16*2 ...program mplab(Hi-tech)compiler...program & simulation ..good...in hardware ..right checked..pin connection...right....with (d0-d3)GND...lcd4bit don't display any message...but lcd 8bit hardware working good...give reason...lcd 4bit

    •   AltAdvertisment

        
       

  2. #2
    Advanced Member level 3
    Points: 5,481, Level: 17

    Join Date
    Apr 2011
    Posts
    926
    Helped
    184 / 184
    Points
    5,481
    Level
    17

    Re: problem in lcd4bit...hardware

    http://extremeelectronics.co.in/micr...ller-tutorial/

    check your code and other thing make sure you have same pins in real hardware and simulations.
    Please marked the thread solved if your problem is answered it will take few seconds of you but saves lot of time for others to get answers for same problems..



    •   AltAdvertisment

        
       

  3. #3
    Banned
    Points: 1,100, Level: 7

    Join Date
    Jan 2013
    Location
    Chennai
    Posts
    110
    Helped
    100 / 100
    Points
    1,100
    Level
    7

    Re: problem in lcd4bit...hardware

    You can leave the data bits D0-D3 left unconnected. It is not necessary to connect it to ground.



    •   AltAdvertisment

        
       

  4. #4
    Member level 1
    Points: 222, Level: 2

    Join Date
    Jan 2015
    Location
    coimbatore
    Posts
    34
    Helped
    1 / 1
    Points
    222
    Level
    2

    Re: problem in lcd4bit...hardware

    ok...hardware don't show data..



--[[ ]]--