+ Post New Thread
Results 1 to 2 of 2
  1. #1
    Newbie level 3
    Points: 26, Level: 1

    Join Date
    Nov 2013
    Posts
    3
    Helped
    0 / 0
    Points
    26
    Level
    1

    [MOVED] Edge Not On Grid Error : (

    Hello all. I finished my layout for an inverter a couple of hours ago and ran DRC and LVS with no errors (they were successful).
    I then needed to make a layout for an xor gate which used two inverters. After I used the "pick from schematic" option, I instantly ran a DRC check, which then gave 228 "Edge not on grid" errors. I know that this error has something to do with the length and width of the rectangles I drew in my layout (something about having L or W that is a multiple of the technology I am using? may someone please explain?), I don't completely understand though, so an explanation or a link will be nice (I tried googling some the error, but I was not able to find something that was noob-friendly). I find it weird that I didn't get DRC errors in my inverter but I did get errors when that inverter was used in other schematics/layouts. Also whatever the error is, since I have 228 of them, should I redo the inverter? or is this error fixable?

    Thank you

    PS: I hope this is the right forum... Sorry if it is not.

    •   AltAdvertisement

        
       

  2. #2
    Newbie level 3
    Points: 26, Level: 1

    Join Date
    Nov 2013
    Posts
    3
    Helped
    0 / 0
    Points
    26
    Level
    1

    Re: [MOVED] Edge Not On Grid Error : (

    Ok, I figured it out. I redid the inverter but this time for some reason the DRS check kept giving me errors which I fixed one by one. I was then able to use my inverter in my other layouts (such as my xor layout that I mentioned in my previous post) with no DRS errors : ) I wonder if it was because I went to options->display and edited my major and minor spacing?



--[[ ]]--