+ Post New Thread
Results 1 to 3 of 3
  1. #1
    Full Member level 6
    Points: 3,598, Level: 14
    Achievements:
    Created Blog entry 7 years registered
    udhay_cit's Avatar
    Join Date
    May 2008
    Posts
    334
    Helped
    36 / 36
    Points
    3,598
    Level
    14
    Blog Entries
    1

    Help me USB to RS232/RS485 converter problem

    Dear friends,
    I am designing a multipurpose converter. we can configure it as follow
    1. USB to RS232
    2. USB to RS485 (4 Wire)
    3. USB to RS485 (2 Wire)
    4. RS232 to RS485 (4 Wire)
    5. RS232 to RS485 (2 Wire)

    USB to RS232 is working properly. Now my problem is when i use USB to RS485 (4wire) i am getting echo signal from RS485 terminal.
    When i connect a RS232 to RS485 converter externally, its working properly. Now i hope the problem comes from RS485 converter & more specifically from TX,RX selection pin(I don't know, it may be wrong).

    Here i attached the schematic diagram can anybody please give me an advise to solve this problem...
    Thanks in advance

    Regards
    Udhay

    •   AltAdvertisement

        
       

  2. #2
    Newbie level 2
    Points: 694, Level: 5

    Join Date
    Sep 2009
    Location
    Orlando, FL, USA
    Posts
    2
    Helped
    0 / 0
    Points
    694
    Level
    5

    Re: Help me USB to RS232/RS485 converter problem

    When you configure it for 4wire RS485, do you pull the Receiver-Enable for the RS485 tranceivers (your CBUS3) low constantly?
    Because if you do then you are enabling the receiver circuit of U4 which will then echo back whatever is sent.



    •   AltAdvertisement

        
       

  3. #3
    Full Member level 6
    Points: 3,598, Level: 14
    Achievements:
    Created Blog entry 7 years registered
    udhay_cit's Avatar
    Join Date
    May 2008
    Posts
    334
    Helped
    36 / 36
    Points
    3,598
    Level
    14
    Blog Entries
    1

    Re: Help me USB to RS232/RS485 converter problem

    Yes there is a 10k pull up resistor available for receive enable(CBUS3)...



--[[ ]]--