+ Post New Thread
Results 1 to 3 of 3
  1. #1
    Advanced Member level 2
    Points: 5,611, Level: 17
    Achievements:
    7 years registered

    Join Date
    Feb 2009
    Location
    some where left alone
    Posts
    667
    Helped
    136 / 136
    Points
    5,611
    Level
    17

    Unusual problem with atmega8

    dear experts
    a simple lcd interfacing code ,code was compiled with no errors and verified in proteus .
    my circuit
    vcc pin7 of atmega8
    gnd pin8 of atmega8
    internal crystal used
    then by mistakely i connected AVCC to gnd
    but lcd showed the text message after half mins my atmega8 was very hot ,i removed power supply and AVCC connected to VCC now it does not showed anything what is the problem ?my question is why lcd displayed test message even AVCC connected to the ground ?

    •   AltAdvertisment

        
       

  2. #2
    Banned
    Points: 23,048, Level: 36

    Join Date
    Dec 2012
    Location
    Bangalore, India
    Posts
    4,294
    Helped
    830 / 830
    Points
    23,048
    Level
    36

    Re: Unusual problem with atmega8

    AVCC is the VCC for ADC circuit. I think your ADC circuit is damaged if not the whole chip.



    •   AltAdvertisment

        
       

  3. #3
    Advanced Member level 2
    Points: 5,611, Level: 17
    Achievements:
    7 years registered

    Join Date
    Feb 2009
    Location
    some where left alone
    Posts
    667
    Helped
    136 / 136
    Points
    5,611
    Level
    17

    Re: Unusual problem with atmega8

    chip is damaged no doubt heated up in 10 secs



--[[ ]]--