+ Post New Thread
Results 1 to 3 of 3
  1. #1
    Full Member level 1
    Points: 1,338, Level: 8

    Join Date
    Apr 2011
    Location
    Chennai, Tamil Nadu, India
    Posts
    106
    Helped
    14 / 14
    Points
    1,338
    Level
    8

    Spartan 6 FPGA Configuration issue in BPI up mode

    Dear friends
    In my customized board with Spartan 6, FPGA is configured in BPI up mode. In the same bus, a NVSRAM also connected. while loading .mcs file to flash(1Gbit), programming become failed but CFI query, flash erase are succesfully completed.

    I programmed FPGA with .bin file and access the flash from processor.so that I can able to find that some sectors of the flash cannot be written. I was suspecting the Flash memmory and i changed with a 512Mbit flash. Both are spansion s29gl series. But the problem still exists.

    Consistently some sectors showing problem. and i verified the schematics and pcb connections and i cannot find any problem. Also i couldn't find any relation between the problem sectors.

    Plz help ...

    Thanks in advance.....

    •   AltAdvertisement

        
       

  2. #2
    Full Member level 2
    Points: 3,118, Level: 13

    Join Date
    May 2006
    Posts
    127
    Helped
    12 / 12
    Points
    3,118
    Level
    13

    Re: Spartan 6 FPGA Configuration issue in BPI up mode

    Looks like configuration mode setting is not proper, please check it.



    •   AltAdvertisement

        
       

  3. #3
    Full Member level 1
    Points: 1,338, Level: 8

    Join Date
    Apr 2011
    Location
    Chennai, Tamil Nadu, India
    Posts
    106
    Helped
    14 / 14
    Points
    1,338
    Level
    8

    Re: Spartan 6 FPGA Configuration issue in BPI up mode

    The issue has been closed. The Reset of flash has been not proper, due to the improper "out of reset" of flash will leads to false memory accessing.



--[[ ]]--