+ Post New Thread
Results 1 to 4 of 4
  1. #1
    Junior Member level 1
    Points: 1,011, Level: 7

    Join Date
    Mar 2008
    Posts
    15
    Helped
    0 / 0
    Points
    1,011
    Level
    7

    Capacitive feedback OTA Design Issues in Loop gain

    HI
    I have designed a capacitive feedback OTA ( OTA is folded cascode single stage OTA with ideal CMFB). When I simulate the loop gain of OTA (using iprobe and stb analysis in cadence) I get a 'High Pass' response at low frequencies.
    I am not sure why this is happening. Please help to solve this issue.

    Thanks

    •   AltAdvertisement

        
       

  2. #2
    Junior Member level 1
    Points: 1,011, Level: 7

    Join Date
    Mar 2008
    Posts
    15
    Helped
    0 / 0
    Points
    1,011
    Level
    7

    Re: Capacitive feedback OTA Design Issues in Loop gain

    Just want elaborate on this. When I did loop gain simulation at low frequency (till 100Hz ) gain was increasing and after that it settled down and started decreasing at pole frequency. This in all I am getting a band pass waveform. Also in the step response it settles down at 10nsec but after that it starts decreasing and picks up again,giving a undershoot. This phenomenon keeps on repeating. I am not sure why this is happning.
    Please help.

    Thanks



    •   AltAdvertisement

        
       

  3. #3
    Member level 5
    Points: 2,269, Level: 11

    Join Date
    May 2004
    Posts
    84
    Helped
    13 / 13
    Points
    2,269
    Level
    11

    Re: Capacitive feedback OTA Design Issues in Loop gain

    Could you post a quick schematic maybe? Is the open loop gain of your amplifier alone allright?



    •   AltAdvertisement

        
       

  4. #4
    Junior Member level 1
    Points: 1,011, Level: 7

    Join Date
    Mar 2008
    Posts
    15
    Helped
    0 / 0
    Points
    1,011
    Level
    7

    Re: Capacitive feedback OTA Design Issues in Loop gain

    Hi
    Fig1 shows the test bench used for loop gain simulation
    Fig2 shows the loop gain and fig3 shows the step response. I have following questions

    1. Why loop gain curve is not flat at the beginning? Theory shows that at low frequency loop gain equals to T0=β.Gm.Ro and hence should be flat

    2. Why is the step response showing these humps? Is this because of loop gain issue? or something else

    I am not getting this please help.

    Thanks




--[[ ]]--