+ Post New Thread
Results 1 to 2 of 2
  1. #1
    Junior Member level 1
    Points: 541, Level: 4

    Join Date
    Jun 2010
    Location
    Delhi
    Posts
    19
    Helped
    3 / 3
    Points
    541
    Level
    4

    PIC to PIC MCU communication in Assembly language

    Hellow everyone!
    i'm working on a PIC to PIC MCU communication in assembly language.
    the receiving PIC isn't working.
    Can anyone help me for making algorithm for its communication.

    •   AltAdvertisement

        
       

  2. #2
    Full Member level 1
    Points: 2,623, Level: 11
    Achievements:
    7 years registered

    Join Date
    Oct 2008
    Location
    Türkiye
    Posts
    112
    Helped
    29 / 29
    Points
    2,623
    Level
    11

    Re: RF MODULE 433MHz

    I suggest you to google your subjects so that you dont wait here for very common and solved problems.

    Receiving PIC is not working or it cant receive data? Make it blink a led so that you make sure wheter it is working or not. Did you try to make your PICs communicate via cable? Try it first and then remove the cable and place your 433 modules. You will see that receiving PIC is still working but received data is wrong. Reasons? A common and possible reason is turn on time of your receiver. Google it. Easiest and primitive way to fix the problem, send your data in a frame. An example frame is: 0x55,0x55,0x55,'x',your_byte. Here 0x55 s to pass turn on time. Recevier must wait for 'x' because following data is sent data. Specify your own 'x' and also 0x55 s :D By the way, dont forget to keep your baud rate low. 300 or 600 is fine. Google your topic.



--[[ ]]--