Search:

Type: Posts; User: MARGD

Search: Search took 0.04 seconds.

  1. Closed: Re: LTC4020 not regulating, blowing sense resistors during debug

    It looks like there were a couple of issues with the design:

    First, the schottky diodes were not sufficiently derated. (60V diodes for a 54V output). I confirmed that the diodes across M2 and M4...
  2. Closed: Re: LTC4020 not regulating, blowing sense resistors during debug

    I've updated the Vshutdown on my board to 14V minimum, set my max V to 55 and my float voltage to 54, using the same values from the modified DC2134A above. It started working, if inefficiently, when...
  3. Closed: Re: LTC4020 not regulating, blowing sense resistors during debug

    I have an update:

    I tried modifying the DC2134A evaluation board to match my board more closely using components that I had on-hand

    I replaced RCBAT1 with 100mOhms (.5A charge current limit)
    I...
  4. Closed: Re: LTC4020 not regulating, blowing sense resistors during debug

    I'm not using the Ilimit pin because my understanding was that the inductor sense resistors were supposed to handle that. Also, none of the application examples in the datasheet use it.

    I'm not...
  5. Closed: LTC4020 not regulating, blowing sense resistors during debug

    All,

    I'm currently working on a design that's trying to use the LTC4020 battery charger, and I'm at a loss to understand what I'm doing wrong. Here's my schematic.

    154969

    When I apply 48V to...
Results 1 to 5 of 5