Search:

Type: Posts; User: andre_teprom

Page 1 of 20 1 2 3 4

Search: Search took 0.07 seconds.

  1. Closed: Re: Please help me avoid a disaster with my first pcb

    Regardless if there is any issue at the PCB layout, I would thoroughly review the schematic diagram; at a glance we can note the lack of pull-up resistor at the DHT22 sensor, as well using a lot of...
  2. Replies
    1
    Views
    248

    Closed: Re: Eplan 2.7 Cross Reference problem

    The issue is unclear; do you want to cross reference what's after the terminal block, toward K2? If not, the cross reference labels look correct because you have defined a mounting location (F100)...
  3. Closed: Re: PIC16F877 interface with ds1307 ...RTC running 10 sec slow

    As said, regardless of whether the simulator exhibit the message "non-realtime simulation" or not (even because only Informations, not Warnings messages were displayed in your log), trust us;...
  4. Closed: Re: PIC16F877 interface with ds1307 ...RTC running 10 sec slow

    Congratulations, you just realized that there are no problems regarding to the original issue.



    No, you point out exactly the problem, if any.
  5. Closed: Re: PIC16F877 interface with ds1307 ...RTC running 10 sec slow

    You didn't mention before this was in a simulation environment; check messages on the log tab, or at status bar, it clearly states something like "simulation is not running in real time". I leave you...
  6. Replies
    20
    Views
    970

    Closed: Re: ST7036i and mikroc STUCK

    Ok, sorry for having overlooked this.

    BTW, seems like the function I2C1_Wr() already has the ack feature implicitly built in. Note that according to MikroC I2C online documentation, it is a...
  7. Replies
    20
    Views
    970

    Closed: Re: ST7036i and mikroc STUCK

    So what is the problem at all? It sounds like you ARE reading it. Since you allways get an ACK, shoulnd't you celebrate this ? If you want to force a NO ACK (NACK) in the sake of experimenting,...
  8. Replies
    20
    Views
    970

    Closed: Re: ST7036i and mikroc STUCK

    Ok, just to make sure you got the point: Since this routine is always executing the snippet below, we need to know what this variable ACKSTAT_bit is; the mapping of an I/O input, or a user-defined...
  9. Replies
    20
    Views
    970

    Closed: Re: ST7036i and mikroc STUCK

    In C language, unlike some script languages, every variable must be declared somewhere on code, and ACKSTAT_bit in the above snippet was not declared, you only read it in the ack() function. Anyway,...
  10. Replies
    20
    Views
    970

    Closed: Re: ST7036i and mikroc STUCK

    Did you really pay attention on the above reply, or at least spent any time to review the correct code before posting ? Regardless of the naming, both ACKSTAT or ACKSTAT_bit are within in the same...
  11. Replies
    20
    Views
    970

    Closed: Re: ST7036i and mikroc STUCK

    So far you have not shown the complete program, the ACKSTAT variable does not appear anywhere else but only being evaluated in both the if's above. If it is present only in the declaration with no...
  12. Replies
    9
    Views
    622

    [SOLVED]Closed: Re: Interface Temperature Sensor

    Strictly speaking, every natural phenomenon is non-linear in some extent, and unless a detailed inspection is made - such as the one you did - it is not possible to know beforehand whether it is...
  13. Replies
    9
    Views
    622

    [SOLVED]Closed: Re: Interface Temperature Sensor

    There are numerous regression calculator websites on the web on which you can insert the above input/output table, obviously selecting just one pair of parameter ( e.g : Celsius / ADC value ). These...
  14. Closed: Re: Why On startup LED1(connceted at GPIO-0) ONCE gets blink at ESP-01 module

    Why did you remove LED pin config from your code?
    It is not supposed to blink any time:


    //pinMode(LED,OUTPUT);
  15. [SOLVED]Closed: Re: Full wave rectifier on Proteus crashes by putting a ground to the circuit

    As the pop-up windows says "see log error" one would expect you have attached/paste the error message. In any case, it is likely to be a problem related to the use of 'ideal' devices (for example,...
  16. Closed: Re: What does the phase margin=110 degrees mean?

    What is preventing you from assessing this by yourself? There are just 2 rules related to the gain and phase margin; tell us your conclusion so that we can confirm or correct it.
  17. Closed: Re: What does the phase margin=110 degrees mean?

    Once you are seemingly showing the graph of the closed-loop transfer function of the system, there is no need to make any additional math, just use usual phase/gain margin criteria to determine...
  18. Closed: Re: What does the phase margin=110 degrees mean?

    Where did you see -110 degrees in the above graph ?
  19. Replies
    3
    Views
    1,124

    Closed: Re: Laptop battery question

    Some BIOS have the option to keep delivering energy on USB slots, which could sink some energy from battery even don't having anything plugged there. I think there is no general answer to this...
  20. Closed: Re: Rottary encoder and STM32 - multi speed

    I'm not sure if it is a good idea to measure rotation speed from knob; handling may vary a lot from one person to another, so the criteria you defined above may not work. Long time ago I did the ISR...
  21. Closed: Re: Rottary encoder and STM32 - multi speed

    In general Encoders are not read in polling strategy, it is used I/O interrupts, and depending of the rate it is needed a dedicated hardware for that, appart from the microcontroller, otherwise it...
  22. Closed: Re: SMPS circuit showing an oscillation in the output current...current monitor probl

    Did you review what was mentioned above regarding C5?
  23. Closed: Re: SMPS circuit showing an oscillation in the output current...current monitor probl

    According to the ACS722`s datasheet, and from the attached schematic above, by pulling up pin 6, you have selected the 80KHz bandwidth mode, not the 20KHz.

    Anyway, why did you selected the CL...
  24. [SOLVED]Closed: Re: Chip Enable Program Error with 8051 MCU(AT89S51)

    From the above picture, the IC on the breadboard seems like being AT89C51, not the AT89S51 you mentioned.
  25. [SOLVED]Closed: Re: Chip Enable Program Error with 8051 MCU(AT89S51)

    Not sure about what exact procedures you did, but since the message log right bellow give indication of a sucessful Write, I would check how fuses are set ( e.g code protect, oscillator ). Try...
Results 1 to 25 of 500
Page 1 of 20 1 2 3 4