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Workshop 4.1 – HFSS

Example: Silicon Spiral Inductor

An Introduction to HFSS
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An Introduction to HFSS

Example – Silicon Spiral Inductor

• The Silicon Spiral Inductor
– This example is intended to show you how to create, simulate, and analyze a 2.5 turn spiral inductor using the Ansoft 

HFSS Design Environment.

Nominal Design:

Spiral:  2.5T, W=15um, S=1.5um, Rad=60um

M6, 2um, = 2.8e7 S/m

Underpass: M5, 0.5um, = 2.8e7 S/m

Stackup:

Passivation: 0.7um

r = 7.9

Oxide: 9.8um

r = 4.0

Substrate: 300um

r = 11.9, = 10 S/m

Substrate

Oxide

Passivation

M6

M5
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An Introduction to HFSS

Example – Silicon Spiral Inductor

• Ansoft HFSS Design Environment
– The following features of the Ansoft HFSS Design Environment are used to create this passive device model

• 3D Solid Modeling

– Primitives: Box, Rectangles, Cylinders

– Boolean Operations: Subtract, Unite, Duplicate

• Boundary

– Boundary Conditions: Perfect H/Natural

• Excitations

– Ports: Lumped Gap Source Port

• Analysis

– Sweep: Fast Frequency

• Results

– Cartesian plotting

• Fields

– Fast Frequency Sweep/Field Plots
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An Introduction to HFSS

Example – Silicon Spiral Inductor

• Getting Started

• Launching Ansoft HFSS

– To access Ansoft HFSS, click the Microsoft Start button, select Programs, and select the Ansoft, HFSS 12 program 

group.  Click HFSS 12.

• Setting Tool Options

– To set the tool options:

• Note:  In order to follow the steps outlined in this example, verify that the following tool options are set : 

• Select the menu item Tools > Options > HFSS Options

• HFSS Options Window:

– Click the General tab

• Use Wizards for data entry when creating new boundaries:  Checked

• Duplicate boundaries/mesh operations with geometry:  Checked

• Auto-assign terminals on ports::  Checked

– Click the OK button

• Select the menu item Tools > Options > Modeler Options.

• Modeler Options Window:

– Click the Operation tab

• Automatically cover closed polylines:  Checked

– Click the Drawing tab

• Operation Data Entry Mode: Point

• Show Measure Dialog :  Unchecked

• Edit property of new primitives:  Checked

– Click the OK button
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An Introduction to HFSS

Example –Silicon Spiral Inductor

• Opening a New Project

– To open a new project:

• In an  Ansoft HFSS window, click the  On the Standard toolbar, or select the menu item File > New.

• From the Project menu, select Insert HFSS Design.

• Set Solution Type

– To set the solution type:

• Select the menu item HFSS > Solution Type

• Solution Type Window:

– Choose Driven Terminal

– Click the OK button
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An Introduction to HFSS

Example – Silicon Spiral Inductor

• Creating the 3D Model

• Set Model Units

– To set the units:

• Select the menu item 3D Modeler > Units

• Set Model Units:

– Select Units: um

– Click the OK button

• Set Default Material

– To set the default material:

• Using the 3D Modeler Materials toolbar, choose Select

• Select Definition Window:

– Click the Add Material button

– View/Edit Material Window:

• For the Material Name type: My_Sub

• For the Value of Relative Permittivity type: 11.9 

• For the Value of Bulk Conductivity type: 10

• Click the OK button

– Click the OK button
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An Introduction to HFSS

Example – Silicon Spiral Inductor

• Create Substrate

– To create the substrate:

• Select the menu item Draw > Box

• Using the coordinate entry fields, enter the box position

– X: -270.0, Y: -270.0, Z: 0.0, Press the Enter key

• Using the coordinate entry fields, enter the opposite corner of the box:

– dX: 540.0, dY: 540.0, dZ: 300.0, Press the Enter key

– To set the name:

• Select the Attribute tab from the Properties window.

• For the Value of Name type: Sub

• Click the OK button

– To fit the view:

• Select the menu item View > Fit All > Active View. 

• Set Default Material

– To set the default material:

• Using the 3D Modeler Materials toolbar, choose Select

• Select Definition Window:

– Click the Add Material button

– View/Edit Material Window:

• For the Material Name type: My_Oxide

• For the Value of Relative Permittivity type: 4.0 

• Click the OK button

– Click the OK button
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An Introduction to HFSS

Example – Silicon Spiral Inductor

• Create Oxide

– To create substrate:

• Select the menu item Draw > Box

• Using the coordinate entry fields, enter the box position

– X: -270.0, Y: -270.0, Z: 300.0, Press the Enter key\

• Using the coordinate entry fields, enter the opposite corner of the box:

– dX: 540.0, dY: 540.0, dZ: 9.8, Press the Enter key

– To set the name:

• Select the Attribute tab from the Properties window.

• For the Value of Name type: Oxide

• Click the OK button

– To fit the view:

• Select the menu item View > Fit All > Active View

or press the CTRL+D key

• Set Default Material

– To set the default material:

• Using the 3D Modeler Materials toolbar, choose Select

• Select Definition Window:

– Click the Add Material button

– View/Edit Material Window:

• For the Material Name type: My_Pass

• For the Value of Relative Permittivity type: 7.9 

• Click the OK button

– Click the OK button
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An Introduction to HFSS

Example – Silicon Spiral Inductor

• Create Passivation

– To create substrate:

• Select the menu item Draw > Box

• Using the coordinate entry fields, enter the box position

– X: -270.0, Y: -270.0, Z: 309.8, Press the Enter key

• Using the coordinate entry fields, enter the opposite corner of the box:

– dX: 540.0, dY: 540.0, dZ: 0.7, Press the Enter key

– To set the name:

• Select the Attribute tab from the Properties window.

• For the Value of Name type: Pass

• Click the OK button

– To fit the view:

• Select the menu item View > Fit All > Active View

or press the CTRL+D key

• Set Default Material

– To set the default material:

1. Using the 3D Modeler Materials toolbar, choose vacuum
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An Introduction to HFSS

Example – Silicon Spiral Inductor

• Create Air

– To create air box:

• Select the menu item Draw > Box

• Using the coordinate entry fields, enter the box position

– X: -270.0, Y: -270.0, Z: 0.0, Press the Enter key

• Using the coordinate entry fields, enter the opposite corner of the box:

– dX: 540.0, dY: 540.0, dZ: 600.0, Press the Enter key

– To set the name:

• Select the Attribute tab from the Properties window.

• For the Value of Name type: Air

• Click the OK button

– To fit the view:

• Select the menu item View > Fit All > Active View

• Create Radiation Boundary
– To select the object Air:

• Select the menu item Edit > Select > By Name

• Select Object Dialog, 

– Select the objects named: Air

– Click the OK button

– To create a radiation boundary

• Select the menu item HFSS > Boundaries > Assign > Radiation

• Radiation Boundary Window

– Name: Rad1

– Select: Radiating Only

– Click the OK button
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An Introduction to HFSS

Example – Silicon Spiral Inductor

• Create Ground
– To create ground:

• Select the menu item Draw > Rectangle

• Using the coordinate entry fields, enter the box position

– X: -270.0, Y: -270.0, Z: 0.0, Press the Enter key

• Using the coordinate entry fields, enter the opposite corner of the base rectangle:

– dX: 540.0, dY: 540.0, dZ: 0.0, Press the Enter key

– To set the name:

• Select the Attribute tab from the Properties window.

• For the Value of Name type: Ground

• Click the OK button

– To fit the view:

• Select the menu item View > Fit All > Active View.  

or press the CTRL+D key
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An Introduction to HFSS

Example – Silicon Spiral Inductor

• Assign a Perfect E boundary to the Ground

– To select the ground:

• Select the menu item Edit > Select > By Name

• Select Object Dialog, 

– Select the objects named: Ground

– Click the OK button

– To assign the Perfect E boundary

• Select the menu item HFSS > Boundaries > Assign > Perfect E

• Perfect E Boundary window

– Name: PerfE_Ground

– Infinite Ground Plane:  Unchecked

– Click the OK button

• Hide Dielectrics

– To hide the dielectrics:

• Select the menu item Edit > Select  All Visible

• Select the menu item View > Hide Selection > All Views
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An Introduction to HFSS

Example – Silicon Spiral Inductor

• Set Default Material

– To set the default material:

• Using the 3D Modeler Materials toolbar, choose Select

• Select Definition Window:

– Click the Add Material button

– View/Edit Material Window:

• For the Material Name type: My_Met

• For the Value of Bulk Conductivity type: 2.8e7

• Click the OK button

– Click the OK button

• Create Offset Coordinate System

– To create an offset Coordinate System:

• Select the menu item Modeler > Coordinate System > Create > 

Relative CS > Offset

• Using the coordinate entry fields, enter the origin

– X: 0.0, Y: 0.0, Z: 304.8, Press the Enter key 
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An Introduction to HFSS

Example – Silicon Spiral Inductor
• Create Spiral Path

– To create the path:

• Select the menu item Draw > Line

• Using the coordinate entry fields, enter the vertex point:

– X: -67.5 , Y: 7.5, Z: 1.0 Press the Enter key

• Using the coordinate entry fields, enter the vertex point:

– X: -67.5 , Y: -67.5 , Z: 1.0 Press the Enter key

• Using the coordinate entry fields, enter the vertex point:

– X: 84.0, Y: - 67.5, Z: 1.0 Press the Enter key

• Using the coordinate entry fields, enter the vertex point:

– X: 84.0, Y: 84.0, Z: 1.0 Press the Enter key

• Using the coordinate entry fields, enter the vertex point:

– X: - 84.0, Y: 84.0, Z: 1.0 Press the Enter key

• Using the coordinate entry fields, enter the vertex point:

– X: - 84.0, Y: -84.0, Z: 1.0 , Press the Enter key

• Using the coordinate entry fields, enter the vertex point:

– X: 100.5 , Y: -84.0, Z: 1.0 , Press the Enter key

• Using the coordinate entry fields, enter the vertex point:

– X: 100.5 , Y: 100.5 , Z: 1.0 , Press the Enter key

• Using the coordinate entry fields, enter the vertex point:

– X: - 100.5 , Y: 100.5 , Z: 1.0 ,  Press the Enter key

• Using the coordinate entry fields, enter the vertex point:

– X: - 100.5 , Y: - 100.5, Z: 1.0 , Press the Enter key

• Using the coordinate entry fields, enter the vertex point:

– X: 117.0, Y: -100.5, Z: 1.0 , Press the Enter key

• Using the coordinate entry fields, enter the vertex point:

– X: 117.0,  Y: 0.0,  Z: 1.0 , Press the Enter key

• Using the coordinate entry fields, enter the vertex point:

– X: 131.0, Y: 0.0, Z: 1.0 , Press the Enter key

• Using the mouse, right-click and select Done

– To set the name:

• Select the Attribute tab from the Properties window.

• For the Value of Name type: Spiral

• Click the OK button when the Properties dialog appears
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An Introduction to HFSS

Example – Silicon Spiral Inductor

• Create Spiral Path

• To assign trace width and thickness
– In Modeler Tree expand trace and click on Create Polyline

– In Properties window change Type to Rectangle

– Width: 15 um

– Height : 2 um

• To fit the view:
Select the menu item View > Fit All   > Active View.  

Or press the CTRL+D key
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An Introduction to HFSS

Example – Silicon Spiral Inductor

• Set Grid Plane

– To set the grid plane:

• Select the menu item 3D Modeler > Grid Plane > XY

• Create Underpass

– To create underpass:

• Select the menu item Draw > Box

• Using the coordinate entry fields, enter the box position

– X: -60.0, Y: 7.5, Z: -0.8, Press the Enter key

• Using the coordinate entry fields, enter the opposite corner of the box:

– dX: -75.0, dY: -15.0, dZ: -0.5, Press the Enter key

– To set the name:

• Select the Attribute tab from the Properties window.

• For the Value of Name type: Underpass

• Click the OK button

– To fit the view:

• Select the menu item View > Fit All > Active View.

Or press the CTRL+D key
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An Introduction to HFSS

Example – Silicon Spiral Inductor

• Create Via1

– To create via:

• Select the menu item Draw > Box

• Using the coordinate entry fields, enter the box position

– X: -60.0, Y: 7.5, Z: 0.0, Press the Enter key

• Using the coordinate entry fields, enter the opposite corner of the box:

– dX: -15.0, dY: -15.0, dZ: -0.8, Press the Enter key

– To set the name:

• Select the Attribute tab from the Properties window.

• For the Value of Name type: Via1

• Click the OK button

• Create Via2

– To create via:

• Select the menu item Draw > Box

• Using the coordinate entry fields, enter the box position

– X: -120.0, Y: 7.5, Z: 0.0, Press the Enter key

• Using the coordinate entry fields, enter the opposite corner of the box:

– dX: -15.0, dY: -15.0, dZ: -0.8, Press the Enter key

– To set the name:

• Select the Attribute tab from the Properties window.

• For the Value of Name type: Via2

• Click the OK button

– To fit the view:

• Select the menu item View > Fit All > Active View.
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An Introduction to HFSS

Example – Silicon Spiral Inductor

• Create Feed

– To create feed:

• Select the menu item Draw > Box

• Using the coordinate entry fields, enter the box position

– X: -120.0, Y: 7.5, Z: 0.0, Press the Enter key

• Using the coordinate entry fields, enter the opposite corner of the box:

– dX: -22.0, dY: -15.0, dZ: 2.0, Press the Enter key

– To set the name:

• Select the Attribute tab from the Properties window.

• For the Value of Name type: Feed

• Click the OK button

– To fit the view:

• Select the menu item View > Fit All > Active View.

Or press the CTRL+D key
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An Introduction to HFSS

Example – Silicon Spiral Inductor

• Unite Objects
– To select spiral objects

• In the model tree, highlight: Spiral, and Via1, Via2, Feed and Underpass

• Select the menu item Modeler > Boolean > Unite

• To fit the view:
Select the menu item View > Fit All   > Active View.  

Or press the CTRL+D key



Introduction

1-20
ANSYS, Inc. Proprietary

© 2009 ANSYS, Inc.  All rights reserved.
February 23, 2009

Inventory #002593

Training ManualTraining Manual

WS04.1-20
ANSYS, Inc. Proprietary

© 2009 ANSYS, Inc.  All rights reserved.
January 20, 2010

Inventory #002843

An Introduction to HFSS

Example – Silicon Spiral Inductor

• Solve Inside Conductors

– To solve inside:

• Select the menu item Edit > Select by Name

• Select Object Dialog, 

– Select: Spiral

• Select the menu item Edit > Properties

• Properties Dialog Attribute Tab

– Solve Inside: Checked

– Click the OK button

– Click the OK button for all warning messages (Solving inside a solid with high conductivity may require a large mesh) 

• Seed Mesh Conductors set for Solve Inside

– To solve inside:

• Select the menu item Edit > Select All Visible

• Select the menu item HFSS > Mesh Operations > 

Assign > Inside Selection > Length Based

• Element Length Based Refinement Dialog

– Name: Length1

– Restrict Length of Elements:  Unchecked

– Restrict Number of Elements: Checked

– Maximum Number of Elements: 5000

– Click the OK button
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An Introduction to HFSS

Example – Silicon Spiral Inductor

• Set Default Material

– To set the default material:

• Using the 3D Modeler Materials toolbar, choose Select

• Select Definition Window:

– Type pec in the Search by Name field

– Click the OK button

• Create Ground Ring

– To create outer ring:

• Select the menu item Draw > Box

• Using the coordinate entry fields, enter the box position

– X: -225.0, Y: -225.0, Z: 0.0, Press the Enter key

• Using the coordinate entry fields, enter the opposite corner of the box:

– dX: 450.0, dY: 450.0, dZ: 2.0, Press the Enter key

– To set the name:

• Select the Attribute tab from the Properties window.

• For the Value of Name type: Ring

• Click the OK button

– To fit the view:

• Select the menu item View > Fit All > Active View
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An Introduction to HFSS

Example – Silicon Spiral Inductor
• Create Inner Ring

– To create inner ring:

• Select the menu item Draw > Box

• Using the coordinate entry fields, enter the box position

– X: -210.0, Y: -210.0, Z: 0.0, Press the Enter key

• Using the coordinate entry fields, enter the opposite corner of the box:

– dX: 420.0, dY: 420.0, dZ: 2.0, Press the Enter key

– To set the name:

• Select the Attribute tab from the Properties window.

• For the Value of Name type: Inner

• Click the OK button

– To fit the view:

• Select the menu item View > Fit All > Active View

• Complete the Ring

– To select the objects Ring and Inner:

• Select the menu item Edit > Select > By Name

• Select Object Dialog, 

– Select the objects named: Ring, Inner

– Click the OK button

– To complete the ring:

• Select the menu item Modeler > Boolean > Subtract 

• Subtract Window

– Blank Parts: Ring

– Tool Parts: Inner

– Click the OK button
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An Introduction to HFSS

Example – Silicon Spiral Inductor

• Create Extension 1

– To create extension:

• Select the menu item Draw > Box

• Using the coordinate entry fields, enter the box position

– X: -157.0, Y: 7.5, Z: 0.0, Press the Enter key

• Using the coordinate entry fields, enter the opposite corner of the box:

– dX: -53.0, dY: -15.0, dZ: 2.0, Press the Enter key

– To set the name:

• Select the Attribute tab from the Properties window.

• For the Value of Name type: Ring_Ext1

• Click the OK button

• Create Extension 2

– To create extension:

• Select the menu item Draw > Box

• Using the coordinate entry fields, enter the box position

– X: 146.0, Y: 7.5, Z: 0.0, Press the Enter key

• Using the coordinate entry fields, enter the opposite corner of the box:

– dX: 64.0, dY: -15.0, dZ: 2.0, Press the Enter key

– To set the name:

• Select the Attribute tab from the Properties window.

• For the Value of Name type: Ring_Ext2

• Click the OK button

– To fit the view:

• Select the menu item View > Fit All > Active View
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An Introduction to HFSS

Example – Silicon Spiral Inductor

• Create Source 1
– To create source:

• Select the menu item Draw > Rectangle

• Using the coordinate entry fields, enter the box position

– X: -142.0, Y: 7.5, Z: 1.0, Press the Enter key

• Using the coordinate entry fields, enter the opposite corner of the base rectangle:

– dX: -15.0, dY: -15.0, dZ: 0.0, Press the Enter key

– To set the name:

• Select the Attribute tab from the Properties window.

• For the Value of Name type: Source1

• Click the OK button

– To fit the view:

• Select the menu item View > Fit All > Active View.  

• Create Source 2
– To create source:

• Select the menu item Draw > Rectangle

• Using the coordinate entry fields, enter the box position

– X: 131.0, Y: 7.5, Z: 1.0, Press the Enter key

• Using the coordinate entry fields, enter the opposite corner of the base rectangle:

– dX: 15.0, dY: -15.0, dZ: 0.0, Press the Enter key

– To set the name:

• Select the Attribute tab from the Properties window.

• For the Value of Name type: Source2

• Click the OK button

– To fit the view:

• Select the menu item View > Fit All > Active View.  
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An Introduction to HFSS

Example – Silicon Spiral Inductor

• Group the Conductors

– To group the conductors:

• Select the menu item Edit > Select > By Name

• Select Object Dialog, 

– Select the objects named: Ring, Ring_Ext1, Ring_Ext2

– Click the OK button

• Select the menu item, Modeler > Boolean > Unite

– To fit the view:

• Select the menu item View > Fit All > Active View. 

• Assign Excitation
– To select the object Source:

• Select the menu item Edit > Select > By Name

• Select Object Dialog, 

– Select the objects named: Source1

– Click the OK button

• Note:  You can also select the object from the Model Tree

– To assign lumped port excitation

• Select the menu item HFSS > Excitations > Assign > Lumped Port

• Lumped Port : General 

– Port Name: 1, 

– Conductor: Ring _Ext1

– Use as Reference:  Checked

• Highlight Selected conductors:  Checked

• Click OK
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An Introduction to HFSS

Example – Silicon Spiral Inductor

• Assign Excitation
– To select the object Source:

• Select the menu item Edit > Select > By Name

• Select Object Dialog, 

– Select the objects named: Source1

– Click the OK button

• Note:  You can also select the object from the Model Tree

– To assign lumped port excitation

• Select the menu item HFSS > Excitations > Assign > Lumped Port

• Lumped Port : General 

– Port Name: 2, 

– Conductor: Ring _Ext1

– Use as Reference:  Checked

• Highlight Selected conductors:  Checked

• Click OK

• Show All

– To show all object

• Select the menu item View > Show All > All Views
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An Introduction to HFSS

Example – Silicon Spiral Inductor

• Assign Excitation
– To select the object Source:

• Select the menu item Edit > Select > By Name

• Select Object Dialog, 

– Select the objects named: Source1

– Click the OK button

• Note:  You can also select the object from the Model Tree

– To assign lumped port excitation

• Select the menu item HFSS > Excitations > Assign > Lumped Port

• Lumped Port : General 

– Port Name: 1, 

– Conductor: Ring _Ext1

• Use as Reference:  Checked

• Highlight Selected conductors:  Checked

• Click OK
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An Introduction to HFSS

Example – Silicon Spiral Inductor

• Assign Excitation
– To select the object Source:

• Select the menu item Edit > Select > By Name

• Select Object Dialog, 

– Select the objects named: Source1

– Click the OK button

• Note:  You can also select the object from the Model Tree

– To assign lumped port excitation

• Select the menu item HFSS > Excitations > Assign > Lumped Port

• Lumped Port : General 

– Port Name: 2, 

– Conductor: Ring _Ext2

• Use as Reference:  Checked

• Highlight Selected conductors:  Checked

• Click OK

• Show All

– To show all object

• Select the menu item View > Show All > All Views
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An Introduction to HFSS

Example – Silicon Spiral Inductor

• Boundary Display

– To verify the boundary setup:

• Select the menu item HFSS > Boundary Display (Solver View)

• From the Solver View of Boundaries, toggle the Visibility check box for the  boundaries you wish to display.

– Note: The background (Perfect Conductor) is displayed as the outer boundary.

– Note: The Perfect Conductors are displayed as the smetal boundary.

– Note: Select the menu item, View > Visibility to hide all of the geometry objects.  This makes it easier to 

see the boundary

• Click the Close button when you are finished
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An Introduction to HFSS

Example – Silicon Spiral Inductor

• Analysis Setup

• Creating an Analysis Setup

– To create an analysis setup:

• Select the menu item HFSS > Analysis Setup > Add Solution Setup

• Solution Setup Window:

– Click the General tab:

• Solution Frequency: 12.0GHz

• Maximum Number of Passes: 20

• Maximum Delta S: 0.02

– Click the Options tab:

• Do Lambda Refinement:  Checked

• Lambda Target: 0.05

• Maximum Refinement per pass: 30%

• Minimum Number of Passes: 6

• Minimum Number of Converged Passes: 2

• Order of Basis Function: Zero Order

– Click the OK button
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An Introduction to HFSS

Example – Silicon Spiral Inductor

• Analysis Setup

• Adding a Frequency Sweep

– To add a frequency sweep:

• Select the menu item HFSS > Analysis Setup > Add Sweep

– Select Solution Setup: Setup1 

– Click the OK button

• Edit Sweep Window:

– Sweep Type: Interpolating

– Frequency Setup Type: Linear Step

• Start: 0.1GHz

• Stop: 20.0GHz

• Step: 0.1GHz

– Interpolating Sweep Options

• Max Solutions: 50

• Error Tolerance: 0.1%

– Click the OK button
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An Introduction to HFSS

Example – Silicon Spiral Inductor

• Save Project

– To save the project:

• In an  Ansoft HFSS window, select the menu item File > Save As.

• From the Save As window, type the Filename: hfss_spiral_inductor

• Click the Save button

• Analyze

• Model Validation

– To validate the model:

• Select the menu item HFSS > Validation Check

• Click the Close button

– Note: To view any errors or warning messages, use the Message Manager.

• Analyze

– To start the solution process:

• Select the menu item HFSS > Analyze All
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An Introduction to HFSS

Example – Silicon Spiral Inductor

• Solution Data

– To view the Solution Data:

• Select the menu item HFSS > Results > Solution Data

– To view the Profile:

• Click the Profile Tab.

– To view the Convergence:

• Click the Convergence Tab

• Note: The default view is for convergence is Table.  Select the Plot radio button to view a graphical 

representations of the convergence data.

– To view the Matrix Data:

• Click the Matrix Data Tab

• Note: To view a real-time update of the Matrix Data, set the Simulation to Setup1, Last Adaptive

• Click the Close button
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An Introduction to HFSS

Example – Silicon Spiral Inductor

• Create Reports

• Create S-parameter vs. Frequency

– To Create a report:

• Select the menu item HFSS > Results > Create Report

• Create Report Window:

– Report Type: Terminal S Parameters

– Display Type: Rectangular

– Click the OK button

• Traces Window:

– Solution: Setup1: Sweep1

– Click the Y tab

• Domain: Sweep

• Category: Terminal S-Parameters

• Quantity:  St(Source1_T1, Source1_T1)

and St(Source1_T1, Source2_T1)

• Function: dB

• Click the Add Trace button

– Click the Done button
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An Introduction to HFSS

Example – Silicon Spiral Inductor

• Custom Equations – Output Variables
– Select the menu item HFSS > Results > Create Report

– Create Report Window:

• Report Type: Terminal S Parameters

• Display Type: Rectangular

• Click the OK button

– Traces Window:

• Click the Output Variables button

– Output Variables dialog:

• Name:  Q11

• Expression: 

– Category: Terminal Y Parameters

– Quantity: Yt(Source1_T1, Source1_T1)

– Function: im

– Click the Insert Quantity into Expression button

– Type: /

– Quantity: Yt(Source1_T1, Source1_T1)

– Function: re

– Click the Insert Quantity into Expression button

• Click the Add button

• Repeat for Q22, by replacing Yt(Source1_T1, Source1_T1)

with Yt(Source2_T1, Source2_T1)

• Click the Done button

– Solution: Setup1: Sweep1

• Domain: Sweep

– Category: Output Variables

– Quantity: Q11, Q22

– Function: abs

– Click the New report button

• Click Close button
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An Introduction to HFSS

Example – Silicon Spiral Inductor

• Create Reports (Continued)

• Custom Equations – Output Variables
– Select the menu item HFSS > Results > Create Report

– Create Report Window:

• Report Type: Terminal S Parameters

• Display Type: Rectangular

• Click the OK button

– Traces Window:

• Click the Output Variables button

• Output Variables dialog:

– Name:  L11

– Expression: 

• Type: -1/(2*pi*freq*

• Category: Terminal Y Parameters

• Quantity: Yt(Source1_T1, Source1_T1)

• Function: im

• Click the Insert Quantity into Expression button

• Type: )

– Click the Add button

– Click the Done button

• Solution: Setup1: Sweep1

• Domain: Sweep

• Click the Y tab

– Category: Output Variables

– Quantity: Y11

– Function: none

– Click the New Report button

• Click Close button
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An Introduction to HFSS

Example – Silicon Spiral Inductor

• Appendix – Alternative Lumped Ports

PEC Bridge

G S G

Port
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An Introduction to HFSS

Example – Silicon Spiral Inductor

• Appendix – Alternative Lumped Ports
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Port
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An Introduction to HFSS

Example – Silicon Spiral Inductor

• Create Spiral Ring

– To create the path:

• Select the menu item Draw > Line

• Using the coordinate entry fields, enter the vertex point:

– X: -217.5 , Y: -217.5, Z: 2.0 Press the Enter key

• Using the coordinate entry fields, enter the vertex point:

– X: -217.5 , Y: 217.5, Z: 2.0 Press the Enter key

• Using the coordinate entry fields, enter the vertex point:

– X: 217.5 , Y: 217.5, Z: 2.0 Press the Enter key

• Using the coordinate entry fields, enter the vertex point:

– X: 217.5 , Y: -217.5, Z: 2.0 Press the Enter key

• Using the coordinate entry fields, enter the vertex point:

– X: -217.5 , Y: -217.5, Z: 2.0 Press the Enter key

1. Using the mouse, right-click and select Done

– To set the name:

• Select the Attribute tab from the Properties window.

• For the Value of Name type: Ring

1. Click the OK button when the Properties dialog appears


