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6.5-1

Microstrip Wave Port
This example is intended to show you how wave port size can influence the 
results of any simulation using  the A nsoft H F S S  V ersion 9  D esig n E nvironment.
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Ansoft Design Environment
The following features of the Ansoft HFSS Design Environment are used  to 
c reate this p assive d evic e mod el

3 D Solid  M od eling
P rimitives:  Boxes, Rectangle
B oolean O p erations:  D u p li cate A long L i ne

B ound ary / Ex c itation
P orts:  W av e P or ts and  I ntegr ati on L i nes

Analy sis
Solution:  P or ts O nly
Sweep :  I nter p olati ng

R esults
C ar tesi an p lotti ng

Field s O verlay s
P or t F i eld  D i sp lay  
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Getting Started

Launching Ansoft HFSS
1. To access Ansoft HFSS, click the Microsoft Start b u tton, select P ro g ram s , and  

select the A n s o f t,  H F SS 9 p rog ram  g rou p .  C lick H F SS 9 .

Se tting T ool  O p tions
T o  s e t th e  to o l  o p ti o n s :

N o te :   I n ord er to follow  the step s ou tlined  in this ex am p le, v erify  that the 
follow ing  tool op tions are set :  

1. Select the m enu  item  Tools > Options > HFSS Options
2 . HFSS O p tions W ind ow :

1. C lick the G e n e ral tab
U se W iz ard s for d ata entry  w hen creating  new  b ou nd aries:  �
C h e c k e d
D u p licate b ou nd aries w ith g eom etry :  � C h e c k e d

2 . C lick the O K b u tton
3 . Select the m enu  item  Tools > Options > 3 D  M od e le r  Options.
4 . 3 D  Mod eler O p tions W ind ow :

1. C lick the O p e rati o n tab
Au tom atically  cov er closed  p oly lines:  � C h e c k e d

2 . C lick the D raw i n g tab
E d it p rop erty  of new  p rim itiv es:  � C h e c k e d

3 . C lick the O K b u tton
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Design Review

Generally speaking when we assign a wave port to a microstrip line,  or any 
q u asi-T E M  line,  we need  to inclu d e some area arou nd  the actu al transmission 
line.  T he b ig q u estion is,  “ how mu ch area? ”
B elow you  will see the cross section of  a simple microstrip line with naming 
conventions shown.

A s a ru le of  thu mb ,  we typically create a 2 D  rectangle to represent the wave port 
stimu lu s f or this type of  stru ctu re.  T he d imensions of  the rectangle are rou ghly 
f ive times the wid th of  the transmission line b y f ou r times the height of  the 
su b strate.
R E M E M B E R :  T hese are only gu id elines ! ! !
T he height of  the port will b e af f ected  b y the permittivity of  the su b strate.  T he 
higher the permittivity,  the less the f ield s will propagate in the air,  and  the shorter 
the port can b e mad e.

~5w

w

h

>4h

T he wid th of  the port will af f ect the port imped ance and  
propagating mod es.  T he narrower the wid th ( image on 
right) ,  the more the f ield s will cou ple to the sid e walls of  
the port.  T his ef f ect may not b e physical.  T he wid er the 
port,  the greater chance that a higher f req u ency 
wavegu id e mod e can propagate.

T his ex ample will ex plore this last phenomenon.
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Opening a New Project
To open a new project:

In an  Ansoft HFSS window, click the � O n the Standar d toolb ar , or  select 
the m enu  item  File > New.
Fr om  the P r o j ec t m enu , select I n s er t  H FS S  D es ig n .

S et S ol u tion T y pe
To s et th e s ol u ti on ty pe:

Select the m enu  item  H FS S  > S o lu t io n  T y p e
Solu tion T y p e W indow:

C hoose D ri v en M od al
C lick the O K b u tton

S et M od el  U nits
To s et th e u ni ts :

Select the m enu  item  3 D  M o d eler  > U n it s
Set M odel U nits:

Select U nits:  m i l
C lick the O K b u tton
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Add New Material
To add a new material:

1. Using the 3D Modeler Materials toolbar, choose S elec t
2 . F rom  the S elect Def inition w indow , click  the A dd M aterial bu tton
3 . V iew / E dit Material W indow :

1. Material N am e:  M y _ R og ers
2 . R elativ e P erm ittiv ity :  3 . 3 8  
3 . C lick  the O K bu tton

4 . C lick  the O K bu tton
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Create Substrate
To create the substrate:

1. Select the menu item Draw > Box
2 . U s ing  the co o r d ina te entr y  f ield s ,  enter  the b o x  p o s itio n

X :  0 . 0 ,  Y :  -4 0 0 . 0 ,  Z :  0 . 0 ,  P r es s  the E n ter k ey
3 . U s ing  the co o r d ina te entr y  f ield s ,  enter  the o p p o s ite co r ner  o f  the b o x :

d X :  2 0 0 . 0 ,  d Y :  8 0 0 . 0 ,  d Z :  8 . 0 ,  P r es s  the E n ter k ey
To set the n am e:

1. Select the A ttri bute ta b  f r o m the P rop erti es w ind o w .
2 . F o r  the V al ue o f  N am e ty p e:  S ubstrate
3 . C lick  the O K b utto n

To f i t the v i ew :
1. Select the menu item V i e w > F i t  A l l  > A c t i v e  V i e w.  

Set D ef aul t M ateri al
To set the d ef aul t m ateri al :

1. U s ing  the 3 D  M o d eler  M a ter ia ls  to o lb a r ,  cho o s e S el ect
2 . Select D ef initio n W ind o w :

1. T y p e p ec in the S earch by  N am e f ield
2 . C lick  the O K b utto n
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Create Trace
To create the trace:

1. Select the menu item Draw > Box
2 . U s ing  the co o r d ina te entr y  f ield s ,  enter  the b o x  p o s itio n

X :  0 . 0 ,  Y :  -9 . 2 5 ,  Z :  8 . 0 ,  P r es s  the E n ter k ey
3 . U s ing  the co o r d ina te entr y  f ield s ,  enter  the o p p o s ite co r ner  o f  the b o x :

d X :  2 0 0 . 0 ,  d Y :  1 8 . 5 ,  d Z :  1 . 4 ,  P r es s  the E n ter k ey
To s et the n am e:

1. Select the A ttri b u te ta b  f r o m the P rop erti es w ind o w .
2 . F o r  the V al u e o f  N am e ty p e:  Trace
3 . C lick  the O K b utto n

To f i t the v i ew :
1. Select the menu item V i e w > F i t  A l l  > A c t i v e  V i e w.  

Create G ro u n d
To create the g rou n d :

1. Select the menu item Draw > Box
2 . U s ing  the co o r d ina te entr y  f ield s ,  enter  the b o x  p o s itio n

X :  0 . 0 ,  Y :  -4 0 0 . 0 ,  Z :  0 . 0 ,  P r es s  the E n ter k ey
3 . U s ing  the co o r d ina te entr y  f ield s ,  enter  the o p p o s ite co r ner  o f  the b o x :

d X :  2 0 0 . 0 ,  d Y :  8 0 0 . 0 ,  d Z :  -1 . 4 ,  P r es s  the E n ter k ey
To s et the n am e:

1. Select the A ttri b u te ta b  f r o m the P rop erti es w ind o w .
2 . F o r  the V al u e o f  N am e ty p e:  G rou n d
3 . C lick  the O K b utto n

To f i t the v i ew :
1. Select the menu item V i e w > F i t  A l l  > A c t i v e  V i e w.  
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Set Default Material
To set the default material:

1. Using the 3D Modeler Materials toolbar, choose v ac uum

C reate A ir
To c reate the A ir:

1. S elect the m enu  item  Draw > Box
2 . Using the coordinate entry  f ields, enter the box  p osition

X :  0 . 0 , Y :  -4 0 0 . 0 , Z :  -1 . 4 , P ress the E n ter k ey
3 . Using the coordinate entry  f ields, enter the op p osite corner of  the box :

dX :  2 0 0 . 0 , dY :  8 0 0 . 0 , dZ :  2 0 0 . 0 , P ress the E n ter k ey
To set the n ame:

1. S elect the A ttrib ute tab f rom  the P rop erties w indow .
2 . F or the V alue of  N ame ty p e:  A ir
3 . C lick  the O K bu tton

To fit the v iew :
1. S elect the m enu  item  V i e w > F i t  A l l  > A c t i v e  V i e w.  

C reate R ad iatio n  B o un d ary
To selec t the ob j ec t A ir:

1. S elect the m enu  item  E d i t  > S e l e c t  > By  N am e
2 . S elect O bj ect Dialog, 

1. S elect the obj ects nam ed:  A ir
2 . C lick  the O K  bu tton

To c reate a radiation  b oun dary
1. S elect the m enu  item  H F S S  > Bou n d ari e s  > A s s i g n  > R ad i at i on
2 . R adiation B ou ndary  W indow

N am e:  R ad1
C lick  the O K bu tton
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Set Grid Plane
To set the grid plane:

1. Select the menu item 3D Modeler > Grid Plane > YZ

C reate th e W av e Po rt
To c reate a rec tangle that represents the port:

1. Select the menu item Draw  > R ec t ang le
2 . U s ing  the co o r d ina te entr y  f ield s ,  enter  the center  p o s itio n

X: 0. 0,  Y : -2 00. 0,  Z : 0. 0, P r es s  the E nter k ey
3 . U s ing  the co o r d ina te entr y  f ield s ,  enter  the o p p o s ite co r ner  o f  the r ecta ng le:

d X: 0. 0,  d Y : 4 00. 0,  d Z : 5 0.0,  P r es s  the E nter k ey
To param eteriz e the ob j ec t:

1. Select the C om m and ta b  f r o m the P roperties w ind o w
2 . F o r  P osition,  ty p e:  0m il,  -P ort_ W idth/ 2 ,  0m il,  C lick  the Tab k ey  to  a ccep t 

A d d  V a r ia b le P ort_ W idth:  4 00m il,  C lick  the O K b utto n
3 . F o r  Y S iz e,  ty p e:  P ort_ W idth,  C lick  the Tab k ey  to  a ccep t 

To set the nam e:
1. Select the A ttrib u te ta b  f r o m the P roperties w ind o w .
2 . F o r  the V alu e o f  N am e ty p e:  P ort1
3 . C lick  the O K b utto n
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Assign the Excitation 1
To select the object p1:

1. Select the menu item Edit > Select > By Name
2 . Select O b j ect D ia lo g ,  

1. Select the o b j ects  na med : P or t1
2 . C lick  the O K  b utto n

To a ssi g n  w a v e por t ex ci ta ti on
1. Select the menu item H F SS > Ex citatio n s  > A s s ig n  > W av e P o r t
2 . W a v e P o r t : G ener a l

1. N a me: p1,  
2 . C lick  the N ex t b utto n

3 . W a v e P o r t : M o d es
1. N umb er  o f  M o d es : 5,  C lick  the U pd a te b utto n
2 . F o r  M o d e 1,  click  the U n d ef i n ed co lumn a nd  s elect N ew  L i n e
3 . U s ing  the co o r d ina te entr y  f ield s ,  enter  the v ecto r  p o s itio n

X : 0 . 0 ,  Y : 0 . 0 ,  Z : 0 . 0 ,  P r es s  the E n ter  k ey
4 . U s ing  the co o r d ina te entr y  f ield s ,  enter  the v er tex

d X : 0 . 0 ,  d Y : 0 . 0 ,  d Z : 8 . 0 ,  P r es s  the E n ter  k ey  
F o r  M o d e 1,  click  the Z pi co lumn a nd  s elect Z pv

1. C lick  the N ex t b utto n
4 . W a v e P o r t : P o s t P r o ces s ing  

1. C lick  the N ex t b utto n
5 . C lick  the F i n i sh b utto n
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Create Wave Port Excitation 2
To select the object Port1:

1. Select the menu item Edit > Select > By Name
2 . Select O b j ect D ia lo g ,  

1. Select the o b j ects  na med :  Port1
2 . C lick  the O K  b utto n

To d u p li ca te the p ort:
1. Select the menu item,  Edit > D u p licate > A lo n g  L in e
2 . U s ing  the co o r d ina te entr y  f ield s ,  enter  the f ir s t p o int o f  the d up lica te v ecto r

X :  0 . 0 ,  Y :  0 . 0 ,  Z :  0 . 0 ,  P r es s  the E n ter k ey
3 . U s ing  the co o r d ina te entr y  f ield s ,  enter  the s eco nd  p o int o f  the d up lica te 

v ecto r
d X :  20 0 . 0 ,  d Y :  0 . 0 ,  d Z :  0 . 0 , P r es s  the E n ter k ey

4 . D up lica te A lo ng  L ine W ind o w s
1. T o ta l N umb er :  2
2 . C lick  the O K b utto n 

5 . C lick  the D on e b utto n
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Boundary Display
To verify the boundary setup:

1. Select the menu item HFSS > Boundary Display ( Solv e r V ie w )
2 . F r o m the So lv er  V iew  o f  B o und a r ies ,  to g g le the V is ib ility  check  b o x  f o r  the  

b o und a r ies  y o u w is h to  d is p la y .
N ote: T he b a ck g r o und  ( P er f ect C o nd ucto r )  is  d is p la y ed  a s  the outer
b o und a r y .
N ote: T he P er f ect C o nd ucto r s  a r e d is p la y ed  a s  the sm etal b o und a r y .
N ote: Select the menu item,  V ie w  > V isib ilit y to  hid e a ll o f  the 
g eo metr y  o b j ects .   T his  ma k es  it ea s ier  to  s ee the b o und a r y

3 . C lick  the C l ose b utto n w hen y o u a r e f inis hed
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Analysis Setup

Creating an Analysis Setup
To create an analysis setup:

1. Select the menu item HFSS > Analysis Setup > Add Solution Setup
2 . So lutio n Setup  W ind o w :

1. C lick  the G eneral ta b :
So lutio n F r eq uency : 2 0 G H z

2 . C heck  S olv e P orts O nly �
3 . C lick  the O K b utto n

Ad d ing a F req uenc y Sw eep
To ad d  a f req uency sw eep:

1. Select the menu item HFSS > Analysis Setup > Add Sw eep
1. Select So lutio n Setup :  S etup1  
2 . C lick  the O K b utto n

2 . E d it Sw eep  W ind o w :
1. Sw eep  T y p e: I nterpolating

E r r o r  T o ler a nce:  0 . 5 %
M a x  So lutio ns :  2 0

2 . F r eq uency  Setup  T y p e: L inear C ount
Sta r t: 0 . 1 G H z
Sto p : 5 0 . 1 G H z
C o unt: 8 1

3 . C lick  the O K b utto n
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Save Project
To save the project:

1. In an  Ansoft HFSS window, select the menu item File > Save As.
2 . Fr om the S ave A s window, ty p e the Filename:  hf ss_ w aveports
3 . C lick  the S ave b utton

Analyze

M od el  V al i d ati on
To val i d ate the m od el :

1. Select the menu item H FSS > V alid at io n  C h ec k
2 . C lick  the C l ose b utton

N ote: T o v iew any  er r or s or  war ning  messag es, use the M essag e 
M anag er .

A n al y z e
To start the sol u ti on  process:

1. Select the menu item H FSS > An aly z e
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Solution Data
To view the Solution Data:

1. Select the menu item HFSS > Results > Solution Data
To view the P r of ile:

1. C lick  the P r of ile T a b .
To view the M atr ix  Data:

1. C lick  the M atr ix  Data T a b
2 . C lick  the C los e b utto n
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Create Reports

Create Propagation Constant vs. Frequency
To Create a report:

1. Select the menu item HFSS > Results > Create Report
2 . C r ea te R ep o r t W ind o w :

1. R ep o r t T y p e:  M od al  S  P aram eters
2 . D is p la y  T y p e:  R ec tan g u l ar
3 . C lick  the O K  b utto n

3 . T r a ces  W ind o w :
1. So lutio n:  S etu p1 : S w eep1
2 . C lick  the Y ta b

1. D o ma in:  S w eep
2 . C a teg o r y :  G am m a
3 . Q ua ntity :  G am m a( p1 :1 ) , G am m a( p1 :2 ) ,  G am m a( p1 :3 ) ,  

G am m a( p1 :4 ) ,  G am m a( p1 :5 )
4 . F unctio n:  i m
5 . C lick  the A d d  Trac e b utto n

3 . C lick  the D on e b utto n
4 . See nex t p a g e f o r  p lo t a nd  d is cus s io n o f  r es ults
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Create Reports

Discussion
What does this plot tell us? 
G iv en  the phy sic al siz e of  the w av e por t ob j ec t that w e c r eated, the f un dam en tal 
m ode ( p2 : 1 )  is a q uasi-T E M  m ode that pr opag ates f r om  D C  on  up.
T his also show s that hig her  or der  m odes c an  pr opag ate ( b > 0 )  at a hig h en oug h 
f r eq uen c y .  T he sec on d m odes star ts pr opag atin g  at ~ 1 4  G H z .
T her ef or e,  if  w e on ly  n eeded to sim ulate up to 1 0  G H z ,  w e w ouldn ’ t n eed to siz e 
our  por t an y  dif f er en t,  how ev er ,  if  w e n eed to sim ulate up to 5 0 G H z ,  then  w e 
n eed to r esiz e our  por t to elim in ate the hig her  or der  pr opag atin g  m odes.
T he last par t of  the ex er c ise w ill ex plor e this.
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Field Pattern Plots
It might be illuminating to look at the field patterns at the port to disc ov er w hic h 
modes are ex c ited.
To display the Mode field patterns in the modeler:

1. F rom w ithin the proj ec t manager,  ex pand the sec tion P ort F ield D isplay
2 . E x pand p1 ,  and selec t Mode 2

1. T he field pattern w ill be ov erlaid on the 3 D  model.  F rom the plot 
below ,  M ode 2  is c learly  not a mic rostrip mode,  but a T E 10 -like w av eguide mode.



Ansoft High Frequency Structure Simulator v9 User’s Guide 

6.5
Example – W av e P o r t s

6.5-2 0

Optimetrics Setup – P a ra metric Sw eep

Add a Parametric Sweep
1. Select the menu item HFSS > Optimetrics Analysis > Add Parametric
2 . Setup  Sweep Analysis W ind o w :

1. C lick  the Sweep D ef init io ns ta b :
1. C lick  the Ad d b utto n
2 . A d d / E d it Sw eep  D ia lo g

1. V a r ia b le:  P o r t _ W id t h
2 . Select L inear  St ep
3 . Sta r t:  2 0 0 m il
4 . Sto p :  6 0 0 m il
5 . Step :  1 0 0 m il
6 . C lick  the Ad d > > b utto n
7 . C lick  the O K b utto n

2 . C lick  the O K b utto n
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Save Project
To save the project:

1. In an  Ansoft HFSS window, select the menu item File > Save.

Analyze

M od el  V al i d ati on
To val i d ate the m od el :

1. Select the menu item H FSS > V alid at io n  C h ec k
2 . C lick  the C l ose b utton

N ote: T o v iew any  er r or s or  war ning  messag es, use the M essag e 
M anag er .

A n al y z e
To start the sol u ti on  process:

1. E x p and the P r oj ect T r ee to disp lay  the items listed under  O pti m etri cs
2 . R ig ht-click  the mouse on P aram etri cS etu p1  and choose A n al y z e 



Ansoft High Frequency Structure Simulator v9 User’s Guide 

6.5
Example – W av e P o r t s

6.5-2 2

Create Reports

Create Propagation Constant vs. Frequency vs. Port_ W id th
To Create a report:

1. Select the menu item HFSS > Results > Create Report
2 . C r ea te R ep o r t W ind o w :

1. R ep o r t T y p e:  M od al  S  P aram eters
2 . D is p la y  T y p e:  R ec tan g u l ar
3 . C lick  the O K  b utto n

3 . T r a ces  W ind o w :
1. So lutio n:  S etu p1 : S w eep1
2 . C lick  the Sw eep s  ta b

1. Select the S w eep D es i g n  an d  P roj ec t V ari ab l e V al u es b utto n
3 . C lick  the Y ta b

1. D o ma in:  S w eep
2 . C a teg o r y :  G am m a
3 . Q ua ntity :  G am m a( p1 :2 ) ,  
4 . F unctio n:  i m
5 . C lick  the A d d  Trac e b utto n

4 . C lick  the D on e b utto n
5 . See nex t p a g e f o r  p lo t a nd  d is cus s io n o f  r es ults
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Create Reports

Discussion
What does this plot tell us? 
T his show s that as w e dec r ease the w idth of  the por t,  the f r eq uen c y  at w hic h the 
hig her  or der  m ode star ts to pr opag ate in c r eases.
T her ef or e,  b y  pr oper ly  siz in g  the w av e por t,  y ou c an  elim in ate an y  hig her  or der  
pr opag atin g  m odes if  y ou b eliev e that they  do n ot ex ist.
Y ou n eed to use c aution  if  y ou ar e sim ulatin g  v er y  hig h f r eq uen c ies,  i. e. ,  
m illim eter  w av elen g ths,  as y ou m ay  n ot b e ab le to m ak e the por ts sm all en oug h 
to elim in ate these m odes.  Y ou pr ob ab ly  shouldn ’ t ev en  tr y  as the hig her  or der  
m odes m ig ht r epr esen t r eal w or ld ef f ec ts.




