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Conventions Used in this Guide

Please take a moment to review how instructions and other
useful information are presented in this guide.

* Procedures are presented as numbered lists. A single bul-
let indicates that the procedure has only one step.

* Bold type is used for the following:

- Keyboard entries that should be typed in their entirety
exactly as shown. For example, “copy file1l” means to
type the word copy, to type a space, and then to type
filel.

- On-screen prompts and messages, names of options and
text boxes, and menu commands. Menu commands are
often separated by carats. For example, click
HFSS>Excitations>Assign>Wave Port.

- Labeled keys on the computer keyboard. For example,
“Press Enter” means to press the key labeled Enter.

e |talic type is used for the following:
- Emphasis.
- The titles of publications.

- Keyboard entries when a name or a variable must be
typed in place of the words in italics. For example,
“copy file name” means to type the word copy, to type
a space, and then to type a file name.

* The plus sign (+) is used between keyboard keys to indi-
cate that you should press the keys at the same time. For
example, “Press Shift+F1” means to press the Shift key
and the F1 key at the same time.

* Toolbar buttons serve as shortcuts for executing com-
mands. Toolbar buttons are displayed after the command
they execute. For example,

“On the Draw menu, click Line s means that you can
click the Draw Line toolbar button to execute the Line
command.
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Getting Help

ANSYS Technical Support

To contact ANSYS technical support staff in your geographical
area, please log on to the ANSYS corporate website, https://
www1.ansys.com. You can also contact your ANSYS account
manager in order to obtain this information.

All ANSYS software files are ASCII text and can be sent conve-
niently by e-mail. When reporting difficulties, it is extremely
helpful to include very specific information about what steps
were taken or what stages the simulation reached, including
software files as applicable. This allows more rapid and effec-
tive debugging.

Help Menu
To access online help from the HFSS menu bar, click Help and
select from the menu:

* Contents - click here to open the contents of the online
help.

* Seach - click here to open the search function of the
online help.

* Index - click here to open the index of the online help.

Context-Sensitive Help

To access online help from the HFSS user interface, do one of

the following:

* To open a help topic about a specific HFSS menu com-
mand, press Shift+F1, and then click the command or
toolbar icon.

* To open a help topic about a specific HFSS dialog box,
open the dialog box, and then press F1.


https://www1.ansys.com/customer/
https://www1.ansys.com/customer/
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HFSS-IE: RCS Test
Model

This example looks at the scattering from a standard RCS
test model, the ogive.

We will look at the scattering from a conducting ogive
with a length of 10" and a half angle of 22.6° = 0.3948
radians. The ogive lies with its axis along the x axis. The
equation that defines this model is:

F(x) = sqrt{l - [(x/5.0)*sin(22.6°)]"2} - cos(22.6°)
y = F(x)*cos(¢)/[1-cos(22.6°)]
z = F(x)*sin(¢p)/[1-cos(22.6°)]

assuming that the x, y, z are defined in inches.

HFSS-IE: RCS Test Model -1
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Creating the Model

Creating this model is very straightforward. We will create an
equation based curve in the x-y plane and then sweep around
the x axis to create the 3D solid.

1

Open a project and insert a new HFSS-IE design.

The default units can be changed to inches (in) if you
desire, but we will ensure the proper units when defining
the model so you can leave it at the default of mm.

Click Draw>Equation Based Curve.
The Equation Based Curve dialog opens.

Let x = the parametric variable (=_t). In the x-y plane z=0
so the equation for y is:

y = (sgrt(l-( t*sin(.3948)/5)"2) - cos(0.3948)

The angles are entered in radians and to insure the units
are handled properly we multiply each nonzero term (x
and y) by the quantity: (1in). So in the Equation Based
Curve dialog, you enter the equations as follows:

X(_1)=_t*(Lin)
Y (1) = (sqrt(1-(_t*sin(.3948)/5)"2)-cos(.3948))/(1-cos(.3948))* (Lin))

Z(H=0
Start _t=-5
End t=5

Number of Points= 24

-2 HFSS-IE: RCS Test Model
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When you click OK to close the dialog and execute the
command, you should see a line like the following:

Look in the History tree under Lines and Equation Curvel
and double-click on CreateEquationCurve. This lets you
view the command Properties window which includes the
setup shown, with the Value column expanded for com-
pete viewing.
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Mame | Value | Linit | Evaluated Value
Command CreateEquationCurve
_Ccucurdinate Sys... Global
e _t{1in) -
] Yi_t) {sqrt{1-{_t"sin{ 3948)/5) " Z}-cos( 3948))/{1-cos( 3948))(1in)) -
|z 0 0
EEE: 5 5
- |End t 5 5
| |Number of Foi... |24 24

If the line does not display as expected, you can edit the
value fields here.
There are no curvilinear elements in HFSS-IE so all curved
surfaces are approximated with segmented models. With
that in mind it is recommended you enter the desired
number of segments in the Number of Points box here.
This allows you to easily adjust the model later if so
desired. What will result is a polyline called
EquationCurvel.

3 Select EquationCurvel and then click Draw>Sweep
>Around AXis.

The Sweep Around Axis dialog displays.

4 In the Sweep Around Axis dialog select X axis, Angle of
sweep = 360, and Number of segments = 24 as shown.

-4 HFSS-IE: RCS Test Model



Getting Started with HFSS-IE: An RCS Test Model

Sweep Around Axis |
Sweep axis: (O Cy Z
Angle of sweep: ISEEI Ideg LI
Diraft angle: IEI Ideg ;I
Diraft type: I R ound ;I
MHumber of zegments: |24 ::ll

] | Cancel |
5 Click OK

The result then should be a solid that is the desired ogive:

The default material assigned to this object is likely cop-
per. Typically these shapes are fabricated using aluminum.

6 Select the ogive object and in the Properties window click
on the word copper in the Material box and select edit.

MName | Value I it |E\raluated

MName

[

EquationCurve1

-

Crientation
| MDdEl "CDDDEFH
Displav Wirefra. | vacuum”

This opens the Materials selection dialog.
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7 In the Material selection window chose aluminum and click
OK.

The model is finished. It has no airbox to worry about so the
model, material and boundary setups are complete.

Add an Incident Plane Wave

We next need to add the source in this case the incident plane
wave. We will compute the monostatic RCS in a the x-y plane.
Since it is monostatic RCS we will need to include many inci-
dent angles. For the scattering computed here we should get
a clean response if we solve every 3°.

1 With the model not selected, right click in the model win-
dow select Assign Excitation>Incident Wave>Plane Inci-
dent Wave from the short cut menu.

The Incident Wave Source: General Data dialog opens.

2 In the General Data dialog select Spherical for Format and
leave the Zero Phase Position as (0,0,0).

3 Click Next and in the Spherical Vector Setup window, for
Iwave phi Start as 0, Stop as180 and Step as 3.

4 For IWave theta select Start as 90, Stop as 90 and Step as
0.

5 Last set the magnitude for Eo Vector Phi =1 and E theta =
0.

-6 HFSS-IE: RCS Test Model
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Incident Wave Source : Spherical Vector Setup

IWavePhi

Start |D |u:|eg j Step |3 |u:|eg j
Stop 180 |E|EEI ﬂ View Point List.. |
[WaveTheta

Start [90 ldeg ~| Step [0 [deg  ~|
Stop |E'I} ||jeg ﬂ View Point List... |
Eao Vectar

Phi |1 Vim

Theta |0 Vim

|se Defaults

6 Click Next and then Finish and the excitation is defined.
The Incident Plane wave appears under Excitations in the
Project tree. If you select the Incident Plane wave, the
Modeler window shows it as follows.

This will solve for the response due to incident planes waves
that are incident in the 8=90°and for ¢= 0 to 180° for 61 val-
ues. The polarization is ¢ directed so we will be solving for
the HH monostatic RCS.

HFSS-IE: RCS Test Model -7
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Adding the Solution Setup

The last step is to add the solution setup.

1 Right click on Analysis under the IEDesign in the Project
Manager window and select Add Solution Setup.

----- BE Mesh Operations

----- SET

@ Ot

----- Fiel
..... Ran
5123 Definitic

-3 Mat

This opens the Solution Setup dialog.

2 In the General tab change the Frequency to 1.18 GHZ.
Leave the rest at its default values.

3 That s all that is needed. Click OK now or if you desire you
can look at the Options tab where you should see that the
default lambda refinement is 0.25 (=14/4).

..... Res ¥ Add Solution Setup..

List...

The Ogive project setup is compete.

Run the Simulation
To run the simulation:

1 Right-click on the Setup just created in the Project Man-

ager window and select Analyze.

2 It should first ask you to save the project by asking a proj-
ect name - enter anything you desire. Once the project has
been saved it will simulate and should solve quickly in 2

passes.

Plotting the Current

To view the current on the ogive:

1 Select the ogive in the model window and right click and

go to: Fields>J>Mag_J.

This opens the Create Field Plot dialog.

-8 HFSS-IE: RCS Test Model
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2 Click on Done.
You will see the induced current for ¢=0° incident angle:

Plotting the RCS

To plot the RCS you first must enter a Far Field setup - the
same as for HFSS. We will create a far field setup with only 1
¢ angle = 0° and one 6 angle = 90°. We will be plotting the
monostatic RCS and so will be plotting against the incident phi
angle and not the observation angles defined here. So we only
need one angle for each.

1 Right click on Radiation in the Project tree of the Project

Manager window and select Insert Far Field Setup>Infi-
nite Sphere...

. 1.%y Field Overlays

P

ElD Definitions | Insert Far Field Setup | Infinite Sphere... ||
I:l Materials Insert Mear Field Setup L
Antenna Array Setup...

The Far Field Radiation Sphere Setup dialog opens.
2 Enter Start and Stop for Phi as 0 and the step size 10.
3 Enter Start and Stop for Theta as 90 and the Step size 10.

HFSS-IE: RCS Test Model -9
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You should have the following:

Mame |Infin'rte Sphere1

Phi
Start o jdeg v
Stop 0 ldeg v
Step Size |10 ldeg =]

Theta
Start EN |deg

=l
Stop |5I} |-:Ieg ﬂ
=l

Step Size |1 ] ||:|eg

Save As Defaults | View Sweep Points... |

4 Click OK.

This closes the dialog and creates InfiniteSpherel under
Radiation in the Project tree.

5 To create the plots, right click on Results in the Project
tree and click Create Far Fields Report>Rectangular
Plot.

The Reports dialog opens.

6 Specify the following: for Category: Monostatic RCS; for
Quantity: MonostaticRCSPhi; and for Function: dB.

7 Change the Primary Sweep from Theta to IWavePhi (we
want to plot the RCS vs. the incident phi angles).

8 Click New Report.
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The resulting plot should resemble this:

XY Plot 1 IEDesign1 2.

dB(MonostaticRCSPhi)

Curve Info

—— dB{MonostaticRCSPhi)
Setup1 : LastAdaptive
Freg="1.18GHZ IWaveTheta="80deq" Phi="0Odeqg" ...

00

5000 10000 15000  180.00
IWavePhi [deq]

This is the HH monostatic RCS pattern for the standard ogive
at 1.18GHZ.

Again these post processing functions are the same as for
HFSS (except you plot shade plots of J not E). You may want
to take some time and work with the post processor. For
example it is interesting to create an animation of the current
shade plot vs. incident angle.
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