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9.1 Setting up the PCB 

9.1.1 Board Options dialog 
The Board Options dialog allows you to set parameters relating to individual PCB documents. 
Select Design » Board Options (DO) from the menus to open the dialog. The settings in this 
dialog are saved with the PCB file.  

 
Figure 1. Set grid options in the Board Options dialog. 

Measurement Unit 

Sets the coordinate system to either metric or imperial. 

Snap X X value for the snap grid 

Snap Y Y value for the snap grid 

Component X X value for the component grid 

Component Y Y value for the component grid. 

Electrical Grid 

When the electrical grid is enabled and you are executing a command which supports the 
electrical grid and you move the cursor within the Grid Range value of an object assigned to a 
net, the cursor will jump to that object. 

Visible Grid 

Sets the size and style of the visible grids. 

Sheet Position 

The sheet is a calculated object, drawn to represent the printed page. The sheet size can either 
be defined by the Size and Location settings in this dialog, or it can be linked to the contents of 
mechanical layer(s). If it is linked to the contents of mechanical layer(s), you can use the Design 
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» Board Shape » Auto-position Sheet command to recalculate it when the contents of the 
linked mechanical layers change.  

Typically, the linked mechanical layers would be used for drawing detail that is required on the 
printout. Another advantage of linking the sheet to mechanical layers is that both the sheet and 
the mechanical layers can be hidden by disabling the Display Sheet option. 

Note: It’s a good idea to turn off the sheet when attempting to place the components on the 
PCB after transferring the design from schematic. The reason for this is generally the sheet 
color is white and the selection color is also white, making it hard to see the components when 
they are picked up and moved using the cursor. 

Designator Display 

The designator display can be either the logical designator shown on the schematic or the 
physical designator assigned when the design is compiled. Normally, these are the same except 
in a multi-channel design when the physical designator includes channel identifier information. 

9.1.2 View Configurations 
• This dialog is used to set the display state and color of each layer in the PCB in 2D view 

mode, and the colors and transparency in 3D view mode (L shortcut key to open the dialog).  
• It is also used to configure other view related information, such as the display of each object-

kind, and the display of net names on pads.  
• View configurations can be saved and reloaded, with the last-used view configuration being 

automatically applied when the board is re-opened.  

 

Figure 2 View Configurations dialog 
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Signal Layers and Internal Planes 

These layers are added too and removed from the PCB in the Layer Stack Manager. Their color 
and display state is controlled in this dialog. 

Note: Press the accelerator key in brackets () next to the layer name to toggle that layers show 
property while in this dialog 

Mechanical Layers 

There are 32 mechanical layers, disable the Only Show Enabled option to display the entire set 
and enable a new mechanical layer for this PCB. Press F2 to edit the name of a mechanical 
layer. 

Layer Pairs 

Layer pairs are mechanical layers that have been associated to handle layer-specific component 
data. For example, if you have component footprints that require glue information, define this on 
a mechanical layer in the Library Editor, then pair this mechanical layer with another. When the 
footprint is flipped to the bottom of the board, the information on the first mechanical layer is 
automatically transferred to the paired mechanical layer. 

Color Sets 

The Default Color Set button sets the colors to the default settings with a pale yellow 
background. Default colors cannot be used if the Transparent Layers option (Display tab) is 
selected. The Classic Color Set button sets the colors to the traditional black background 
setting. 

Keep-Out Layer 

The keep out layer is a special layer. Objects placed on the keep out layer act as an obstacle or 
boundary to an object placed on any signal layer. The keep out layer is typically used to define 
regions such as the board routing and placement boundary, or areas of the board that must be 
kept free of components and routing. The keep out layer is discussed more in section 9.2. 

9.1.3 The PCB coordinate system 
The PCB Editor has a coordinate system with the origin located in the bottom left hand corner of 
the workspace. This point has the coordinates of (0,0) and is known as the Absolute Origin. The 
workspace size is 100 inches by 100 inches. The reference point of the coordinate system can 
be re-defined at any time using the Edit » Origin » Set menu command and this sets what is 
known as the relative Origin. The coordinate readout in the status bar references this relative 
Origin. The Edit » Origin » Reset menu command sets the relative Origin back to the Absolute 
Origin. 

An Origin Marker shows the location of the relative Origin. This is displayed by checking the 
Display Origin Marker check box in the Display tab of the Preferences dialog. 

The coordinate system units can be either metric or imperial. The View » Toggle Units menu 
command or the Q shortcut key toggles the co-ordinate system between metric and imperial. 

9.1.4 Grids 

9.1.4.1 Snap Grid 
The Snap Grid ensures accurate movement and placement of objects. The Snap Grid causes 
the coordinates of a mouse click to snap to the nearest snap grid point. The Snap Grid has X 
and Y values and is set in the Board Options dialog. Press G or CTRL+G shortcuts to change the 
grid.  
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9.1.4.2 Component Grid 
The Component Grid is similar to the Snap Grid except that it is only active when placing or 
moving components. The Component Grid has X and Y values and is set in the Board Options 
dialog. 

9.1.4.3 Visible Grid 
The Visible Grids either display as lines or dots when turned on. They are independent of the 
Snap Grid. The PCB Editor has two visual grids that you can set in the Board Options dialog and 
display independently.  

9.1.4.4 Electrical Grid 
The Electrical Grid can be thought of as a range of 
attraction. During interactive editing the cursor will 
jump to any existing electrical object when the cursor 
falls within the range of the electrical grid setting.  

F
g

When the Electrical Grid overrides the Snap Grid an 
octagon displays on the cursor when the hot-spot (or 
electrical centre-point) is under the cursor. When you 
see that octagon, you know that the cursor is precisely 
located on the object it has jumped to.  

The Electrical Grid is set and turned on or off in the 
Board Options dialog. You can also toggle the 
Electrical Grid on and off using the SHIFT+E shortcut, 
or disable it temporarily during an edit-type operation 
(such as interactive routing) by holding down the CTRL 
key. 

Shortcut keys for setup options  

Pressing the O shortcut key displays a menu that provide
dialogs. Combine this shortcut with the underlined letter in
the board options. The options in this menu are described

Note: Right click on a layers tab at the bottom of the PCB
dialogs and commands. 

 

Option Dialog displayed 

Board Options Board Options dialog 

Board Layers View Configurations dialog  

Layer Stack Manager Layer Stack Manager dialog 

Classes Object Classes dialog 

Preferences General tab of Preferences d

Display Display tab of Preferences d

Show/Hide Show/Hide tab of View Conf

Defaults Defaults tab of Preferences 

Table 1. Dialogs and preferences in PCB 
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9.1.4.5 Exercise – Exploring document and environment options 
Use this exercise to experiment with document and environment options.  

1. Open the document 4 Port Serial Interface.PcbDoc located in the \Altium 
Designer Summer 09\Examples\Reference Designs\4 Port Serial 
Interface folder. 

2. Experiment with the Used On, All On and All Off buttons and with turning on and off 
individual layers in the Board Layers & Colors dialog. 

3. Observe the display change when the Display Sheet option is toggled in the Board Options 
dialog. 

4. Experiment with changing the colors of various layers. 

5. Now, experiment with changing the various grid settings to see changes in the grid display 
and object movement in the Board Options dialog. 

6. In the PCB Editor » Defaults page of the Preferences dialog, select Component and click 
on the Edit Values button. In the Comment section of the Component dialog, make sure the 
Hide option is enabled. Also check the Autoposition option is set to Left-Above in the 
Designator section.  
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9.2 Creating a new PCB 
This section looks at how to create a new PCB using the Board Wizard. 

9.2.1 Creating the Blank PCB 
There are three ways to create a new PCB: 

• Select File » New » PCB from the menus. This creates an empty PCB workspace, with a 6in 
by 4in board shape. 

• In the New from Template region of the Files panel, select PCB Templates. This opens the 
Choose Existing Document dialog where you can select from an array of template files. The 
template name indicates the sheet size and each template file also includes a default board 
shape, typically 6in by 4in. 

• Using the Board Wizard. This is launched from the bottom of the Files panel. The Wizard can 
be used to select from a pre-defined list of industry standard board shapes or generate a 
simple board outline. 

 

Figure 4. A new PCB created by using the New from Template option. 

9.2.2 Defining a sheet template 
The PCB sheet template is simply a display feature that is linked to mechanical layers in the 
PCB design. In the View Configurations dialog there is a checkbox next to each mechanical 
layer, titled Linked to Sheet. Any layer with this enabled is used by the software to calculate the 
size of the white sheet region. 

• Define a template on a mechanical layer using the standard design objects, enable the 
Linked to Sheet checkbox, and enable the display of the sheet in the Board Options dialog. 
If you change the shape or size of the template, select Design » Board Shape » Auto 
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Position Sheet from the menus to automatically resize the white sheet region to just enclose 
all objects on the linked mechanical layers. 

• There are a number of pre-defined PCB sheet templates in the \Altium Designer 
Summer 09\Templates folder, open the required size and copy the contents of Mechanical 
16 into your own PCB to create a sheet template. 

9.2.3 Defining the Board Shape, and Placement / Routing   
Boundary 

Once the blank board has been created the next step is to define the shape of the board 
(typically this is the final finished board shape), and the routing and placement boundary.  

• The board shape can be defined manually using the commands in the Board Shape sub-
menu, or by getting the software to define it automatically from a set of selected objects. 
Defining it from selected objects is typically done when you have imported a board shape 
definition from another tool, such as a mechanical CAD package. 

• The placement and routing boundary is defined by placing a continuous barrier on the Keep 
out layer. Any object placed on the keep out layer is considered an obstacle to objects on all 
the signal layers. Typically the keep out boundary is defined along, or slightly in from the 
board outline, taking into consideration any mechanical clearance requirements, such as 
brackets, card guides, and so on.  

 
Figure 5. Board shape (black region) and keep out boundary for the 4 Port Serial Interface example PCB. 
The row of small fills is there to prevent routing between the contacts of the edge connector. 
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9.2.4 Exercise – Creating a board outline & placement / routing 
boundary 

This exercise creates a new board outline for the training example. 

1. Display the Files panel (System » Files from panel control) and click on the PCB Templates 
option in the New from template section. 

2. Choose A4.pcbdoc in the Choose Existing Document dialog. The new blank PCB will 
open, as shown in , where the black region on the sheet represents the board 
shape. We will now redefine it based on data in a DXF mechanical file.  

Figure 4

3. Select File » Import to display the Import File dialog. 

4. Set the Files of Type option to AutoCAD (*.DXF, *.DWG) 

5. Browse and locate the file \Altium Designer Summer 09\Examples\Training\PCB 
Training\Temperature Sensor\Outline.DXF and open it. 

 

Figure 6. Import the board shape from a DXF file. 

6. When the Import from AutoCAD dialog appears, set the following: 

7. Set the Scale to mm (the imported shape should be approximately 2021mil x 2755mil) 
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8. In the Layer Mapping, map the source DXF layer to mechanical layer 4 

9. Set the Insertion Point to something sensible, for example X=1000, Y=1000. The value is 
not crucial, as you will move it after importing. 

10. leave other options at their defaults 

11. When the OK button is clicked, a shape, forming a rectangle like shape, will appear on 
Mechanical layer 4. 

12. We will now redefine the board shape to match this shape. Select the shape segments (drag 
a rectangle around them). 

13. Select Design » Board Shape » Define from selected objects. The black board shape will 
redefine to match the imported tracks. 

14. To move the new board shape to the centre of the sheet, drag a rectangle to select the 
board shape and the mechanical layer tracks, press the M key to display the Move submenu 
and select Move Selection. Click somewhere on the selection to define the point where it 
will be held, then move the board outline and mechanical layer tracks approximately to the 
centre of the sheet, and click to place them.  

Note: To ensure that objects remain on your preferred working grid it is generally better to 
select a meaningful point when moving or copying & pasting objects, in this case the point 
at the bottom left of the rectangle where the vertical and horizontal tracks meet would be 
suitable. If you want to set your reference point based on an object, make the layer that the 
object is on the active layer – that way the electrical grid will pull the cursor to a meaningful 
point on the object. Alternatively, press Shift+E to toggle to the Electrical Grid (All Layers) 
mode. 

15. Change the Visible grid 2 to 100 mils in the Board Options dialog. 

16. To define the placement / routing boundary first deselect all. The easiest way to select all the 
tracks on Mechanical layer 4 is to use the select on current layer command. To do this, make 
the Mechanical layer the active layer (use the layer tabs at the bottom of the PCB 
workspace), press S for select, then Y to select all on the current layer.  

17. Choose Edit » Copy from the menus, choosing an appropriate reference point to hold the 
selection by when prompted (such as one of the corners). 

18. Make the Keep out layer the current layer. If the Keep out layer is not currently enabled, 
press L to display the View Configurations dialog and enable it. 

19. You are now going to paste the selection onto the current layer (the Keep out layer). To do 
this select Edit » Paste Special from the menus, enable the Paste on Current Layer option 
in the Paste Special dialog, and click Paste to return to the workspace where you can paste 
the tracks onto the keep out layer. 

20. Save the new PCB as \Altium Designer Summer 09\Examples\Training\PCB 
Training\Temperature Sensor\Temperature Sensor.PcbDoc. 

21. Check in the Projects panel If the board is part of the Temperature Sensor project. If it is 
not, click and drag the board, dropping it on the project name. 

22. Right-click on the project name and choose Save Project from the floating menu. 
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9.3 Setting up the PCB layers 

9.3.1 Enabling Layers 
The PCB Editor has a concept of design layers to represent the various physical layers created 
to fabricate a printed circuit board. When placing objects using the PCB Editor, you need to 
consider which layer they are to be placed on. Objects are placed on the current layer, shown as 
the active layer tab at the bottom of the PCB workspace.  

• Electrical layers are added in the Layer Stack Manager dialog (Design » Layer Stack 
Manager). 

 

Figure 7. Define the required electrical layers in the Layer Stack Manager dialog. 

• Layer display and the control of other non-electrical layers is done in the View Configurations 
dialog  (Design » Board Layers & Colors). 

 

Figure 8. Control the display of layers in the View Configurations dialog. 
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• The current layer (the layer you are placing on) is set by any of the following: 
• Clicking on the appropriate Layer tab at the bottom of the workspace, 
• Pressing the * key to toggle to the next copper layer,  
• Pressing the + or – keys on the numeric pad to move up or down to the next layer. 

9.3.2 Layer definitions 
Each of the PCB Editor layers is described below. 

Signal Layers 
There are 32 signal layers that can be used for track placement. Anything placed on these layers 
will be plotted as solid (copper) areas on the PCB. As well as tracks, other objects (e.g. fills, text, 
polygons, etc.) can be placed on these layers. The signal layers are named as follows: 

Top Layer Top signal layer 

MidLayer1 to MidLayer30 Inner signal layers  

Bottom Layer Bottom signal layer 

Signal layer names are user-definable.  

Internal Planes 
Sixteen layers (named Internal Plane 1–16) are available for use as power planes. Nets can be 
assigned to these layers and multi-layer pads and vias automatically connect to these planes. 
Plane layers can be split into any number of regions, with each region being assigned to a 
different net. Nested split planes are supported. Internal Plane layer names are user-definable. 
Internal planes are designed and output in the negative, objects that are placed on the plane 
define regions of no copper.  

Silkscreen layers 
Top and Bottom Overlay (silkscreen) layers are typically used to display component outlines and 
component text (designator and comment fields that are part of the component description).  

Mechanical layers 
Thirty two mechanical drawing layers are provided for fabrication and assembly details, such as 
dimensions, alignment targets, annotation or other details. Mechanical layer items can be 
automatically added to other layers when printing or plotting artwork. Mechanical layer names 
are user-definable. Mechanical layers can also be paired; use this when creating library 
components that require side-of-board layer-related information, such as glue dots.  

Solder Mask 
Top and bottom Solder Mask layers are provided for creating the artwork used to make the 
solder masks. These automatically generated layers are used to create masks for soldering, 
usually covering everything except component pins and vias. You can control the expansions for 
these masks when printing/plotting by including a Solder Mask Expansion rule, or the manual 
override feature in the pad/via dialogs. Refer to the Design Rules section for more information on 
the Solder Mask Expansion rule. User-defined openings in the mask can also be created by 
placing design objects directly on the mask layer. These layers are designed in the negative, the 
visible objects become openings in the mask. 

Paste Masks 
Top and bottom Paste Mask layers are provided to generate the artwork which is used to 
manufacture stencils to deposit solder paste onto surface mount pads on PCBs with surface 
mount devices (SMDs). The size of the paste deposit is controlled by Paste Mask Expansion 
rule, refer to the Design Rules section for further information. It can also be defined using the 
manual override in the pad/via dialog, or by placing objects manually on the paste mask layer. 
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Drill Drawing 
Coded plots of board hole locations are typically used to create a drilling drawing that shows a 
unique symbol for each hole size at each hole location. Individual layer pair plots are provided 
when blind/buried vias are specified. Three symbol styles are available: coded symbol; 
alphabetical codes (A, B, C etc.) or the assigned size.  

Drill Guide 
A drill guide plots all holes in the layout. Drill guides are sometimes called pad masters. 
Individual layer pair plots are provided when blind/buried vias are specified. These plots include 
all pads and vias with holes greater than zero (0) size. 

Keep Out layer 
This layer is used to define the regions where components and routes can validly be placed. For 
example, the board boundary can be defined by placing a perimeter of tracks and arcs, defining 
the region within which all components and tracks must be placed. No-go areas for components 
and tracks can be created inside this boundary by blocking off regions with tracks, arcs and fills. 
Keepouts apply to all copper layers. The basic rule is that components cannot be placed over an 
object on the Keep Out layer and routes cannot cross an object on the Keep Out layer.  

Note that there are also layer-specific keepouts, each standard design object has a keepout 
attribute, and when this is enabled the object behaves as a layer-specific keepout and is 
automatically excluded from Gerber and ODB++ output generation. 

Multi-layer 
Objects placed on this layer will appear on all copper layers. This is typically used for through-
hole pads and vias, but other objects can be placed on this layer. 

System section 
The options described below cannot have objects placed on them but they are turned on or off in 
the System Colors section of the Board Layers & Colors dialog. 

DRC Errors  

This option controls the display of the Design Rule Check (DRC) error marker. 

Connections 

This option controls the display of the connection lines. The PCB Editor displays connection lines 
wherever it locates part of a net that is unrouted. 

Pad and Via Holes 

Controls the display of pad and via holes. To be able to distinguish pads from vias in draft mode, 
pad holes are outlined in the current Pad Holes color. 

Visible Grids 

Controls the display of the two visible grids. 

9.3.3 Exercise – Configuring the layer display 
To confirm that the required layers are displayed: 

1. Press the L shortcut key to display the View Configurations dialog. 

2. Click the Used Layers On link at the bottom of the dialog, to display all layers that have 
objects on them. 

3. Confirm that the Connections and From Tos check box is enabled. 

4. Note that mechanical layer 16 is linked to the sheet.  This layer contains all the objects used 
to create the sheet template. 
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9.3.4 Defining the Electrical Layer Stackup 
The number and order of electrical layers is defined in the Layer Stack Manager dialog. 

 
Figure 9  Layer Stack Manager dialog 

The Layer Stack Manager allows you to visualize the ‘stack up’ of your PCB, i.e. the relationship 
between copper, substrate and Prepreg. A picture of your layer stack can be copied to the 
Windows clipboard and pasted into project documentation by right-clicking and selecting Copy 
to Clipboard.  

9.3.4.1 Adding layers 

Adding a Signal or Plane layer 

Use the buttons on the right to add signal and plane layers to the board. The new layer is added 
below the layer selected in the dialog (unless the selected layer is the Bottom Layer). You can 
also right-click to add new layers. Typically PCBs are fabricated from an even number of layers; 
these can be any mix of signal and plane layers. Double-click on the layer name to define the 
layer name, the copper thickness and assign the net name for plane layers. 

Adding Insulation layers 

As additional layers are added to the PCB, insulation layers are automatically added. The 
insulation layer can be either Core or Prepreg and this is determined by the Stack Up style 
setting.  

9.3.4.2 Working with layers 

Editing layer properties 

Double click on a layer name to edit the layer properties, including the name and the physical 
properties. 

Deleting a layer 

To delete a layer, click on the name text of an existing layer and then click on the Delete button, 
or right-click and choose Delete from the right-click menu.  

Editing the Stack Up order 

To change the order in which layers are defined in your PCB, click on the name of the layer and 
click on the Move Up or Move Down buttons, or right-click and choose Move Up or Move 
Down. 
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Editing the Stack Up style 

The Stack Up style defines the order in which the PCB substrate, copper and prepreg insulation 
layers are fabricated as well as the finish on the PCB. The style is selected in drop down list in 
the top right corner of the Layer Stack Manager. The choices are: 

• Layer Pairs 
• Internal Layer Pairs 
• Build Up. 

The board finish is defined by selecting the buttons next to the Top and Bottom Dielectric check 
boxes. Click on these to set the material, thickness and dielectric constant for the finish. 

9.3.4.3 Where the physical properties are used 
The physical properties that are defined in the different layer dialogs, including insulation type, 
thickness and dielectric constant, and the copper thickness, is used by the signal integrity 
analysis feature. 

9.3.5 Layer Sets 
To define a layer set there is now a tool in PCB that has predefined layer sets or you can create 
your own. This is located in Design » Manage Layer Sets » Board Layer Sets.  

 
Figure 10 Defining new layer sets 

To create a new layer set simply click on New Set, give the set a name and pick the layers you 
wish to include in the set. Layer sets can also be imported and exported to and from PCB 
designs. 
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9.3.6 Drill pairs 
The term drill pairs refers to the two layers that a drilling operation starts from and finishes at. By 
default, one Top-Bottom drill pair is defined. If blind or buried vias are to be used on your PCB, 
layer pairs must be defined for these. Click on the Drill Pairs button in the Layer Stack Manager 
to display the Drill Pair Manager. 

 
Figure 11 Define the drill pairs if the board uses blind/buried vias 

 

9.3.7 Placing a Stackup Legend 
A legend that details the current layer stackup and individual layer properties can be placed 
anywhere in the workspace.  

• Place the legend via the Place Stackup Legend button in Layer Stackup dialog. 
• After clicking once to define the first corner of the legend, press Tab to configure which detail 

should be included. 
• The detail in the legend is automatically determined from the current board configuration, if 

the configuration changes you will need to re-place the legend. 

 
Figure 12. Layer stackup legend setup dialog. 
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Figure 13. Stackup legend placed on a mechanical layer 

 

9.3.8 Defining Mechanical layers 
Mechanical layers are added to the PCB workspace in the View Configurations dialog. Before a 
Mechanical layer can be used, it must be enabled.   

• To enable a new layer first disable the Only show enabled mechanical layers check box. 
This will result in all layers being listed. Enable the new layer, then turn the Only show 
enabled mechanical layers on again. 

• To edit a mechanical layer name, click to select the name and press F2 to edit it. 

 

Figure 14. Setting up Mechanical Layers in the Board Layers & Colors dialog. 

• The Show check box allows you to control the display of a mechanical layer. 
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• When checked, the Display In Single Layer Mode check box causes that layer to be 
displayed when Single Layer Mode is invoked (SHIFT+S). 

• Check the Linked to Sheet check box to relate a mechanical layer to the white sheet object. 
Related mechanical layers are then hidden when the Display Sheet option is disabled (Board 
Options dialog). They are also used to determine the extents of the sheet when the Auto-
position sheet option is chosen in the Board Shape sub-menu. 

9.3.8.1 Mechanical Layer Pairs 
Mechanical layers can be paired. Used this feature when you need extra detail in the component 
footprint, and that detail needs to change to another layer when the component is moved from 
the top side of the board to the bottom side. An example of this is glue dot information.  

• Configure Mechanical pairs by clicking the Layer pairs button at the bottom of the View 
Configurations dialog, or right clicking on the layer tabs and selecting Configure Mechanical 
Pairs. 

• The objects placed on a mechanical layer in the PCB library will flip to its paired layer when 
the component is switched to the bottom of the board.  

• Click the Add, Delete or Mechanical Pair Properties buttons in the Mechanical Layer Pairs 
dialog to modify the mechanical layer pairs. 

 

9.3.9 Internal power planes 
The PCB Editor supports up to sixteen power planes. These planes are defined in the negative –
objects placed on a plane layer become regions of no copper.  

9.3.9.1 Defining an internal power plane 
• An internal power plane is added, named and assigned to a net using the Layer Stack 

Manager. When a net has been assigned to an internal plane layer, pins in that net 
automatically connect to that plane layer using thermal relief connections.  

• Double-click on the plane in the Layer Stack Manager, or in the workspace to assign the net. 
The PCB Editor automatically connects pins that belong to the power plane net and isolates 
all other pins from the plane. 

• The style of plane connections is defined in the Power Plane Connect Style design rule. 
Nets that are not connected to the plane are isolated from it by a clearance that is defined in 
the Power Plane Clearance rule. 

• The pullback, or region of no-copper required around the edge of the PCB, is defined in the 
Edit Layer dialog. Double-click on the plane in the Layer Stack Manager to display this 
dialog. 

9.3.9.2 Defining a split power plane 
• Internal power planes can be split and shared amongst multiple nets.  
• A plane is split by placing objects (typically lines) to divide it into separate regions (select 

Place » Line). As soon as you stop placing lines on a plane the layer is analyzed and each 
separate split region detected.  

• The width of the placed lines defines the clearance between the split regions. Press the TAB 
key during line placement to change this width. 

• Double-click on a split region to assign it to a net. Alternatively, set the display mode of the 
PCB panel to Split Plane Editor. 

• Splits can be created completely within another split region. 
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Figure 15. Split planes on an Internal plane layer with the Split Plane dialog showing the net assignment for 
the large split region (Peak Detector With Banking.PcbDoc). 

9.3.9.3 Re-defining a split plane 
A split plane is defined by the set of objects that make up its boundary. Move and modify these 
to redefine the split plane. 

9.3.9.4 Deleting a split plane 
Delete the split boundary lines to delete a split plane. 

 

9.3.10 Exercise – Setting up layers 
1. Set up the layers in the Layer Stack Manager.  Select layer names, right-click and set the 

properties, i.e. names and copper thickness. Note that you can use the buttons to add and 
delete layers and move them up and down in the stack.  

2. Open the View Configurations dialog and select the layers you need to show in the design 
window, e.g. Top and Bottom layers, Keep-Out Layer, Drill Drawing, Multi Layer and Top 
Overlay. 

3. Show and enable Mechanical layers 1, 4 and 16. Make sure the Only Show enabled 
mechanical layers are deselected first to show all mechanical layers available. Then turn 
this option on again when you have set up the layers you wish to use. Link Mechanical 16 to 
the sheet so that the title block of the template will appear on this layer. 
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