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Introduction  

 Wireless communications have progressed very rapidly in recent years, and many 

mobile units are becoming smaller and smaller. To meet the miniaturization 

requirement, the antennas employed in mobile terminals must have their dimensions 

reduced accordingly. Planar antennas, such as microstrip and printed antennas have 

the attractive features of low profile, small size, and conformability to mounting 

hosts and are very promising candidates for satisfying this design consideration. For 

this reason, compact, broadband and wideband design technique for planar antennas 

have been attracted much attention from antenna researchers. Very recently, 

especially after the year 2000, many novel planar antenna designs to satisfy specific 

bandwidth specifications of present day mobile cellular communication systems 

including the global system for mobile communication (GSM; 890 – 960 MHz), the 

digital communication system (DCS; 1710 – 1880 MHz), the personal communication 

system (PCS; 1850 – 1990 MHz), and the universal mobile telecommunication system 

(UMTS; 1920 – 2170 MHz), have been developed and published in the open 

literature.  

Planar antennas are also very attractive for applications in communication devices 

for wireless local area network (WLAN) systems in the 2.4 GHz (2400 – 2484 MHz) 

and 5.2 GHz (5150 – 5350 MHz) bands.      

The aim of this tutorial is to show you how to use HFSS to design planar antennas for 

wireless communications. Therefore, we have chosen four antennas types; dipole 

antenna, the rectangular patch antenna, probe feed patch antenna and triangular 

microstrip antenna. At the end, we will propose some projects.   
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High Frequency Simulator Structure (HFSS)  

HFSS is a high performance full wave electromagnetic (EM) field simulator for 

arbitrary 3D volumetric passive device modelling that takes advantage of the 

familiar Microsoft Windows graphical user interface. It integrates simulation, 

visualization, solid modelling, and automation in an easy to learn environment 

where solutions to your 3D EM problems are quickly and accurate obtained. Ansoft 

HFSS employs the Finite Element Method (FEM), adaptive meshing, and brilliant 

graphics to give you unparalleled performance and insight to all of your 3D EM 

problems. Ansoft HFSS can be used to calculate parameters such as S-Parameters, 

Resonant Frequency, and Fields. Typical uses include: 

 

 Package Modelling – BGA, QFP, Flip-Chip 

 PCB Board Modelling – Power/ Ground planes, Mesh Grid Grounds, 

Backplanes 

 Silicon/GaAs-Spiral Inductors, Transformers 

 EMC/EMI – Mobile Communications – Patches, Dipoles, Horns, Conformal 

Cell Phone Antennas, Quadrafilar Helix, Specific Absorption Rate ( SAR), 

Infinite Arrays, Radar Section (RCS), Frequency Selective Surface (FSS) 

 Connectors – Coax, SFP/XFP, Backplane, Transitions 

 Waveguide – Filters, Resonators, Transitions, Couplers 

 Filters – Cavity Filters, Microstrip, Dielectric 

 HFSS is an interactive simulation system whose basic mesh element is a 

tetrahedron. This allows you to solve any arbitrary 3D geometry, especially 
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those with complex curves and shapes, in a fraction of the time it would take 

using other techniques.  

 The name HFSS stands for High Frequency Strucutre Simulator. Ansoft 

pioneered the use of the Finite Element Method (FEM) for EM simulation by 

developing / implementing technologies such as tangential vector finite 

elements, adaptive meshing, and Adaptive Lancozos - pade Sweep (ALPS). 

Today, HFSS continues to lead the industry with innovations such as Modes 

to Nodes and Full wave Spice.  

 Ansoft HFSS has evolved over a period of years with input from many users 

and industries. In industry, Ansoft HFSS is the tool of choice for High 

productivity research, development, and virtual prototyping.      
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Chapter one - The Dipole Antenna 
 
I – Introduction 
 
The monopole and dipole antennas are commonly used for broadcasting, cellular 
phones, and wireless communications due to their omnidirective property. Thus in  
this tutorial, a dipole antenna will be constructed and analyzed using the HFSS 
simulator. The example will illustrate both the simplicity and power of HFSS through 
construction and simulation of this antenna structure. The following notes will 
provide a brief summary of goals. 
 

 General navigation of software menus, toolbars, and quick keys. 
 Variable assignment. 
 Overview of commands used to create structures. 
 Proper design and implementation of boundaries. 
 Analysis Setup. 
 Report Creation and options. 

 
 
1- Starting HFSS  

 
- Click the microsoft Démarrer button, Select Programs, and select Ansoft, HFSS 
9.2 program group. Click HFSS 9.2.  
 
- Or Double click on the HFSS 9.2 icon on the Windows Desktop.  

HFSS 9.lnk  
2- Creating the Project 
 
First launch the HFSS Simulator.   
 

 

Project manager 
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From the Project Manager window. Right-Click the project file and select Save As 
from the sub menu.  
 

 
 
Name the file “dipole” and Click Save. 
 

 
 
 
Note: Before click on “Enregistrer”, always create a personal folder to store all 
HFSS projects. 
 
3- Working with geometries 
 
To begin working with geometries. 
 

- you must insert an HFSS design. Right-Click the project file and select Insert 
> Insert HFSS Design from the menu. 
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- Or click on  from the toolbars.      
 
 

 
 

Due to the nature of this design we will use Driven Modal as the solution type. 
From the HFSS menu select Solution Type and Driven Modal.  
 

 

 
O. El Mrabet & M. Essaadi                                                                                                      2005 - 2006 

3



Telecommunication & System UFR                                                                           The Dipole Antenna 
 

 
 
The units are chosen as mm by choosing the heading 3D modeler and Units from the 
menu. 

 

 
 

 

HFSS relies on variables for any parameterization / optimization within the project. 
Variables also hold many other benefits which will make them necessary for all 
projects. 
 

• Fixed Ratios (length, width, height) are easily maintained using variables. 
• Optimetrics use variables to optimize the design according to user-defined 

criteria. 
• All dimensions can be quickly changed in one window as opposed to altering 

each object individually. 
 
Click the HFSS heading and select Design Properties at the bottom of the menu. 
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This will open the variable table. Add all variables shown below by selecting Add. Be 
sure to include units as needed. 

 

 
 

The final variable table should looks like 
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4- Drawing the Dipole 
 
We will start to by creating the dipole element using the Draw Cylinder button  
from the toolbar.  

 
 
By default the proprieties dialog will appear after you have finished drawing an 
object. The position and size of objects can be modified from the dialog.   
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Double click 
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Follow the format above for structure size. Give the name dip1 to this object. Assign 
the material PEC and click OK. PEC (Perfect Electric Conductor) will create ideal 
conditions for the element. 
 
The next step is to build the symmetric of dip1. To do that, Right -Click the drawing 
area and select Edit -> Duplicate -> Around Axis. 

 
 

 
 

The dipole structure is illustrated below: 
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5- Creating the port 
 
In the section you will create a Lumped Gap Source. This will provide an excitation 
to the dipole structure. Begin by selecting the YZ plane from the toolbar. Using the 
3D toolbar, click Draw Rectangle and place two arbitrary points within the model 
area. 
 

                                         

Select YZ plane 
Draw rectangle 

 
Enter the following information 
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Double Click 

 

Enter the information below 

 
With the source geometry in place, the user must provide an excitation. A lumped port 
will be used for the dipole model. This excitation is commonly used when the far field 
region is of primary interest. In the project explorer, right-click Excitation -> Assign 
-> Lumped Port. 
 

 

 
 

Name the port source and leave the default values for impedance.  
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Click Next and enter the following: 
 

 
 
Using the mouse, position the cursor to the bottom-center of the port. Ansoft's snap 
feature should place the pointer when the user approaches the center of any object. 
Left-click to define the origin of the E-field vector. Move the cursor to the top-center 
of the port. Left-click to terminate the E-field vector. Click finish to complete the port 
excitation. 
 
Note: In case you find some difficulties for drawing the lumped port, you can redraw 
the rectangular plane, affect the lumped port, then resize the rectangular plane.   
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6- Radiation Boundary 
 
In this section, a radiation boundary is created so that far field information may be 
extracted from the structure. To obtain the best result, a cylindrical air boundary is 
defined with a distance of λ/4. From the toolbar, select Draw Cylinder.  
 

 
 

Enter the following information: 
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With the geometry complete, the actual radiation boundary may now be assigned. 
From the 3D toolbar select face from the drop down window as shown below. 
 

 
 

Click and select all faces as follow: 
 

 
 
With all faces selected, right-click the Boundary icon in the object explorer and select 
Boundary -> Assign -> Radiation. 
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Leave the default name Rad1 and click OK. 
 
 
 
7- Solution Setup 
 
In this section a solution must be defined to display the desired data. We are primarily 
interested in the frequency response of the structure. We will also explore HFSS's 
ability to calculate general antenna parameters such as directivity, radiation resistance, 
radiation efficiency, etc... .  
From the project explorer, select Analysis -> Add Solution Setup. 
 

 
 

Enter the following. Click ok when complete. 
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To view the frequency response of the structure, a frequency sweep must be defined. 
From the project explorer select Setup1 -> Add Sweep. 
 

 
 
Enter the following 
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8- Structure Analysis 
 
At this point, the user should be ready to analyze the structure. Before running the 
analysis, always verify the project by selecting  from the 3D toolbar. If everything 
is correct the user should see: 
 

 
 

Analyze the structure by clicking  
 
9- Create Reports 
 

 
O. El Mrabet & M. Essaadi                                                                                                      2005 - 2006 

16



Telecommunication & System UFR                                                                           The Dipole Antenna 
 

After completion of the analysis, we will create a report to display both the resonant 
frequency and also the radiation pattern. Click on the heading HFSS and select 
Results -> Create Reports. 
 

 
 
Choose the following in the Create Report window: 
 

 
 
Select the following highlighted parameters and click Add Trace to load the options 
into the Trace window. 
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Click Done when complete.  
The graph is displayed below: 
 

 
 
HFSS has the ability to compute antenna parameters automatically. In order to 
produce the calculations, the user must define an infinite sphere for far field 
calculations. Right-click the Radiation icon in the project manager window and 
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select Insert Far Field Setup -> Infinite Sphere. 
 

 
Accept all default parameters and click Done. Right-click Infinite Sphere1 -> 
Compute Antenna Parameters... from the project explorer as shown: 
 

 
 

Select all defaults and results are displayed as follows: 
 

 
 

Next, the far field will be plotted. Create Reports as previously shown. Modify the 
following: 
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Enter the following: 
 

 
 

Select the Mag and enter the following: 
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Select Add Trace and click Done when complete. The radiation pattern is displayed 
below: 
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Chapter Two - The Rectangular Patch Antenna 

 
I – Introduction 
 
The objective of this chapter is to show you how to create, simulate and analyze a 
microstrip patch antenna resonating at a frequency of 7.5 GHz as shown in Fig.1.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 

 
A (0, 0,0) 

Top View 
 

 
 
 
 

2.2rε =
 
 
 
 

Cross View 
 

Fig.1 – Rectangular Patch Ante
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II – Creating the Rectangular Patch  
 
According to the first chapter, you can create and save a project.  
 
1 – Substrate 
 
To draw the Substrate, click  on the toolbar. Then draw a box by filling the 
following data as shown below. 
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2 – Feed Line 
 
To draw the Feed Line, click  on the toolbar. Then draw a box by filling the 
following data as shown below. 
 

 
 

 
 

3 – Patch 
 
To draw the Patch , click  on the toolbar. Then draw a box by filling the following 
data as shown below. 
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We know that the Patch and Feed line should be one object. So, we need to unite 
them. Note that both objects are of the same material. Click on both objects that you 
need to unite, i.e. Patch and Feed_line in the history tree. Click on one and hold the 
CTRL key and click on the other. Right Click Edit > Boolean > Unite. The two 
objects are united now.  
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4 – Ground Plane 
 
To draw the Ground Plane, click  on the toolbar. Then draw a box by filling the 
following data as shown below. 
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5 – Assign Excitation 
 
The excitation is a waveguide port at the beginning of the microstrip line. The 
reference plane of this port is located directly at the beginning of the radiating plane. 
Antennas are excited through the port. To draw the Port, click  on the toolbar. 
Then draw a rectangle by filling the following data as shown below. 
 
Choose the object Port from history tree, right-click and assign excitation. In our case, 
it is waveport. Click waveport, name it as your preference, then click Next, now 
define your integration line. Normally, integration line is defined from the bottom 
middle point to the upper middle point. Keep other values as default. Click Finish. 
 
 

 
 

A pop up will come up  
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Then click ‘suivant’ and choose new line 
 

 
 

Draw the lumped port,  
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6 – Assign Boundary 
 
Now the model has been created, we need to assign boundary conditions. In HFSS, 
radiation boundaries are used to simulate open problems that allow waves to radiate 
infinitely far into space. HFSS absorbs the wave at the radiation boundary, essentially 
ballooning the boundary infinitely far away from the structure. In our case, our ABC 
(Absorbing Boundary condition) is an air box. 
To draw the Air Box, click  on the toolbar. Then draw a box by filling the 
following data as shown below. 
 

 
 

 
 
Now select boundary, right click > Assign Boundary > radiation 
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7 – Analysis Setup 
 
Finally, you have your model ready to run. Now you need to identify your analysis 
setup.  
To create an analysis setup, select the menu item HFSS > Analysis Setup > Add 
Solution Setup. In the Solution Setup window, click the general tab, Solution 
frequency is 7.5 GHz, Maximum Number of Passes is 20 and Maximum Delta S per 
Pass is 0.02.  
 
8 – ADD Frequency Sweep 
 
To add a frequency sweep, select the menu item HFSS > Analysis Setup > Add 
Sweep. Select Solution Setup: Setup1. Click OK button. Then Edit Sweep Window. 
Sweep Type: Fast, Frequency Setup Type: Linear Count, Start: 5 GHz, Stop: 10 GHz, 
Count: 500. Click OK button. 
 
9 – Model Validation  
 
To validate the model, select the menu HFSS > Validation Check. Click the Close 
button. To view any errors or warnings messages, use the Message Manager.  
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10 – Analyze  
 
To start the solution process, select the menu item HFSS > Analyze. 
  
Or click on the icon .  
 
11- Solution Data 
 
Note: The Solution Data window can be also displayed by right-click on the Setup1 
under analysis on the HFSS design tree. Note also that the default view is Profile. 
Select the Convergence tab.  
 

 
 
The simulation will stop as soon as the results converge, which is at pass 14. 
 
12- Create Reports 
 
To create a report, select Results > Create Report.  
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Set Report Type to Modal S Parameters, Display Type to Rectangular then click OK 
button.  
 

 
 
In the Traces Window, set Solution to Setup1: Adaptive1. In the Y tab, set Category 
to S Parameter, Quantity to S (waveport, waveport), Function to dB and click Add 
Trace button. Click Done button. Note that you can create any type of report it all 
depends on what you want to analyze specifically. 
 

 
The antenna is resonating around 7.5 GHz. 
 
Note: More accurate results could be achieved by zooming in the simulation between 
7.00 GHz and 8.00 GHz. (Change the Start and Stop values to 7 GHz and 8 GHz, 
respectively then run simulation again). 
 
Moreover, we notice that Zin at 7.5 GHz is 88.05 Ω. To view Zin, go to 
Results<Solution Data click on Z Matrix and drag the frequency menu to 7.5 
GHz and read the Magnitude of the input impedance. 
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12- Radiation Pattern 
 
Create infinite sphere. Then go to Results< Create Report. When the new window 
pops up change the Report Type to Far Field and Display type to 3D Polar Plot. 
Click Add Trace then Ok. 
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Chapter Three – Probe Feed Patch Antenna  

 
I – Introduction 
 
This third chapter is intended to show you how to create, simulate and analyze a 
Probe Feed Patch Antenna (Fig.1) using the Ansoft HFSS. The main aim of this 
chapter is to show how to create a coax cable probe.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 

 
Top View 

 
 
 
 
 

2.2rε =
 
 
 
 

Cross View 
 

Fig.1 – Probe Feed Patch Antenn
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II – Getting Started 
 
By now, you can launch HFSS, opening a project and name it 
“probe_Feed_Patch_Antenna”.  
 
Then set the solution type: 
 

- select the menu item HFSS > Solution Type  
- choose Driven Terminal  
- click Ok button 

 

 
 

To set the units  
 

- select the menu item 3D Modeler > Units 
- select Units: cm 
- click ok button  
 

 
 
 
III – Creating the Probe Feed Patch Antenna   
 
1 – Substrate 
 
To draw the Substrate, click  on the toolbar. Then draw a box by filling the 
following data as shown below. 
 

 
O. El Mrabet & M. Essaadi                                                                                                      2005 - 2006 

35



Telecommunication System  & UFR                                                                Probe Feed Patch Antenna 
 

 
 

 
 
2 – Patch 
 
To draw the Patch , click  on the toolbar. Then draw rectangle by filling the 
following data as shown below. 
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Then assign a perfect E boundary to the patch. Select Patch, double click, select 
Assign Boundary > Perfect E…   
 

 
3 – Ground Plane 
 
To draw the Ground Plane, click  on the toolbar. Then draw rectangle by filling 
the following data as shown below. 
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Then assign a perfect E boundary to the patch. Select Ground, double click, and 
select Assign Boundary > Perfect E…   
 

 
 
 
4 – Coax Cable  
 
The antenna is excited using a coax cable port. This port is located under the patch.  
 

 To draw the coax cable port, we start by drawing the infinite ground Cut Out 
as shown below. 
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Then select the Ground & Cut_Out, right click, select Edit > Boolean > Substract 
 

 Create the coax.  
 
So to create the coax, select the menu item Draw > Cylinder, then enter the data as 
described below 
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 Create the Coax Pin  

 
So Select the menu item Draw > Cylinder, then enter the data as described below 
   

 
 

 
 

 Create the Wave port 
To create a circle that represents the port: 
Select the menu item Draw > Circle, then enter the data as shown below 
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To assign wave port excitation, select Port 1, then go to menu item HFSS > 
Excitations > Assign > Wave port 

  
 

 Create the Probe 
To create the probe, select the menu item Draw > Cylinder, then enter the data as 
shown below 
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5 – Assign Boundary 
 
To draw the Air Box, click  on the toolbar. Then draw a box by filling the 
following data as shown below. 
 

 
 

 
 

 
Now select Box 1, right click > Assign Boundary > radiation 
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6 – Analysis Setup 
 
Finally, you have your model ready to run. Now you need to identify your analysis 
setup.  
To create an analysis setup, select the menu item HFSS > Analysis Setup > Add 
Solution Setup. In the Solution Setup window, click the general tab, Solution 
frequency is 2.55 GHz, Maximum Number of Passes is 20 and Maximum Delta S per 
Pass is 0.02.  
 
7 – ADD Frequency Sweep 
 
To add a frequency sweep, select the menu item HFSS > Analysis Setup > Add 
Sweep. Select Solution Setup: Setup1. Click OK button. Then Edit Sweep Window. 
Sweep Type: Fast, Frequency Setup Type: Linear Count, Start: 1 GHz, Stop: 3 GHz, 
Count: 200. Click OK button. 
 
8 – Model Validation  
 
To validate the model, select the menu HFSS > Validation Check. Click the Close 
button. To view any errors or warnings messages, use the Message Manager.  
 

 
 
9 – Analyze  
 
To start the solution process, select the menu item HFSS > Analyze. 
  
Or click on the icon .  
 
10- Solution Data 
 
Note: The Solution Data window can be also displayed by right-click on the Setup1 
under analysis on the HFSS design tree. Note also that the default view is Profile. 
Select the Convergence tab.  
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The simulation will stop as soon as the results converge, which is at pass 10. 
 
11- Create Reports 
 
To create a report, select Results > Create Report.  
 

 
Set Report Type to Modal S Parameters, Display Type to Rectangular then click OK 
button.  
 

 
 
In the Traces Window, set Solution to Setup1: Adaptive1. In the Y tab, set Category 
to S Parameter, Quantity to S (waveport, waveport), Function to dB and click Add 
Trace button. Click Done button. Note that you can create any type of report it all 
depends on what you want to analyze specifically. 
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12- Radiation Pattern 
 
To create a 2D polar far field plot go to Results > create Report. When the new 
window pops up change the Report Type to Far Field and Display type to Radiation 
Pattern then click OK. 
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Chapter Four – Triangular Microstrip Antenna  
 
I – Introduction 
 
This fourth chapter is intended to show you how to create, simulate and analyze a 
complex antenna such as dual frequency equilateral triangular antenna with a pair of 
narrow slots (Figure 4.1) using the Ansoft HFSS. The main aim of this chapter is to 
show how to create complicated drawing.  

 
Figure 4.1 – Geometry of the dual frequency equilateral triangular antenna with 

a pair of narrow slots 
 
II – Getting Started 
 
By now, you can launch HFSS, opening a project and name it 
“Triangular_Antenna”.  
 
Then set the solution type: 
 

- select the menu item HFSS > Solution Type  
- choose Driven Terminal  
- click Ok button 
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To set the units  
 

- select the menu item 3D Modeler > Units 
- select Units: mm 
- click ok button  
 

 
 
III – Dual frequency equilateral triangular antenna with a pair of narrow slots 
 
1 – Substrate 
 
To draw the Substrate, click  on the toolbar. Then draw a box by filling the 
following data as shown below. 
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2 – Triangular Patch 
 
Since there isn’t a triangular icon that allow us to draw triangular shapes. So to draw 
it, we must first begin by drawing a rectangular patch.   
To draw the Patch, click  on the toolbar. Then draw rectangle by filling the 
following data as shown below. 
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We start to draw a poly line to form a triangular shape as shown above by clicking on 
this icon  on the toolbar.  

 

 
 

Then start to enter the point positions (P1, P2, and P3).  
Then select the Patch & Polyline1, right click, select Edit > Boolean > Substract 
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Now, we start to another a second Polyline  
 

  
 

Then enter the appropriate point positions of the Polyline 2, when you finished select 
the Patch & Polyline2, right click, select Edit > Boolean > Substract 
  

 

 
O. El Mrabet & M. Essaadi                                                                                                      2005 - 2006 

52



Telecommunication System & UFR                                                           Triangular Microstrip Antenna 
 

 
 
 

Assign a perfect E boundary to the patch. Select Patch, double click, select Assign 
Boundary > Perfect E…   
 

 
3 – Ground Plane 
 
To draw the Ground Plane, click  on the toolbar. Then draw rectangle by filling 
the following data as shown below. 
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Then assign a perfect E boundary to the patch. Select Ground, double click, and 
select Assign Boundary > Perfect E…   
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4 – Coax Cable  
 
The antenna is excited using a coax cable port. This port is located under the patch.  
 

 To draw the coax cable port, we start by drawing the infinite ground Cut Out 
as shown below. 

 

 
 

 
 
Then select the Ground & Cut_Out, right click, select Edit > Boolean > Substract 
 

 Create the coax.  
 
So to create the coax, select the menu item Draw > Cylinder, then enter the data as 
described below 
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 Create the Coax Pin  
 
So Select the menu item Draw > Cylinder, then enter the data as described below 
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 Create the Wave port 
To create a circle that represents the port: 
Select the menu item Draw > Circle, then enter the data as shown below 

 

 
O. El Mrabet & M. Essaadi                                                                                                      2005 - 2006 

57



Telecommunication System & UFR                                                           Triangular Microstrip Antenna 
 

 
 

To assign wave port excitation, select Port 1, then go to menu item HFSS > 
Excitations > Assign > Wave port 

  
 

 Create the Probe 
To create the probe, select the menu item Draw > Cylinder, then enter the data as 
shown below 
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5 – Assign Boundary 
 
To draw the Air Box, click  on the toolbar. Then draw a box by filling the 
following data as shown below. 
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Now select Box 1, right click > Assign Boundary > radiation  
The final antenna should like as follow 
 

 
 
 
6 – Analysis Setup 
 
Finally, you have your model ready to run. Now you need to identify your analysis 
setup.  
To create an analysis setup, select the menu item HFSS > Analysis Setup > Add 
Solution Setup. In the Solution Setup window, click the general tab, Solution 
frequency is 1.8 GHz, Maximum Number of Passes is 20 and Maximum Delta S per 
Pass is 0.02.  
 
7 – ADD Frequency Sweep 
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To add a frequency sweep, select the menu item HFSS > Analysis Setup > Add 
Sweep. Select Solution Setup: Setup1. Click OK button. Then Edit Sweep Window. 
Sweep Type: Fast, Frequency Setup Type: Linear Count, Start: 1 GHz, Stop: 3 GHz, 
Count: 200. Click OK button. 
 
8 – Model Validation  
 
To validate the model, select the menu HFSS > Validation Check. Click the Close 
button. To view any errors or warnings messages, use the Message Manager.  
 

 
 
9 – Analyze  
 
To start the solution process, select the menu item HFSS > Analyze. 
  
Or click on the icon .  
 
10- Solution Data 
 
Note: The Solution Data window can be also displayed by right-click on the Setup1 
under analysis on the HFSS design tree. Note also that the default view is Profile. 
Select the Convergence tab.  
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The simulation will stop as soon as the results converge, which is at pass 10. 
 
11- Create Reports 
 
To create a report, select Results > Create Report.  
 

 
Set Report Type to Modal S Parameters, Display Type to Rectangular then click OK 
button.  
 

 
 
In the Traces Window, set Solution to Setup1: Adaptive1. In the Y tab, set Category 
to S Parameter, Quantity to S (waveport, waveport), Function to dB and click Add 
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Trace button. Click Done button. Note that you can create any type of report it all 
depends on what you want to analyze specifically. 
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