+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 20 of 27
  1. #1
    Newbie level 5
    Points: 1,273, Level: 8

    Join Date
    Apr 2006
    Posts
    8
    Helped
    0 / 0
    Points
    1,273
    Level
    8

    errores en gtp usb summer

    I've built a GTP-USB+ (summer edition) programmer. I use it with winpic800 (3.55f) but when I try to program a pic (18F4585, but have tried others) it says "Error - No is answer of hardware" or something like that.
    I've measured the voltage on the programmer and it seems right, VPP is about 10.5V, maybe it should be slightly more but I don't know if that's why it won't work?

    I hope someone can give me some tips on where to search for errors..

  2. #2
    Advanced Member level 4
    Points: 19,384, Level: 33
    Kripton2035's Avatar
    Join Date
    Jul 2001
    Location
    Western Europe
    Posts
    1,053
    Helped
    168 / 168
    Points
    19,384
    Level
    33

    gtp usb plus firmware

    vpp needs to be 12v5 to 13v5 or so..
    if you build gtp usb plus and programmed it with the firmware that you can get on the net or emule, then it is gtp usb lite firmware, and wont work with gtp usb plus hardware !
    you need to build gtp usb lite hardware...
    of buy the preprogrammed chip to the author...


    1 members found this post helpful.

  3. #3
    Newbie level 5
    Points: 1,273, Level: 8

    Join Date
    Apr 2006
    Posts
    8
    Helped
    0 / 0
    Points
    1,273
    Level
    8

    gtp-usb plus firmware

    It's an old firmware and an old version of the GTP-USB and it should be correct. I don't know why the VPP won't go to 13,5V as it should be, have to look that over..



    •   Alt3rd May 2006, 22:29

      advertising

        
       

  4. #4
    Advanced Member level 4
    Points: 19,384, Level: 33
    Kripton2035's Avatar
    Join Date
    Jul 2001
    Location
    Western Europe
    Posts
    1,053
    Helped
    168 / 168
    Points
    19,384
    Level
    33

    gtp-usb firmware

    on the old gtpusb, the vpp generation is made of diodes and capacitors (3 each). may be one of your diode is reversed ? or bad cap ?
    on the new gtpusb, the vpp is made with diode and one inductor.. what do you have ? you can post the jpeg of the schematic you used ? regards.



  5. #5
    Newbie level 5
    Points: 1,273, Level: 8

    Join Date
    Apr 2006
    Posts
    8
    Helped
    0 / 0
    Points
    1,273
    Level
    8

    gtp-usb summer 2005

    I have the one with 3 diodes and 3 capacitors. I don't have any errors in the connection, but when I measure the individual voltages over each cap the voltage after the second one is only about 8V, so I guess the problem is somewhere in between there.. I'll search for errors during the weekend.

    Added after 4 hours 27 minutes:

    Here is an attachment of the schematic I've built from. It's a stripped down version, only for icsp, with only one "VPP generator" and without the things only necessary for ZIF-programming.



  6. #6
    Advanced Member level 4
    Points: 19,384, Level: 33
    Kripton2035's Avatar
    Join Date
    Jul 2001
    Location
    Western Europe
    Posts
    1,053
    Helped
    168 / 168
    Points
    19,384
    Level
    33

    firmware gtp usb

    do you have a scope to see the signals at ra0 and ra1 ?
    and after the capacitors ?
    should help..



  7. #7
    Newbie level 5
    Points: 1,273, Level: 8

    Join Date
    Apr 2006
    Posts
    8
    Helped
    0 / 0
    Points
    1,273
    Level
    8

    winpic800 3.55

    Unfortunately I don't.



  8. #8
    Advanced Member level 4
    Points: 19,384, Level: 33
    Kripton2035's Avatar
    Join Date
    Jul 2001
    Location
    Western Europe
    Posts
    1,053
    Helped
    168 / 168
    Points
    19,384
    Level
    33

    pickit2hybrid

    try to permute the diodes, and see if the voltage changes, this may help in finding a bad or reversed diode ?



  9. #9
    Newbie level 5
    Points: 1,273, Level: 8

    Join Date
    Apr 2006
    Posts
    8
    Helped
    0 / 0
    Points
    1,273
    Level
    8

    winpic no answer is of hardware

    I have a diode-tester on my multimeter and the diodes are fine and not reversed. The voltage increases over each capacitor, just not as much as it should. Don't really know what could be the problem. The USB on my _laptop_ should be able to output as much current as any other I think(?).



    •   Alt10th May 2006, 20:24

      advertising

        
       

  10. #10
    Newbie level 5
    Points: 1,273, Level: 8

    Join Date
    Apr 2006
    Posts
    8
    Helped
    0 / 0
    Points
    1,273
    Level
    8

    winpic800

    I now have vpp at about 12.5V, I increased the 2k2 resistor from the last capacitor to 27k.
    It can identify wich pic I am trying to program, and the hardware test goes ok.
    But I still have the same problem, in winpic800 when trying to program it almost immediatly goes up to 95% and stops, both the vpp and data led is lit and then it says "No is answer from hardware".



    •   Alt20th May 2006, 15:31

      advertising

        
       

  11. #11
    Newbie level 5
    Points: 1,273, Level: 8

    Join Date
    Apr 2006
    Posts
    8
    Helped
    0 / 0
    Points
    1,273
    Level
    8

    gtp-usb+ firmware

    Is there anyone who knows if there is needed to do something special with the .hex file to the GTP-USB Summer 2005 version when programming the 2550? I'm starting to wonder if the problem is in the .hex-file or maybe winpic800.



  12. #12
    Member level 3
    Points: 1,598, Level: 9

    Join Date
    Apr 2006
    Posts
    61
    Helped
    6 / 6
    Points
    1,598
    Level
    9

    firmware gtp usb plus

    Hi Ivarrson,
    I do not have the hex file or the schematic to checkout.
    If you can post the same i can try to help you out
    What version of winpic800 are you using



  13. #13
    Advanced Member level 4
    Points: 19,384, Level: 33
    Kripton2035's Avatar
    Join Date
    Jul 2001
    Location
    Western Europe
    Posts
    1,053
    Helped
    168 / 168
    Points
    19,384
    Level
    33

    gtp usb firmware

    please read the thread.. everything you're asking for is already written..



  14. #14
    Newbie level 4
    Points: 1,867, Level: 10

    Join Date
    Feb 2006
    Posts
    7
    Helped
    0 / 0
    Points
    1,867
    Level
    10

    winpic 800

    I also build GTP-USB as in the gif. The only thing, I have 2 Vpp (Vpp1 & Vpp2) but it same spec as Vpp1 for 18Pin and below , Vpp2 for 28 & 40 pin MCU.

    I also measure the voltage after cap as you are and the voltage also as you get.

    If somebody need the schematic & firmware, I can upload.



  15. #15
    Full Member level 4
    Points: 2,863, Level: 12

    Join Date
    Dec 2005
    Posts
    237
    Helped
    9 / 9
    Points
    2,863
    Level
    12

    gtp usb summer

    hi there, plz do upload the schematic, pcb track and firmware, as i'm looking for usb programmer for a long time. Plz specify the correct version on software(winpic800) to us as well. Thankx



  16. #16
    Newbie level 4
    Points: 1,867, Level: 10

    Join Date
    Feb 2006
    Posts
    7
    Helped
    0 / 0
    Points
    1,867
    Level
    10

    winpic800 - gtp-usb [plus] firmware

    Also can refer to

    http://www.edaboard.com/viewtopic.php?p=654689#654689

    for schematic,software & firmware.



  17. #17
    Newbie level 3
    Points: 1,205, Level: 7

    Join Date
    Dec 2006
    Posts
    3
    Helped
    0 / 0
    Points
    1,205
    Level
    7

    winpic800 3.55 gtp summer 2005

    Hi friends here, I also face this problem same as Ivarrson, I also do not know why, it can detect that Pic16F877A, but can not read and burn. Do anyone else face this problem and can solve it? I am using WinPic800 3.55d.

    The program burn until 96% then will hang on there, My PIC tools, red led is on, mean that the program still running, but there was a ERROR poop up: "No is answer of Hardware". After this problem, i can not detect anyone, I need to unplug and replug again, so that I can detect again for that PIC. Why?

    Added after 2 minutes:

    Beside this, I burn my PIC by using Serial Port, after use USB converter, WinPic800 also can not read the data, it will hang at 66%, why?



  18. #18
    Full Member level 3
    Points: 4,300, Level: 15

    Join Date
    Jul 2006
    Location
    North Judson, IN USA
    Posts
    166
    Helped
    19 / 19
    Points
    4,300
    Level
    15

    gtp usb summer winpic800

    I built the Brenner8 USB programmer and had a similar problem - USB worked, but it could not read, write, or identify any PIC. I solved the problem by starting the software BEFORE plugging in the programmer. Also make sure the transistors and diodes are mounted properly (espescially if you substituted any components). Hope this helps. Peace.



  19. #19
    Newbie level 3
    Points: 1,205, Level: 7

    Join Date
    Dec 2006
    Posts
    3
    Helped
    0 / 0
    Points
    1,205
    Level
    7

    winpic800 usb programmer

    Ok, right now, mind to tell me what brand of motherboard who's facing this type of error, I am using Abit KN9S, my friends told me that, he using Asus A8N-SLi no problem at all. So, might the motherboard structure problem will cause the PiC tools or USB un-stable? My other friends who's tried on other model of ABiT motherboard, serial port and USB port also can not work at all. So I just need get more information so that I can confirm the motherboard might cause this error occur and make trouble for us.

    Thanks a lot



  20. #20
    Full Member level 3
    Points: 4,300, Level: 15

    Join Date
    Jul 2006
    Location
    North Judson, IN USA
    Posts
    166
    Helped
    19 / 19
    Points
    4,300
    Level
    15

    winpic800 problem

    My motherboard is an Abit NF-7 Ver. 2. Did you try plugging the USB cable into a channel with no other devices on it? Most Abit boards have multiple channels. Just a thought.



+ Post New Thread
Please login
Page 1 of 2 12 LastLast