+ Post New Thread
Results 1 to 4 of 4
  1. #1
    Newbie level 2
    Points: 23, Level: 1

    Join Date
    Jan 2017
    Posts
    2
    Helped
    0 / 0
    Points
    23
    Level
    1

    Help Configuring TW2837 video Quad MUX using atmega32u4

    I am having trouble in getting desired output from the TW2837 Video Mux chip. I have used atmga32u4 as a host controller. I am able to get four blue screens on TV separated by boundary lines.I am also able to generate the color bar test pattern. However when I connect a camera on any of the four input channels the respective display is just noisy, scrambled, running lines. I don't know what else to do ? if anyone has implemented it please help ! or share your experience.

    •   Alt11th January 2017, 18:25

      advertising

        
       

  2. #2
    Super Moderator
    Points: 24,082, Level: 37
    ads-ee's Avatar
    Join Date
    Sep 2013
    Location
    USA
    Posts
    5,358
    Helped
    1354 / 1354
    Points
    24,082
    Level
    37

    Re: Help Configuring TW2837 video Quad MUX using atmega32u4

    you should probably describe the circuit connection between the camera (also give the camera part number) and the TW2837. I suspect you've got something connected wrong or are missing something in the way you are connecting them.



    •   Alt11th January 2017, 18:42

      advertising

        
       

  3. #3
    Newbie level 2
    Points: 23, Level: 1

    Join Date
    Jan 2017
    Posts
    2
    Helped
    0 / 0
    Points
    23
    Level
    1

    Re: Help Configuring TW2837 video Quad MUX using atmega32u4

    Actually the Video signal from camera entering into the input pin of TW2837 is absolutely fine (TV displays it perfect when i hook up wires from input pins TW2837. it means the input side is working fine ) the application schematic has been taken from data sheet as attached.tw2837.jpg



    •   Alt12th January 2017, 18:20

      advertising

        
       

  4. #4
    Super Moderator
    Points: 38,295, Level: 47
    Awards:
    Most Frequent Poster

    Join Date
    Apr 2014
    Posts
    7,822
    Helped
    1889 / 1889
    Points
    38,295
    Level
    47

    Re: Help Configuring TW2837 video Quad MUX using atmega32u4

    Hi,

    * PCB layout problems?
    * missing power supply decoupling capacitors?

    ****
    * are the supply voltages stable all the time?


    Klaus



+ Post New Thread
Please login
--[[ ]]--