+ Post New Thread
Results 1 to 5 of 5
  1. #1
    Newbie level 6
    Points: 384, Level: 4

    Join Date
    May 2015
    Posts
    12
    Helped
    0 / 0
    Points
    384
    Level
    4

    gsm module does not show response message on LCD

    I am connecting GSM module SIM900A with PIC microcontroller and show their response on LCD. When I send AT commands to GSM module, it does not show any response messages. I made a call to my phone through GSM module using ATD command and hang up through ATH command. But in this case also it does not show any response messages. When I made a call to GSM module, I can hear the ring but LCD does not show anything. When I use another GSM module, it works properly. What is the reason? Please help me.

    •   Alt2nd January 2017, 09:08

      advertising

        
       

  2. #2
    Super Moderator
    Points: 24,480, Level: 38
    andre_teprom's Avatar
    Join Date
    Nov 2006
    Location
    Portugal
    Posts
    7,352
    Helped
    917 / 917
    Points
    24,480
    Level
    38
    Blog Entries
    5

    Re: gsm module does not show response message on LCD

    What is the reason? Please help me.
    If you do not have the uptake to realize that without presenting any code or picture nobody can help you, you will hardly note that there are other ways of debugging the program, such as systematically identifying what is and what is not working ( communication, display, etc... )
    --------------------------------------------------------------------------------------------------
    Part of the world that you live in, You are the part that you're giving ( Renaissance )



    •   Alt2nd January 2017, 19:49

      advertising

        
       

  3. #3
    Newbie level 6
    Points: 384, Level: 4

    Join Date
    May 2015
    Posts
    12
    Helped
    0 / 0
    Points
    384
    Level
    4

    Re: gsm module does not show response message on LCD

    I have two GSM SIM900A modules. First GSM module is properly working with LCD. When I use second GSM module, its working but doesnot show any response message on LCD. So I think LCD is good but not work with second GSM. Also there is no problem in communication section, otherwise its not work with first GSM. I only replace first GSM with second one and other connections remain same. The echo and response messages are shown for first GSM and not for second GSM. The program used in both cases are also same.



    •   Alt4th January 2017, 13:03

      advertising

        
       

  4. #4
    Super Moderator
    Points: 236,416, Level: 100
    Awards:
    1st Helpful Member

    Join Date
    Jan 2008
    Location
    Bochum, Germany
    Posts
    40,887
    Helped
    12494 / 12494
    Points
    236,416
    Level
    100

    Re: gsm module does not show response message on LCD

    Possible reasons:
    - module has some nonvolatile parameters set differently. Enforce factory settings.
    - module is damaged
    - module incorrectly soldered



  5. #5
    Newbie level 6
    Points: 384, Level: 4

    Join Date
    May 2015
    Posts
    12
    Helped
    0 / 0
    Points
    384
    Level
    4

    Re: gsm module does not show response message on LCD

    Thank you guys..... its working now..The output voltage of second GSM module is around 2.8V. So I used a 3.3V to 5V voltage converter in between GSM txr pin and PIC rxr pin. Now its show response messages.



--[[ ]]--