---
+ Post New Thread
Results 1 to 5 of 5
  1. #1
    Newbie level 6
    Points: 569, Level: 5

    Join Date
    Mar 2010
    Location
    Toronto
    Posts
    13
    Helped
    3 / 3
    Points
    569
    Level
    5

    why pinging works on hub but not on switch

    our prototype can only pinging through hub. it wont work on switch. we use the same network cable, same condition. when pinging through hub, it works very well; when connect it to the switch directly, it stops pinging. Why? What is the potential problem?
    Please anyone has an idea.

    Thanks in advance!

    •   Alt11th March 2010, 22:40

      advertising

        
       

  2. #2
    Newbie level 6
    Points: 569, Level: 5

    Join Date
    Mar 2010
    Location
    Toronto
    Posts
    13
    Helped
    3 / 3
    Points
    569
    Level
    5

    Re: why pinging works on hub but not on switch

    anyone help? Plz,
    I stucked here



    •   Alt12th March 2010, 16:08

      advertising

        
       

  3. #3
    Administrator
    Points: 58,311, Level: 58
    Awards:
    3rd Helpful Member
    bigdogguru's Avatar
    Join Date
    Mar 2010
    Location
    Southwest, USA
    Posts
    8,305
    Helped
    2155 / 2155
    Points
    58,311
    Level
    58
    Blog Entries
    3

    Re: why pinging works on hub but not on switch

    Can you give a little more background info? By prototype do you refer to the ethernet interface as well? Could be something to do with the MAC address and ARP. A hub broadcast packets on all ports, while a switch only routes packets to a port where a particular MAC address is known to exist. ARP is used to correlate an IP Address, assigned by the user to a MAC Address permanently assigned to an interface. Where did you acquire the MAC Address for the prototype?



    •   Alt14th March 2010, 15:23

      advertising

        
       

  4. #4
    FvM
    FvM is offline
    Super Moderator
    Points: 173,943, Level: 99
    Awards:
    1st Helpful Member

    Join Date
    Jan 2008
    Location
    Bochum, Germany
    Posts
    28,344
    Helped
    8902 / 8902
    Points
    173,943
    Level
    99

    Re: why pinging works on hub but not on switch

    When doing ethernet related development, you should be able to use respective tools, e.g. wireshark, to debug the communication.
    ICMP echo request ("Ping") needs to be preceeded by determining the peer's MAC address trough ARP (performed by the TCP/IP stack
    automatically), you should trace the complete action to see, where it fails.



  5. #5
    Member level 4
    Points: 1,164, Level: 7

    Join Date
    Feb 2010
    Location
    Hamburg, Germany
    Posts
    71
    Helped
    14 / 14
    Points
    1,164
    Level
    7

    Re: why pinging works on hub but not on switch

    Hi,

    It could be a problem with Auto-MDIX support in your PHY and/or transformer. Have you tried both crossover and straight through cables?

    You might also want to check if autonegotiation is working properly and optionally try to configure all of your hardware manually.

    Regards,
    Chris



+ Post New Thread
Please login