---
+ Post New Thread
Results 1 to 12 of 12
  1. #1
    Full Member level 2
    Points: 2,075, Level: 10

    Join Date
    Oct 2008
    Location
    Hyderabad
    Posts
    123
    Helped
    41 / 41
    Points
    2,075
    Level
    10

    nodebug designs are not supported.

    Dear All,

    I've encrypted some of my design files using "vencrypt" (i've tried with +protect option also).

    After proper encryption, Ive used those encrypted files for simulations. But it is giving the following Fatal Error after running the VSIM command.
    Compilation (VLOG..) of those files were successful.


    ** Fatal: Attempting to load -nodebug design unit.
    # Nodebug designs are not supported.
    #
    # Time: 0 fs Iteration: 0 Instance: /xxxxx.v
    File: ./xxxx.v
    # FATAL ERROR while loading design

    I am using the "ModelSim PE Student Edition 6.5a".
    Can any one provide me the information whether it is possible to simulaite Encrypted files using the above version?
    If yes... pls let us know how.
    How to simulate the encrypted fiels? any special settings or switches ect...

    Pls. help ASAP.

    Regards,
    SunilB.

    •   Alt29th May 2009, 12:59

      advertising

        
       

  2. #2
    Full Member level 5
    Points: 3,287, Level: 13

    Join Date
    Dec 2004
    Location
    Munich, Germany
    Posts
    243
    Helped
    46 / 46
    Points
    3,287
    Level
    13

    vp modelsim protect

    if you have encrypted the files with a different simulator version than the one which you are using for your current simulation, it might not work. try to use the same version



  3. #3
    Full Member level 2
    Points: 2,075, Level: 10

    Join Date
    Oct 2008
    Location
    Hyderabad
    Posts
    123
    Helped
    41 / 41
    Points
    2,075
    Level
    10

    nodebug designs

    Hello friend,

    Thanks for the prompt response.

    I am using the same version of Modelsim for both generation of encryption and simulation. Just one after the other.

    -Sunil Budumuru.



  4. #4
    Advanced Member level 3
    Points: 6,706, Level: 19

    Join Date
    May 2008
    Location
    Shang Hai
    Posts
    972
    Helped
    77 / 77
    Points
    6,706
    Level
    19

    nodebug designs modelsim

    the version of the tool is correct?



  5. #5
    Full Member level 2
    Points: 2,075, Level: 10

    Join Date
    Oct 2008
    Location
    Hyderabad
    Posts
    123
    Helped
    41 / 41
    Points
    2,075
    Level
    10

    encrypted files in spanish

    yes



    •   Alt30th May 2009, 16:28

      advertising

        
       

  6. #6
    Full Member level 2
    Points: 2,467, Level: 11

    Join Date
    Mar 2006
    Location
    Bangalore
    Posts
    123
    Helped
    23 / 23
    Points
    2,467
    Level
    11

    nodebug designs are not supported

    Hi Sunil,
    Some student versions will not allow to use complete set of of "option" switch while simulating. You can just check-out FAQs of Modelsim for the simulation with encrypted verilog files. Pressumes that without encryption your design are getting simulated.

    Try to do the verror number in your simulator also for finding out the root cause. Or google the verror <number> to see others faced the same error with the protected files while simulating.

    Thanks,
    -Paul



  7. #7
    Full Member level 2
    Points: 2,075, Level: 10

    Join Date
    Oct 2008
    Location
    Hyderabad
    Posts
    123
    Helped
    41 / 41
    Points
    2,075
    Level
    10

    verilog protected .vp modelsim

    Hi Paul,

    Thank you fr the info.

    1. Without encryption I could able to simulate the design.
    2. Tool is just reporting as mentioned below... no verror number.

    -SunilB
    asic-dft.com



  8. #8
    Full Member level 2
    Points: 2,467, Level: 11

    Join Date
    Mar 2006
    Location
    Bangalore
    Posts
    123
    Helped
    23 / 23
    Points
    2,467
    Level
    11

    fatal: attempting to load -nodebug design unit

    Hi Sunil,
    while encrypting with "vencrypt" give "-quiet" option to give the display messages while encrypting is proper. See ModelSim Userguide for more details.

    (attached herewith for your referance- Page 229)

    Thanks,
    -Paul



  9. #9
    Full Member level 2
    Points: 2,075, Level: 10

    Join Date
    Oct 2008
    Location
    Hyderabad
    Posts
    123
    Helped
    41 / 41
    Points
    2,075
    Level
    10

    vopt protect modelsim

    Hi Paul,

    I've tried with "-quiet" option.
    By the way "-quiet" option is to Disables encryption messages.

    No warnings and errors were found during encryption.

    Regards,
    SunilB
    asic-dft.com



  10. #10
    Advanced Member level 2
    Points: 4,734, Level: 16

    Join Date
    Sep 2004
    Location
    Bangalore, India
    Posts
    646
    Helped
    82 / 82
    Points
    4,734
    Level
    16

    modelsim encrypted verilog

    Sunil,
    It maybe due to the vopt flow. Can you try using "vsim -novopt <top_level>"?

    Ajeetha, CVC
    www.cvcblr.com



  11. #11
    Full Member level 2
    Points: 2,075, Level: 10

    Join Date
    Oct 2008
    Location
    Hyderabad
    Posts
    123
    Helped
    41 / 41
    Points
    2,075
    Level
    10

    attempting to load nodebug

    Hi Ajeetha,

    Tht didn't work. Still reporting the same fatal error.

    -Sunil Budumuru
    asic-dft.com



  12. #12
    Newbie level 1
    Points: 626, Level: 5

    Join Date
    Jun 2009
    Posts
    1
    Helped
    0 / 0
    Points
    626
    Level
    5

    modelsim vp file

    Hi sunil,

    When you encrypt the *.v file, It will create as *.vp... so, you should use *.vp file for compilation. I think this may be fatal error. Please check and inform me..

    Regards,
    VIgnesh



+ Post New Thread
Please login