+ Post New Thread
Results 1 to 6 of 6
  1. #1
    Member level 3
    Points: 1,389, Level: 8

    Join Date
    Apr 2011
    Location
    Istanbul, Turkey
    Posts
    55
    Helped
    0 / 0
    Points
    1,389
    Level
    8

    Mentor Graphics PADS Layout - Split/Mixed Plane - pad does not connect to plane

    Hi all,

    I'm using Mentor Graphics PADS VX.1.2 for PCB design in Windows 7 Pro OS.

    I have a pad-plane connection issue. Some pads (not all) does not connect as if they are different nets although they are the same net.

    Here is a problematic plane with its properties shown:
    Click image for larger version. 

Name:	plane_connect2-2.png 
Views:	4 
Size:	132.7 KB 
ID:	140477

    When I do plane connect using Pour Manager:
    Click image for larger version. 

Name:	plane_connect3.PNG 
Views:	4 
Size:	104.3 KB 
ID:	140473

    I get following errors(don't know how relevant):
    Click image for larger version. 

Name:	plane_connect4.PNG 
Views:	4 
Size:	78.5 KB 
ID:	140472

    Here is shown only the top layer (using "z1" modeless command):
    Click image for larger version. 

Name:	plane_connect5.PNG 
Views:	4 
Size:	30.1 KB 
ID:	140471

    Here is the cam plane preview where the problem is better seen:
    Click image for larger version. 

Name:	plane_connect6.PNG 
Views:	5 
Size:	12.9 KB 
ID:	140470


    Here is my Split/Mixed Plane options:
    Click image for larger version. 

Name:	plane_connect7.PNG 
Views:	3 
Size:	63.1 KB 
ID:	140475

    Note: In all pictures, green is the explanation edits.

    How can I fix this issue?

    Any suggestions are welcomed.
    Last edited by ogulcan123; 12th August 2017 at 10:13. Reason: Deleting unnecessary attachment
    Cheers,
    Ogulcan

    •   Alt12th August 2017, 10:11

      advertising

        
       

  2. #2
    Advanced Member level 5
    Points: 19,397, Level: 33
    barry's Avatar
    Join Date
    Mar 2005
    Location
    California, USA
    Posts
    3,739
    Helped
    806 / 806
    Points
    19,397
    Level
    33

    Re: Mentor Graphics PADS Layout - Split/Mixed Plane - pad does not connect to plane

    If you'll notice you've got DRC errors (those little green 'x's) in the upper left corner of your pour. There's something amiss in that area.



    •   Alt12th August 2017, 17:56

      advertising

        
       

  3. #3
    Member level 3
    Points: 1,389, Level: 8

    Join Date
    Apr 2011
    Location
    Istanbul, Turkey
    Posts
    55
    Helped
    0 / 0
    Points
    1,389
    Level
    8

    Re: Mentor Graphics PADS Layout - Split/Mixed Plane - pad does not connect to plane

    Quote Originally Posted by barry View Post
    If you'll notice you've got DRC errors (those little green 'x's) in the upper left corner of your pour. There's something amiss in that area.
    Hi,

    I put those little green x's myself as I mention that all green anything is my own edit. That area has to be merged, there should be no gap.

    I'll try to do some ECO to PCB, import export etc; and in the meantime, any suggestions are welcomed.
    Cheers,
    Ogulcan



    •   Alt13th August 2017, 07:17

      advertising

        
       

  4. #4
    Full Member level 4
    Points: 3,571, Level: 14
    Achievements:
    7 years registered
    senilicus's Avatar
    Join Date
    Feb 2007
    Location
    Amsterdam / The Netherlands
    Posts
    225
    Helped
    61 / 61
    Points
    3,571
    Level
    14

    Re: Mentor Graphics PADS Layout - Split/Mixed Plane - pad does not connect to plane

    Check your thermal tie settings, Any overrides there?



  5. #5
    Member level 3
    Points: 1,389, Level: 8

    Join Date
    Apr 2011
    Location
    Istanbul, Turkey
    Posts
    55
    Helped
    0 / 0
    Points
    1,389
    Level
    8

    Re: Mentor Graphics PADS Layout - Split/Mixed Plane - pad does not connect to plane

    Quote Originally Posted by senilicus View Post
    Check your thermal tie settings, Any overrides there?
    Hi,

    Thanks for the tip. I spent some time with the thermal settings, I also check the decals thermal settings and this actually help me with some other issues.

    However, I solved the problem..

    What actually solved my issue is that the plane area has to cover the center of the pad.

    For those who will face the same problem, refer to below picture for solution:
    Click image for larger version. 

Name:	plane-solved.PNG 
Views:	3 
Size:	66.7 KB 
ID:	140521
    Cheers,
    Ogulcan



    •   Alt14th August 2017, 08:40

      advertising

        
       

  6. #6
    Full Member level 2
    Points: 3,314, Level: 13
    TraceRouter's Avatar
    Join Date
    Aug 2005
    Location
    Wichita, KS
    Posts
    141
    Helped
    21 / 21
    Points
    3,314
    Level
    13

    Re: Mentor Graphics PADS Layout - Split/Mixed Plane - pad does not connect to plane

    Quote Originally Posted by ogulcan123 View Post
    What actually solved my issue is that the plane area has to cover the center of the pad.
    I'm not sure how close Pads is to Expedition, but in Expedition there is a setting that controls this. If you have something called "Plane Classes and Parameters", open it. Change your class to the class that the plane is using and then go to the "Clearances/Discard/Negative" tab. Uncheck the "For buried connections, do not connect when pad origin is outside of the plane shape." After doing that, you will get a connection as long as the plane makes contact with the pad. Hopefully, Pads has the same function



--[[ ]]--