+ Post New Thread
Results 1 to 6 of 6
  1. #1
    Newbie level 5
    Points: 101, Level: 1

    Join Date
    Apr 2017
    Posts
    8
    Helped
    0 / 0
    Points
    101
    Level
    1

    Resonance Frequency in Driven Modal

    Dear All,

    I got a close to reality resonance frequency with eigen mode solver (simulating the enclosed vacuum volume within the resonator but with no pickup included). When I try to use the driven modal solution type with the pickup also included as antenna, my resonance frequency is different from the eigenmode solution by 5 MHz. Could some one help me with identifying where I could be possibly wrong.

    Thanks in advance!!!
    Cheers
    Sud

    •   Alt14th June 2017, 11:42

      advertising

        
       

  2. #2
    Full Member level 5
    Points: 3,186, Level: 13
    Achievements:
    7 years registered Created Blog entry

    Join Date
    Jul 2007
    Location
    Trieste
    Posts
    285
    Helped
    41 / 41
    Points
    3,186
    Level
    13
    Blog Entries
    1

    Re: Resonance Frequency in Driven Modal

    So you included pickups with the driven model and that was not the part of Eigen simulation?
    If yeas then this is the reason for shift in frequency.



    •   Alt15th June 2017, 12:15

      advertising

        
       

  3. #3
    Newbie level 5
    Points: 101, Level: 1

    Join Date
    Apr 2017
    Posts
    8
    Helped
    0 / 0
    Points
    101
    Level
    1

    Re: Resonance Frequency in Driven Modal

    Quote Originally Posted by nomigoraya View Post
    So you included pickups with the driven model and that was not the part of Eigen simulation?
    If yeas then this is the reason for shift in frequency.
    I also felt this could be the reason but a shift of 5 MHz is too much I guess. Because in reality when we measure the S21 of the resonator (through pickups), I still read close to the simulation value but without the pickups. I beleive there might be overlap of some material properties. I also performed in eigenmode solver both with and without pickups and this offset is still existent.

    Thanks



    •   Alt17th June 2017, 11:00

      advertising

        
       

  4. #4
    Full Member level 5
    Points: 3,186, Level: 13
    Achievements:
    7 years registered Created Blog entry

    Join Date
    Jul 2007
    Location
    Trieste
    Posts
    285
    Helped
    41 / 41
    Points
    3,186
    Level
    13
    Blog Entries
    1

    Re: Resonance Frequency in Driven Modal

    Quote Originally Posted by sudhmech View Post
    I also performed in eigenmode solver both with and without pickups and this offset is still existent.

    Thanks
    If you have solved the complete model including pickups with Eigen Solver and you are getting one frequency which you are not able to get with driven model then there could be one of two possibilities
    1. Model is not setup properly either in both or one of the solvers so make sure to have proper meshing have you checked the mesh before running the simulation as far as my limited knowledge is driven model is very dependent on mesh
    2. Are you sure you are looking at the right mode as 5MHz means may be you are looking at some other mode

    Just try to think on these lines



  5. #5
    Newbie level 6
    Points: 198, Level: 2

    Join Date
    Sep 2016
    Posts
    14
    Helped
    0 / 0
    Points
    198
    Level
    2

    Re: Resonance Frequency in Driven Modal

    Quote Originally Posted by sudhmech View Post
    Dear All,

    I got a close to reality resonance frequency with eigen mode solver (simulating the enclosed vacuum volume within the resonator but with no pickup included). When I try to use the driven modal solution type with the pickup also included as antenna, my resonance frequency is different from the eigenmode solution by 5 MHz. Could some one help me with identifying where I could be possibly wrong.

    Thanks in advance!!!
    Cheers
    Sud
    I notice this all the time simulating resonant cavities at 2.45 GHz - adding some kind of coupler like an aperture/waveguide gives your cavity a slightly larger volume, thus your frequency is slightly lower.
    Also look at the mesh and the order of the simulation - make sure both eigenmode and modal excitation are mixed or second order and they might come closer together.



    •   Alt21st June 2017, 18:41

      advertising

        
       

  6. #6
    Newbie level 5
    Points: 101, Level: 1

    Join Date
    Apr 2017
    Posts
    8
    Helped
    0 / 0
    Points
    101
    Level
    1

    Re: Resonance Frequency in Driven Modal

    Hello Guys,

    Sorry for the late response as I was on vacation.

    The issue that I posted could be solved as I did not define the terminating boundary conditions properly. The resonance frequency drift is not beyond a few kHz.

    However, I am interested in solving the same in Driven Modal and am confused about how to define the port excitation.

    Click image for larger version. 

Name:	Front View.JPG 
Views:	1 
Size:	63.5 KB 
ID:	139987

    Click image for larger version. 

Name:	Side VIew.JPG 
Views:	2 
Size:	47.4 KB 
ID:	139988

    I am attaching the cavity design views to make the picture clearer. The straight and U bent stabs are the pickups through which we want to read beam current information. In my model, when I try to defiine them as a coaxial feed line and apply waveport excitations on all the ports (I changed the source magnitude to 0 W for apart from the incident port), I am not able to see the same field distribution for a solution frequency that I set as the resonance frequency I achieved from the Eigenmode solver. Could someone help me here. Thanks a lot in advance!!!



--[[ ]]--