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Objective :

To Simulate the WR-90 waveguide filled with no dielectric and to obtain the Field patterns, value ofIntrinsic
Impedance and wavelengths for the first 4 modes.

Starting Ansoft HFSS

Click theMicrosoft Start Button ,Select Programs and Select the Ansoft>HFSS9>HFSS9
or Double click the HFSS9 icon on the desktop
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On the File menu, click New. You specify the name of the project when you save it using the File>Save or
File>Save As.Open a previously saved project using the File>Open command

The Process

1. Parametric Model

Geometry/Materials

2. Analysis
Solution Setup
Frequency Sweep

2D Reports
Fields

wwwLgReHamihceaimh akd\bailspalaeWehk@hotaa(ReeRester Institute Of Technology),Rochester ,NY
The document is for study only,if tort to your rights,please inform us,we will delete


www.cadfamily.com

Ansoft Desktop

Eqaenu % Ansoft HFSS Internal Beta - via_testé - Main - 30 Modeler E.m
I % [Fe ot Yew Fropct Crw Dbodser HES Toos Wirdow Mep
DM i mB&>oc].(mA 3dodcasa@aa il «f/%® & sa]]4feuwn - \
B B8 S0 fm% Ehtliieds ZhMhliss 4 Toolbars
< O 3 i % |
| T via_testé - Main - 3D Modeler
=T vin_tasts®
= il thaint
| & Modal 3D Modeler
& Boundoriss Window
| M3 Excilolions
i i Mesh Dperetions
Project W JF fnnlysis
B Optimatics
M'anage'r : 1= Fesults
with project |t I FortFisld Display
tree o o [ Field Duerdays
|- Findision
ol bl
%. i gnd_ontpad
s pea_anlipacd
¥ il via
# [ Detnitions
= win_testh [F-Amp,/Hss34 | Setpl : Soking Adaptive Poss#1 - Building Mari=an
= @b Min | | Progress
Message - Solution Setup 'Setup ' When uzing | B Coordin.. | Glakel - Window
Manager - Salution Setup 'Sep ' When using || Po'llm:n “3brd_sizer? ,brd_o Salving LumpPodz?
!hrﬂ__sue _m
brd_see
Yroce_thickness
Status
bar
. . B Property Window
Coordinate Entry Fields ——
Erter e bos position, % [En0]r 000z [0.0090 Jabsol v |[Catesa v |Imi

WWWLgRSHamAcEan afdbailspgaevenk@hotaraiReRftster Institute Of Technology),Rochester ,NY
The document is for study only,if tort to your rights,please inform us,we will delete



www.cadfamily.com

Project Manager Window \‘

Project Manager X

Project - [ htes_coax_training '
- HFSSModel1 Design
€7 Madel
[¥ Boundaries
+ 5 Excitations
EP Mesh Operations
< fF Analysis |
Jesign Automation > @ Optimetrics
*Parametric - E Eesults i
«Optimization _ ] :
*Sensitivity +- [T Part Figld Display
*Statistical + [l Field Overlays
S Radistion
--[.] Defintions

+ (L1 Materials

Design Setup

FN

Design Results

F 3

To set up an HFSS design, follow this general procedure. Note that after you insert a design, you do not need to
perform the steps sequentially, but they must be completed before a solution can be generated.

I - Insert an HFSS design into a project.
1) On the Project menu, click Insert HFSS Design
The new design is listed in the project tree. It is named HFSSDesignn by default, where # is the order in which the

design was added to the project. The 3D Modeler window appears to the right of the Project Manager. You can
now create the model geometry

Ansoft HFSS - [Project3 — HFSSModell — 3D Modeler]
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II -Selecting the Solution Type

Before you draw the model, specify the design’s solution type.
1) On the HFSS menu, click Solution Type. The Solution Type dialog box appears.

Solution Type: Projectd - HFSSHModell =

= Driven Terminal

{7 Eigenmode

ak. I Cancel I

2) Select Driven Modal in the solution types.
We select Driven Modal as our model is a rectangular waveguide and Driven modal is used for calculating the

mode-based S-parameters of passive, high-frequency structures such as microstrips, waveguides, and
transmission lines, which are “driven” by a source

III- Setting the Model’s Units of Measurement

You can then choose to display the model’s dimensions in the new units, or rescale the model’s dimensions to the
new units.

To set the model’s units of measurement:
1. On the 3D Modeler menu, click Units. The Set Model Units dialog box appears.

Set Model Uniks =]
Select units: =

I Rescale to newe units

2. Select the new units for the model from the Select units pull-down list.

You can select the Rescale to new units option to rescale the dimensions to the new units. Clear the Rescale to
new units option (the default) to convert the dimensions to the new units without changing their scale

3. Click OK to apply the new units to the model.

IV-_Drawing a Model

wwwLgReHamihceaimh akd\bailspalaeWehk@hotaa(ReeRester Institute Of Technology),Rochester ,NY
The document is for study only,if tort to your rights,please inform us,we will delete


www.cadfamily.com

You can create 3D objects by using HFSS’s Draw commands. Objects are drawn in the 3D Modeler window.

To draw a WR-90 Rectangular waveguide ,

1. On the HFSS menu, click Draw. The Draw dialog box appears.Select Box

"] Eile  Edit Wiew Project | Draw 3D Modeler HFSS  Tools  window  Help

F "vacuum

1o

E|-- Froject3”
-8 HFSSModell
ED Drefinitions

D M aterials

Base Rectangle

D e | 5 B2 | £ - Line

@ EZ2SRBRO - B0 X b= teta 2=

L Wy _-)l =e A gpline

S = O R oo S ||wy

=1

B =N

Arc »

2t (o]~ (@ [ o [[EE]] 4 5 o ]

[ Recktangle

a
= Ellipse

< Circle
"+ Regular Polygon

Leleo- |
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2. Dimensions of the box can be specified while drawing the box .At the lower end of the screen on the right is
the Coordinate entry fields

A

1]

N o

Z°

|q—7 Coordinate Entry Fields

3. Enter the Initial XYZ coordinates and then enter the length in XY &Z direction in dX,dY&dZ .
For e.g to draw the box with initial point to be origin and propogation along X axis. Since it is a WR-90 rectangular
waveguide the dimensions are a=2.286cm , b=1.016cm.

ol

dy: 2286

o Pl

1.016

Relaty, -

_Artesia = | cm

The length of the waweguide = any multiple of

the wavelenghth

Once you Draw the box the properties window opens up , you can also specify the coordinates and size of the box

here
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The properties window can also be obtained by
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V- Assigning Materials

1) Right click on the 3D Modeler Window to get the 3D Modeler menu
2) On the 3D Modeler menu, click Assign Material.

Select Objecks

Mexk Behind
all Object Faces

Measure

S

Edit

¥ Assign Material. ..

Assign Boundary »

Assign Excitation »

Assign Mesh Operation

,,,,, = Results EI@ Lisks A=sign Excitation
,,,,, Port Field Dizplay % allobjecks Assign Mesh Operaktion »
[ Field Owverlays Flok Fields 3 Duplicate
""" ? Fadiation Flot Mesh Scale
=-[C3 Definitions I
A LY Surface L

3) The Select Definition window appears. By default, it lists all of the materials in Ansoft’s global material

library as well as the project’s local material library.
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4.Select a material from the list. Select Air or vacuum for the whole box as our rectangular waveguide is not

filled with any dielectric.

5.Click OK.

6. The material you chose is assigned to the object.

VI- Assigning Boundaries

Boundary conditions specify the field behavior at the edges of the problem region and object interfaces.

Vertex

Plane

z

/Cooldinate System (CS)

Origin

Face

1) Right click on the 3D Modeler Window to select faces
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2) Click on the faces to select the faces which are to be assigned to be a perfect conductor
3) On the HFSS menu, click Boundaries.Select Assign and choose Finite conductivity.
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Delete Al
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Symmetry...

Master...

Slave..,
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VII- Assigning Excitations

Excitations in HFSS are used to specify the sources of electromagnetic fields and charges, currents, or voltages on

objects or surfaces in the design.

Assigining excitations is a two step process

VILI. a) Assign Ports
b)Assign an Intergration Lines or Terminal lines separately for each modes

a) Assigning Ports

1. Select the object face to which you want to assign the port.

2. Click H FSS>Excitations>Assign>Wave Port.
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Wave port represents the surface through which a signal enters or exits the geometry. Hence 2 ports are required
to be defined. HFSS assumes that each wave port you define is connected to a semi-infinitely long waveguide
that has the same cross-section and material properties as the port. HFSS generates a solution by exciting each
wave port individually.

Select Objecks
Seleck Faces

rext Behind
4all Sbhject Faces

Measure
Wi »

Edit g

H=sign Boundary »

a=sign Excitation

A=zsign Mesh Operation > Lumped Fork. ..
Incident Wawe. ..
Flot Fields L4

woltage. . .
Flokt Mesh

3. The Wave Port wizard appears.
4. Type the port’s name in the Name text box or accept the default name, and then click Next.

M arme: |"v'-.-"aveF'|:|rt'I

5. To specify more than one mode to analyze at the port, type a new value in the Number of Modes box, and
then click Update. The mode spreadsheet is updated to include the total number of modes

MHumber of Modes; |4 |lpdate

tode Integration Line | Charactenstic Imp. [£o]
| Mone j
2 MHaone Zpi
3 Zpi

4 Hone Zpi
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b) Defining Integration Line

An integration line needs to be specified to define a port mode. Since we are analysing the WR-90 waveguide
for the first 4 modes we need to specify 4 intergration lines

1. Select New Line from the mode’s Integration Line list.
2.The dialog box disappears while you draw the vector

Create Line

Cirawve the port line. “hen you are finished, the port edit dialog will
reappear.

Cancel

4. Select the start point of the vector in one of the following ways
4.a. Click the point. Or Type the point’s coordinates in the X, Y, and Z boxes at the lower end of the screen
5. Select the endpoint of the vector using the mouse or the keyboard. The endpoint defines the direction and
length of the integration line.
6. The Wave Port or Lumped Port dialog box reappears.

VIII-_Solution Setup

a) Adaptive solution setup
b) Frequency sweep setup

Adaptive solution setup

1. On the HFSS menu, point to Analysis Setup, and then click Add Solution Setup

-8 HFSSkodell =] EE
L =P Model Eg
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-G Exciations
----- B Mesh Opergions

..... £ Lp—

_____ ﬁ F'.-:h:I Solukion Setup. ..
..... = Re Lt
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Tnnls window  Help

1 Solution Type. .. I~ « O £ iy &
List... v <l =
&% Validation Check. ..
! il &
1B Edit Motes. .. B % ®
30 Model Editor Or

Boundaries

3
Excitations 4
Mesh Operations 4

Add Solution Setup. ..

Optimetrics Analysis b ™ Add Sweep...

2. The Solution Setup dialog box appears. It is divided among the following tabs:

General - Includes general solution settings

Advanced - Includes advanced settings for initial mesh generation and adaptive analysis

Ports - (if a port was defined) Includes mesh generation options for model ports

Defaults - Enables you to save the current settings as the defaults for future solution setups or revert
the current settings to HFSS’s standard settings.

3. Click the General tab.
3.a For Driven solution types, do the following:

1. Enter the Solution Frequency in the frequency units.
The minimum value for adaptive Mesh Frequency is 2/3™ of the final frequency required .Although it is
recommended to just adapt to the Final frequency.
Since we are analyzing the first 4 modes of the WR-90 waveguide the Cut-Off Frequency of the last mode is
16 Ghz. Hence the Final Frequency is a value, which is higher than that. For e.g. 20Ghz

2 .Enter the Maximum Number of Passes = 10
The Maximum Number of Passes value is the maximum number of mesh refinement cycles that you
would like HFSS to perform. This value is a stopping criterion for the adaptive solution; if the maximum

number of passes has been completed, the adaptive analysis stops. If the maximum number of passes has
not been completed, the adaptive analysis will continue unless the convergence criteria are reached

3. Enter the Delta s =. 002
The delta S is the change in the magnitude of the S-parameters between two consecutive passes.

4.Click Ok
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Solution Setup

General ] Advanced ] Ports ] Default= ]
Adaptive MeSh— S alution Freguency: ||20 GH= - |
Frequency
[ Solve Ports Only
Adaptive Solutions
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b axirnurm Delta 5 Per Pass: o002
Use Defaultz

(] I Cancel
Frequency Sweep setup

1. In the HFSS menu Select Analysis Setup and then select Add sweep

- =P
= =T Ej

=% e Hl| 288 P r

LB Boundaies -l

--E Escitations [y
i-EF Mesh Operations - |

@--.ﬁ? Analpzis SELECT

[+

F.ename

: Cielete
= —

--F_‘TI Fai Properties. ..
Aod Swesp...

H - -
Project I fralyzs

Rewvert ko Initial Meash
Apply Mesh Spenctions

M ame Y Profile
M ame Setup Convergence
Passes 3 Matriz Data

2.The Edit Sweep Dialog Box opens.

3.Select Discrete and enter the Start and stop Frequency.
Since we are analyzing the first 4 modes of the WR-90 waveguide the Cut-Off Frequency of the last mode
is 16 Ghz. Hence the Stop Frequency is a value, which is higher than that. For e.g. 20Ghz

4.Click OK
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Edit Sweep |
Sweep Type DC Extrapolation Options
f* Dizcrete I
" Fast | | J
" Interpolating ™
Time Domain Caleulation. .. |
Frequency Setup | Frequency

Type: Linear Step -
Start |1 |GH2 ﬂ Dizplay >>

Stop |2|:| |GHz =]

Step Size |1 |GHz =]

[ Sawe Fields (&l Frequencies)

| ak. I Cancel

VIII — Running a Simulation

To validate your model
1.Select HFSS menu > Validate Check

2.Click OK
Walidation Check: hf_keds_diftfpair? - HESSMadeal1 =
™ 30 Madsl
@ e S E e T Boundatis: and Excitatione
" Mezh O perations
waldatian Cheek completed  Emors: 0 Warrings: 2 o Anolpsiz Solup
o Optimelics
Fadiation
See Messags wwindoss o det=ix
Cloz=
To Analyze

1.0n the HFSS menu, click Analyze

EESB O

While a simulation is running, you can monitor the solution’s progress in the Progress window.

Setupl: Solving Fors an Local Machine -

Adepting pl. Fess 9
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You can also view the following solution data at any time during or after the solution

» Convergence data-- by clicking HFSS>Analysis Setup>Convergence.
» Matrices computed for the S-parameters, impedances, and propagation constants by clicking
HFSS>Analysis Setup>Profile.

Once the simulation is completed HFSS Informs you in the message window.

Results

HFSS > Results > Solution Data
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HF'SS computes the following matrix data
» S, Y, and Z Parameters
» VSWR
» Excitations: - Gamma and Zo

Plotting the results

HFSS> Results> Create Report

Or you can also go to the project tree and right click on results and click create report. The Create report
window dialog box appears.
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1) Select the report type you want to view from the pull down list on the top of the dialog box

2) Select the type of plot you want to create, from the display type pull down list.

3) Click OK
The Traces dialog box appears

4) In the Solution list, click the solution containing the data you want to plot.

5) In the domain list, click a domain. For modal and terminal S- parameter reports, the domain can be
frequency or time. In this case we want frequency domain.

6) Click on Add Trace, click Done
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1) Analyze the propagation constant for the first four modes.
2) Determine the wavelength at different frequencies for the first four modes.

3) Determine the intrinsic impedance at different frequencies for the first four modes
4) Analyze E and H field patterns for the first four modes.
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Plot of propagation constant vs. frequency for TE10, TE20, TEO1, TE and TM11 using HFSS
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Note that the mode propagates only when the propagation constant has is real and the operating
frequency is greater than its cutoff frequency. As the traveling waves are functions of exp(-j# z), has

to be real and make exp(-j# z) imaginary.

Plot of propagation constant vs. frequency for the first four modes using Theoretical values

Fropagation Constant vs Frequency
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Similarly you can draw plots for wavelength vs. frequency and impedance vs. frequency from the data
given in the solution data box.

1. In the project tree, right-click the solution setup of interest, and then click Matrix Data on the
shortcut menu.The Solution Data dialog box appears. The Matrix Data tab is selected.

2. In the Simulation pull-down list, click the solution setup and solved pass - adaptive, single
frequency solution, or frequency sweep - for which you want to view matrices.

3. Select the type of matrix you want to view: S,Y, and Z matrices or Z, (characteristic impedance.).
The wavelength data is displayed when you check the gamma box. The available types depend on the
solution type.

4. Select the format — Magnitude/ Phase, Real/ Imaginary, dB/ Phase, Magnitude, Phase, Real,
Imaginary, or dB — in which to display the matrix information. The available formats depend on the
matrix type being displayed.
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Impedance vs. Frequency for the first four modes
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Field Patterns for E and H fields

On the project tree click on Port Field Display>wave port 1>model
The TE10 mode will be displayed in the model
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Similarly click on mode2, mode3 and mode 4
TE20
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To view E and H field patterns

Select the face for which you want to view the field pattern
On the HFSS menu click on Fields>plot fields>mag E
For H field pattern click on Fields>plot fields>mag H
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E field : attern in [v/m]
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