
2005 Aug 1

Advanced Design 
System

Lecture : 劉益良、張訓豪

Date : 2005/08/18                  



22005 Aug

Course Topics

1:Circuit Simulation Fundamentals
2:DC Simulation and Circuit Modeling
3:AC Simulation and Tuning
4:S-Parameter Simulation and Optimization
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Here is ADS Simplified: 3 steps

STEP 1: design capture

Insert circuit & system 
components and set up 
the simulation.

STEP 2: Simulation

Netlist is automatically sent to the 
simulator.

Simulation results(data) are 
written to a dataset.

STEP 3: display the results

Plot or list data & write 
equations.
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Starting ADS and creating a project

To create a new project: 
click the folder icon or File >
New Project and name it.
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Project directories are created and a 
blank schematic window opens!

ADS automatically creates these directories for every project. But they are 
empty until you create the schematics, simulate to produce data, and 
display the results.

NOTE: A new schematic becomes a .dsn
file in the networks directory only after 
you save it with a name.
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Schematic window 

Use 
icons to 
create, 
open, 
and 
save 
designs.

Zooming and 
View all icons.

Move, copy, delete, undo

Rotate , 上下
翻, 左右翻

ADS has many palettes – with many 
components for creating schematics 
and simulation setups!
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Inserting and editing components
End command 
or use ESC Activate / DeactivatePush / Pop for 

sub-circuits.

Edit components to see and 
modify parameter values.

也可以直接
在此處修改

Component History: type 
the name = get the 
component. 

大小寫有差別!!
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Hot keys are labeled

Pin / Gnd Wire / 
Wire or 
Pin label

宣告變數
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Check your schematic for errors
Tools > check representation

View > clear Highlighting

已連接的
點是藍色,
而未連接
的點為紅
色。
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First step: insert a Simulation 
Controller

*NOTE asterisk means schematic is not yet saved.

Click the gear and insert the 
controller.
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Next, edit the Simulation parameters.

By default, freq is the swept variable here!

Edit on-screen if the parameter 
is displayed or use the dialog 
box.

Output tab 
allows you to 
select what goes 
to the dataset

Display tab lists 
all the settings 
for on screen 
display.
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Running the simulation
Click: Simulation > Simulation setup:

result

display

Before you simulate:

•You can name the dataset file.

•If not, default dataset = schematic name.

Dataset files (.ds) are in the                

DATA directory.

Data Display windows (.dds)

are in the PROJECT directory.

To simulate: use F7 key, click 
Simulate, or click the gear icon on the 
schematic.
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Simulation information: Status Window

One way to stop a 
simulation, click:

Simulation/Synthesis      
> Stop Simulation

A successful simulation 
results in a dataset:

If there is a warning or 
error, it will appear here.

When finished, the 
Data Display opens…
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Data Display window
If automatically opens or you can open this window from any Schematic or 
the ADS Main window:

Default dataset

First, select a 
plot, list or Eqn
for the data….

•Data displays open empty the first time, 
unless you use a template.

•You insert plots, lists, equations using the 
default dataset file or other dataset files that 
are specified explicitly.
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List or plot the simulation data…
STEPS:

1.Insert the plot, list, or 
equation.

2.Select the data or 
equations.

3.Options – edit data 
or plot.

4.Save / name the 
DDS window.

Other datasets and 
DDS equations, click 
here!

Trace Options:edit
data traces or 
equations here.

Measurement equations 
and variables from 
schematic are also 
available.
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You control all your simualtion data

資料多時可分頁

上頁/下頁

可將兩marker的資
料相減

若equation 合法就
為黑色,若不合法就
為紅色

•Insert > Templates

•Create Pages

•Zoom into plots

•Scroll through lists
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Tuning Parameters: tune mode = 
simulation Simulate > Tuning…

Tuning allows you to tweak parameter values and 
see the results!

要點選
參數而
不是元
件!
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Review: contents of an ADS Project 
Directory

To delete ADS files, 
use the Main Window 
command:              
File > Delete Design

Project

.dds files (data display server): Data display 
windows you create to display simulation data. 
You cannot see these in the Main window. (在
project下)         

data directory contains .ds files (datasets). 
This is the simualtion data.

Networks directory contains .dsn files (designs). 
These are layouts and schematics with 
simulation setups. 

Preference files & ADS netlist.log
mom_dsn (Momentum) 

Substrates (Momentum)
Synthesis (used for E-Syn & DSP
Verification (used for DRC)
notebook

These miscellaneous 
directories are not 
required for most circuit 
simulations.
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ZAP your projects for e-mail or disk

From the Main window, click: File > Archive or Unarchive

NOTE: Archive 
files become .ZAP 
files.

They can include 
all networks, data, 
and display files 
(entire project).
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Course Topics

1:Circuit Simulation Fundamentals
2:DC Simulation and Circuit Modeling
3:AC Simulation and Tuning
4:S-Parameter Simulation and Optimization
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DC Simulation

You get steady-state DC voltages and 
currents according to Ohm’s Law: V=IR

•Capacitors = treated as ideal open circuits

•Inductors = treated as ideal short circuits

•Topology check: dc path to ground (if not error 
message)

•Kirchoff’s Law satisfied: sum of node current = 0
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DC simulation controller
Palette and editor (dialog box)

VAR

Sweep: allows you to sweep a 
parameter but it must be declared as a 
variable. Note the dialog entry 
automatically puts quotes on the 
controller (screen) entry.

Swept Variable in the controller

Initialize 
Vce!!
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DC Parameter

You can get V, I, and Power!
Available after simulation on 
schematic.
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Schematic Annotation of DC values

Simulate >

Clear it here

No controller settings necessary!

Immediately after DC simulation, click: Simulate > Annotate DC 
Solution.

Minus sign used for current flowing 
out of a connection. Otherwise, 
current flows into a connection or 
device.

DC Simulation Controller is 
required in all simulations if you 
want DC annotation.
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Wire/Pin Labels (node names) in 
schematic 

To label a node, use the icon:
•Type in the name, point and click.

•You get node voltage in the dataset

•Use these in equations: dBm (Vout).

•Connect two pins by name – without a 
wire.

•Move and edit the label names 
(attributes).

•You can also create busses.
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Wire/Pin Labels (node names) in 
schematic

To remove a label, use the icon:          
With a blank (no name), click on the node. 

Or Edit > Wire/Pin Label > Remove 
Wire/Pin Label

To edit the label, double click it, Or 
use the command: Edit > Wire/Pin 
Label Attributes 
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Variable Equations: VAR

Click:

Component parameters can be assigned to 
a varable: VAR.

VARS can be used with optimization, 
parameter sweeps, and other applications!

兩邊至
少要有
一邊有
單位
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Analog Models

Model Cards: use a 
built-in symbol and 
model card which lists 
all the parameters 
that you can modify. 
This example is a BJT 
model.
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Symbols, units, names, case sensitivity

Example of on-screen control:
C (component name): changes the component   
C1 (instance name): rename it                            
C= (parameter): a number (unit) or valid variable.

Case Sensitivity:
UNIX is always case sensitive:

PC is usually case sensitive:

•For example, insert R – after the first insert, PC 
will recognize either r or R.

•But m=milli, M=mega, V=volts, and VARS are 
case sensitive all of the time!                                 
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Hot keys (key binding) for components

Tools > Hot Key / Toolbar Configuration > Component Menu / Hot Key.

In this tab, you set Hot 
Keys for components, 
library items, 
controllers, and 
sources.
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ADS default command Hot Keys

Pre-configured keys:

F7 = simulate

F5 = Move Component Text

Try this now: click the F5 key, 
select the component, move 
the cursor and the text will 
follow!

If you don’t like mouse clicks, 
HOT KEY your keyboard.

Its global for all projects. 
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NOW: Set up a Hot Key in a new 
project
STEP 1: Tools > Hot Key / Toolbar Configuration

STEP 2: Set up a hot key for the Simulation setup a. Select the command.

b. Type in the letter: S

(not case sensitive).

c. Click: Assign & Apply.

d. Press the S key to verify            

it works.
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Viewing and creating a schematic symbol

View > Create / Edit schematic Symbol View > Create / Edit Schematic
Schematic view Symbol view
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Design parameters for any schematic
Click: File > Design / Parameters to set parameters for your design:

•Description for library annotation

•Component instance name: Q

•Symbol: SYM_BJT_NPN

•Passed parameter for Bf = beta

You can copy parameters from other 
library models.
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Insert the model in a new schematic

Insert the sub-circuit from the library

ICONS: Push into and 
Pop out of the 
hierarchy.

Design 
parameters 
follow the sub-
circuit: Q1, beta, 
etc.
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Course Topics

1:Circuit Simulation Fundamentals
2:DC Simulation and Circuit Modeling
3:AC Simulation and Tuning
4:S-Parameter Simulation and Optimization
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AC Simulation

You get linear small-signal response and 
you get Noise values:
•DC analysis performed (unseen)

•Nonlinear devices are linearized

•Kirchoff’s Law satisfied: sum of node current = 0

•Noise contributors defined and listed

•Budget analysis available (for named nodes)

•Signal voltages are peak – noise voltages are RMS
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AC Simulation Controller

AC is a linear or small signal 
simulation and freq is defined 
in the cintroller not the source.

Set on-screen parameters 
in the Display tab

Turn Noise 
on/off: yes/no
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AC Noise calculations

Click 
here:

Again, use the Display tab 
to see your settings on-
screen.

Nodes are Wire/Pin 
Labels.

Sort by name or by 
value: in the dataset.

Blank gives you all 
contributors.

NOTE: Port Noise 
can be included in 
the simulation, but 
it does not apply to 
NF. 
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AC sources are for AC simulations
Three AC sources… Source parameter definitions:

•V_AC, P_AC, and I_AC are component names.

•SRC1, PORT1, and SRC2 are instance names 
which you can change.

•Vac=polar(1,0)V is the default value. The polar 
function can be removed.

•Freq=freq is a global variable – you set the start 
& stop values in the simulation controller.

•P sources are also ports (ok for S-parameter).

•Num=1 is the port number.

•I current sources can be used for other 
simulations to inject current.

•Arrow in symbol shows the direction of current 
flow.
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Setting AC source values

Simplify Pac by removing the 
polar function.

•POWER: The dbmtow function converts 
power in dbm to watts for the simulator.

•PHASE: The polar function specifies phase. 
By default, all sources are cosine waves. Use 
-90 for a sinewave.

•NOISE and Vdc: By default, noise is turned 
on for the P_AC source. Use Display 
tab/settings to make visible. Vdc 10 mV is an 
offset.

•Equations can also be used: P=1W, 
P=1+j*1W, P=complex(1,0), etc.
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Review of ADS equation types

Schematic

Data display

•VAR: pre-simulation
Use for initializing sweep variables or other 
settings. VARs are available in the dataset if 
you select them in the Output tab of the 
simulation controller.

•MeasEqn: pre-simulation
Use for calculations on schematic and are 
available in the dataset by default. Use 
node labels and functions.

•Eqn; post-simulation                          
Use for calculations in the data display. Use 
node voltages, functions, and any dataset 
data.
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Review of Data Display equation editor

Schematic MeasEqns
appear in the dataset.

Click here for DDS 
equations:

•Invalid equations are red.

•Valid equations are black.
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LAB 1: Circuit Simulation Fundamentals

1. Start ADS on the computer.

2. Create a new Project. (type the name: lab1)

3. Create a low-pass filter design.

a. In the Main window, click the New Schematic Window icon (shown here).                          
This is the same as selecting the menu command: Window > New Schematic 
Window. Immediately, the Schematic window will appear. If your preferences are set to 
create an initial schematic, you will have two schematics now opened – close either one 
of them.  
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b. Save the schematic. Notice the top window border of the schematic shows the schematic 
name as untitled. Click the icon (shown here) and the Save Design As dialog will appear. 
Type in the name lpf and click Save. This will save it in the networks directory of lab1    
project. 

NOTE on saving designs – After naming the schematic, the Save icon will not bring up this
same dialog box. Instead, it will save the named design. To save the design with a different 
name, use the command: File > Save Design As.

c. In the Lumped Components palette, select (click) the capacitor C shown here (not the C 
model). Then click the Rotate By Increment icon as needed for the correct orientation and 
then click to insert the capacitor as shown on the schematic. Next, insert another capacitor.

Rotate

NOTE: some boxed items (R, L and 
C) are models-not components.
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d. Continue creating the low-pass filter as shown by inserting the inductor and 
grounds (icons are shown here). Then wire the components together. This will 
give you practice with schematic capture. You can try using the copy, move 
and other icons or commands.

e. After the filter is built, edit the value of C2 to be 3 pico-farads. To do this, 
double click the capacitor symbol or select the capacitor and use the icon 
(shown here). When the dialog box appears – change the value: C=3.0 pF, 
click Apply and OK.

f. Next, select the Simulation-S_Param palette and insert the S-parameter
simulation controller (gear icon). Use the ESC key to end the command.

g. Then insert the port terminations: Term Num=1 and Term num=2 shown 
here.
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h. Use Component History: After the circuit is built, 
delete capacitor C2 and then reinsert it by typing or 
selecting (history) the capital letter C in the Component 
History field and press Enter. Next, edit the value 
directory on the schematic by highlighting the value and 
typing over it with the value (3.0 pF). Verify that it has 
changed by looking at the value in the edit dialog box.

4. Setup the S-param Simulation.
a. To setup the simulation, double click on the S-

parameter simulation controller on the schematic. When 
the dialog box appears, change the Step-size to 0.5 GHz
and click Apply. Notice how it updates the value on the 
screen . The OK button does the same thing as Apply 
and also dismisses the dialog box - do not click Ok yet.

b. Click the Display tab and you will see that the Start,  
Stop and Step values have been checked (by default) to 
be displayed on the schematic. Later in this course, you 
will use the display tab to check other parameters you 
want displayed on the schematic.

c. Click the OK button to dismiss the dialog box. You 
are now ready to simulate.
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5. Launch the simulation and display the data.
a. At the top of the schematic window, click the Simulate icon gear (shown here)                   

to start the simulation process.

b. Next, look for the Status window to appear and you should see messages 
similar to the ones here, describing the results of the simulation, the writing of the 
dataset file, and the creation of a display window. If not, ask the instructor for help.

NOTE: If you scroll up, 
you will see more 
simulation information

c. If no simulation errors occurred, close the Status window. You can always get the 
status window back  using the schematic window command: Window > Simulation
Status.
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d. The Data Display window will appear with the name lpf in the top left corner – this 
is the same name as your schematic. Also, you are looking at page1 which is blank 
at this time. Examine the picture below – the next steps will show how to display the 
simulation data. 

The default 
DATASET name 
appears here.

Rectangular Plot

This palette is 
where you choose 
a plot type, list 
table, or equation 
to insert.

These buttons are used to zoom 
or scroll through lists of data.



502005 Aug

e. To create the plot, click on the Rectangular Plot icon and move the cursor 
(with outlined box) into the window and click. When the next dialog box appears, 
select the S(2,1) data and click the Add button. Then select dB as the format for 
the data. Click OK in both boxes.

f. The plot should show a reasonable low pass filter response.
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g. Put a marker on the trace: Click the menu command: Marker > New. Select a 
point on the trace and click to insert the marker. Select the marker or the marker text 
and move the marker using the cursor or the keyboard arrow keys. Also, move the 
marker text by selecting it and positioning it as desired. Try deleting the marker or 
putting another marker on the trace.

6. Save the Data Display Window.

7. Tune the filter circuit.
This step introduces the ADS tuning feature that allows you to tune parameter 
values of components and see the simulation results in the data display. In this 
step, you first select the components and then select the tuning feature. If you 
select the tuning feature first, you must select the component parameters and 
not the components. 
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a. Position the Data Display and the Schematic windows so you can see them 
both on the screen. If necessary, re-size thewindows and use View All.

b. Now, in the lpf schematic, select both components C1 and L1 using the SHIFT
or Ctrl key as shown here.

c. Now, start the tuner by clicking the command: Simulate>Tuning or click the Tune   
Parameters icon (shown here).

Immediately, the status (simulation) window will appear along with the Tune Control 
dialog box (shown here). Go ahead and tune the filter using the default settings and 
watch the updated traces appear in the Data Display.
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Move the slider or click on the buttons 
to tune values. Notice how the new 
traces appear on the s_data plot after 
each change.

Each tuning creates another trace. 
The marker moves to the most recent 
simulated (tuned) trace which is 
thicker than the others. This trace is 
the s_data dataset which is changed 
each time you tune (simulate).



542005 Aug

d. Change the tuning range: In the Tune Control dialog, click Details 
and watch the dialog change from brief to detailed. Type in a larger 
range such as 6 and then tune the filter again. You should be able to 
see a greater range of responses.

Change the 
ranges here.

e. Continue tuning until you are satisfied with the results – click the Update button 
to have the C and L unit values updated on the schematic. If you click the 
Component button you will notice that it allows you to add other parameters to the 
tuning . The Brief button returns to the smaller (brief) Tune Control dialog.
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f. When you are satisified with the 
tuned response, simply click the 
Cancel button and the plot will 
contain the final tuned trace similar to 
the one shown here. It is not 
important to achieve any particular 
goal in this lab exercise but simply to 
learn how to use the Tuner.

g. Save the data display and the 
schematic using the Save icon. Then 
close both windows so that only the 
ADS Main window remains.
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Lab2:DC simulations and Circuit Modeling

1. Create a new project: amp_1900.
a. Then, open a new schematic window and save it with the name: bjt_pkj.

2. Set up a generic BJT symbol and model card.
a. In the schematic window, select the palette: Devices-BJT. Select the BJT-NPN device 

shown here and insert it onto the schematic.

b. Insert the BJT_Model (model card) shown here.

NOTE: The BJT_NPN symbol 
shows Model = BJTM1. This 
means the symbol will use that 
specific model (model card) for 
simulation. 
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c. Double click on the BJT_Model card. When the dialog appears, click Component 
Options and in the next dialog, click Clear All for parameter visibility – then click Apply. 
This will remove the Gummel-Poon parameter list from the schematic. Keep this dialog 
open.

d. Next, in BJT_Model dialog, select the Bf parameter and type in the word beta as shown 
here. Also, click the small box: Display parameter on schematic for Bf only and then click 
Apply. Beta is now a parameter of this circuit - later on you will tune it like a variable.

Click here to display an 
individual value.

Use Component Options to 
clear all the displayed 
parameters.
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e. Set Vaf (Forward Early Voltage) = 50 and display it.

f. Set Ise (E-B leakage) = 0.02e-12, and display it also. Then close the dialog with OK. 
The device now has some more realistic parameters.

g. For the BJT device, remove the unwanted display parameters (Area, Region, Temp 
and Mode) by unchecking the box. This will make the schematic less crowded with 
parameters that you are not using.

3. Add parasitics and connectors to the circuit.
The picture shown here is the completed sub-circuit with connectors and parasitics. 
Remember to use the rotate icon for orientation of the components as you insert 
them. Here are the steps:
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a. Insert lumped L and C components: Insert three lead inductors of 320 pH each and         
two junction capacitors of 120 fF each. Be sure to use the correct units (pico and         
femto) or  your circuit will not have  the correct response. Tip: type L or C in component 
history to get the components onto your cursor without using the palette.

b.  Add some resistance R=0.01 ohms to the base lead inductor and display the desired 
component values as shown.

c.  Insert port connectors: Click the port connector icon (shown here) and insert the
connectors exactly in this order: 1) collector, 2) base, 3) emitter. You must do             
this so that the connectors have the exact same pin configuration as he ADS BJT     
symbol.

d.  Edit the port names as show here: change P1 to C, change P2 to B, and change             
P3 to E.

e.  Clean up the schematic: Position the components so that the schematic looks     
organized – this is good practice. To move component text, press the F5 key,             
select the component, use the cursor to position the text.
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NOTE: you must number the 
ports (num=) exactly as shown 
or the device will not have the 
correct orientation for the 
symbol that will be used.

4. View the default symbol.
There are three ways to create a symbol for a circuit: 1) use the default symbol, 2) draw 
a symbol, or 3) use a built - in ADS symbol. For this lab you will use a built-in BJT 
symbol. The following steps show how to do this: 
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a.  To see the default symbol, click: View > Create/Edit Schematic Symbol. When the 
dialog appears, click OK and the default symbol will appear.

b.  Next, a box or rectangle with three ports is generated. This is the default symbol. 
However, delete this symbol using the commands: Select > Select All. Then click the 
trash can icon or delete key.

c.  Return to the schematic – click: View > Create/Edit schematic.
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5. Set up the Design Parameters and built-in symbol.
a. Click File > Desgin Parameters and  the dialog appears.

b. In the General tab, make theses changes: 1) change the Component Instance Name 
to Q, 2) change the Symbol Name to SYM_BJT_NPN by clicking the arrow and 
selecting it (this is the built-in symbol), 3) in the Artwork field, select Fixed and SOT23
as shown here.

Built-in symbol:  
SYM_BJT_NPN
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c. Click Save AEL File to write these changes but do not close this dialog yet because you 
still need to set other parameters.

d. Go to the Parameters tab. In the Parameter Name area, type in beta and assign a 
default value of 100 by clicking the Add button. Be sure the box to Display the parameter 
is checked as shown here. Click the OK button to save the new definitions and dismiss the 
dialog.

The parameter beta is 
now recognized as a 
variable of this circuit. Its 
value can now be passed 
(assigned) from an upper 
level hierarchy when you 
use bjt_pkg as a sub-
circuit.

NOTES: multiplicity_M

You can define multiple components in 
parallel. You can also copy parameters 
from another device or file.

e. In the schematic window, Save the   
design. In the next steps, you will see   
how the Design Parameters will be used.
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6. Use a curve tracer template to test the bjt_pkg sub-circuit.
a. In the current schematic of the bjt_pkg, click File > New Design. When the dialog 

appears, type in the name: dc_curves and select the BJT_curve_tracer template as 
shown. Click OK and a new schematic will be created with the template, ready to insert 
bjt_pkg.



652005 Aug

This is where you will 
connect the device 
(bjt_pkg) in the next 
few steps.

This is a data 
display template - it 
will automatically 
plot the curves.
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b. Save the design and then click the Component Library icon (shown here).

c. When the dialog opens, select the amp_1900 project as shown and click on the bjt_pkg
sub-circuit. Insert it into the schematic as shown here. Every circuit that you build will be 
available in the project library as a sub-circuit.

d. Connect the bkt_pkg component as shown. You 
may have to adjust the wires and text (F5) to make it 
look good. Also, you can now close the library
window and save the dc_curves design again – it is 
good practice to save often.
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7. Modify the template Parameter Sweep.                         

a. Change the Parameter Sweep IBB values to: 0 uA to 100 uA in 10 uA steps as shown 
here. Do not change the DC simulation controller default settings for sweeping VCE – they 
are OK.  Notice that the VAR1 variables (VCE=0 and IBB=0) do not require modification 
because they are only required to initialize (declare) the variable for the simulator.    

Only one variable can 
be swept in the 
controller.

Parameter sweep used for 
multiple variable sweeps. Note 
that DC1 is the name 
(SimInstance Name) of the 
simulation controller.

VarEqn is required 
to initialize variables.
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8. Simulate at beta=100 and 160.
a. Simulate (F7) with Beta = 100. After the 
smulation is finished, the data display will appear 
with the curve tracer results (data display 
template). Try moving the marker and watch the 
updated values appear.

b. Simulate again with Beta = 160 by changing 
the value directly on the schematic. You should 
see the updated values.

c. Verify the values for beta = 160 and VCE = 
3V, where IBB=40 uA and IC=3 mA with about 
10 mW of consumed power If not, check the 
design.

DC Curves at 
beta = 100

9. Open a new design and check all your files in the Main window.

a. Save the current schematic: dc_curves. In the same window, create a 
new design (without a template) named: dc_bias. Then save the design by 
clicking on the Save Current Design icon (shown here) so that it is written 
into the ADS database.
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b. Now, check the ADS Main Window: you should have 3 designs in the networks directly: 
bjt_pkg, dc_curves, and dc_bias. You may have to double-click on the file browser 
networks to refresh the browser.

c. In the File Browser area, click on the plus / minus boxes and the up arrow (or two dots). 
This allows you to see the files you have created in this project. Remember: you can only
work in one project at a time, but you can copy files from other projects and bring them in.

Try clicking the plus 
(expand) and minus 
(contract) boxes.

Try the up arrow. Project and directory 
path are shown here.

d. Finally, try the Show / Hide all windows feature. This is used for security or to find 
other open windows that are not ADS.

In this case, only the Main window remains.
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10. Set up and simulate the dc bias parameter sweep.
NOTE on parameter sweeps: If only one variable is swept, you can use the Simulation 
controller (Sweep tab). However, if more than one parameter is swept, a Parameter sweep 
component is required as in the templates you have just used. In general, all simulation 
controllers allow you to sweep only one parameter (variable).

a. Insert the bjt_pkg using library icon or the component history. Now push into the 
bjt_pkg and click File > Design Parameters. Reset the beta parameter default to160, pop 
out and delete the bjt_pkg and reinsert it – beta is now 160 whenever you use the 
modeled circuit.
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b. From the Probe components palette or component history, insert an I_Probe and 
rename it IC instead of I_Probe1 as shown here.

c. From the Sources-Frequency domain palette or using component history, insert a dc 
supply and current source and set their values as shown: Vdc = 3V and Idc = IBB as 
shown here.

d. Wire the components together and add the ground (ground icon).

e. Insert a DC simulation controller or DC. Edit (double click) the controller and go to the 
Sweep tab and assign: IBB: 10uA to 100uA in 10uA steps. Then go to the Display tab
and check the settings to be displayed as shown. Then click Apply and OK.

f. Insert a VAR (click icon) variable equation. Use the cursor on the screen to set IBB=0 A
to initialize (declare) the variable to be swept.

g. Insert a wire label VBE at the base. The voltages at that node will appear in the dataset 
for use in calculating bias resistor values.

h. Simulate and plot the data. When the data display opens, insert a list of VBE and IC.i
only. Because you swept IBB to get these values, IBB will automatically be included.
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NOTE on results: As you can see, with 3 volts across the device, 40 uA of base current 
results in about 799mV across the base-emitter junction, with about 3.3 mA of collector 
current. If you want, draw a box around the values at 40 uA IBB.

i. Save the design and data display.

11. Calculate bias values Rb and Rc for a grounded-emitter circuit.

a. In the data display, insert an equation and type: Rb = (3 – VBE) / IBB.

b. Select the Rb Eqn and use the keyboard Ctrl C and Ctrl V to copy/paste it – it will become    

Rb1.

c. Highlight the Rb1 equation  as shown and change it to become

Rc: Rc = 2 / IC.i. The total DC supply will be 5 volts. Therefore, 

with 3 volts VCE, 2 volts remain for the collector resistor.
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d. Insert a new List and scroll down to the Equations menu (shown here), and add Rb and Rc. 
Then edit both column headings on the list with a bracketed [3] as shown. This references the 
40uA IBB using its index value [3]. Index values begin at zero: 0, 1, 2, 3, etc. You can also use 
Plot Options to add a label to the list as shown:

Bias Resistor Values @ 40 uA IBB

12. Set up the biased network.
Now that you have the calculated bias resistor values, you can test the bias network.

a. Save the design (dc_bias) with a new name: dc_net. By this time, you should know how to 
do this (File > Save Design As). Also, save and close the dc_bias data display.

b. Modify the design as shown. Begin by deleting the current source IBB, the I_Probe, and the 
Var Eqn.

c. Go to the Lumped Components palette or use component history or Hot Key Ctrl R to 
insert resistors for the base (56 kOhm) and collector (590 Ohm) as shown. You may need to 
use the rotate icon to insert it correctly.
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d. Change the instance R names to RC and RB as shown.

Insert the cursor and type 
over to rename it to RC.

NOTE on components with artwork: Later on (after the last lab), you can easily and 
quickly change to lumped components with artwork by changing the component name – for 
example, change R to R_Pad1, C to C_Pad1, L to L_Pad1, etc. Then you can create a 
layout of the schematic. For now, use lumped without artwork.

e. Set the V_DC supply: Vdc = 5V. Wire the circuit and organize it. 
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f. Delete the DC simulation controller and put a new one in its place – this is faster and more 
efficient than removing the sweep settings. Because there is no sweep, you do not have to set 
anything to check DC values.

13. Simulate and annotate the DC solution.
a. Use the Simulate > Simulation setup                                     
(or Hot Key “S” if you have set it) and uncheck                                                         
the automatic open data display feature.

b. Click Simulate > Simulate, or on a PC try the F7 keyboard key, to run the simulation.        
The dataset name will be the same as the schematic – this is the default. You can verify this 
by reading the status window. 

c. Annotate the current and voltage by clicking on the menu command; Simulate >
Annotate DC Solution. If necessary, move components or component text (F5 key) to 
clearly see the values of voltage and current. Be sure that you have the same values 
dhown here. If not, check your work, including the sub-circuit.
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NOTE: To move 
pin/node names, 
point-click-drag.

d. Clear the annotation, click: Simulate > Clear DC Annotation and then Save all you 
work. Close all windows if nor doing the optional steps that follow.
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Lab3: AC Simulations
1. Copy & Paste (Ctrl+C / Ctrl+V) from one design to another.

a. Open the last design (dc_net) and copy the circuit shown highlighted here by dragging 
the cursor around the area – this is known as rubber banding. With the items 
highlighted, copy then by using the keyboard keys Ctrl+C or the Edit > Copy command. 
Using Ctrl+C is preferred because it eliminates mouse clicks.
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b. Use the File > New Design command to create a new schematic and name it: ac_sim.
Then use Ctrl+V or use Edit > Paste and insert (ghost image) the copy by clicking into the 
new schematic.

c. Save the ac_sim design. You must save it or it will not be written to the database.

d. Click the command Window > Designs Open. This command gives you access to 
designs that are open in memory but not visible in a window or not saved in memory. When 
the dialog appears, select dc_net and click Ok. Then close dc_net design using File > Close
Design (no need to save the changes).

e. In the empty schematic window, reopen the ac_sim design using the                              
File > Open Design icon. This gives you a list of all the designs in the                
project. If a design is created but not saved initially, it will not be in this                                 
list and you will need to use the command Window > Designs Open to       
access it.

                   

2. Modify the copied circuit and pin labels.
Delete wires, insert new components, and rewire as needed. The steps follow:

a. Disconnect  the DC source and move it to the side with a ground.

b. Insert two ideal DC_Block capacitors from the Lumped-Components palette or use 
component history.
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c. Insert a V_AC source from the Sources-Freq Domain palette. Ground the source. Then 
add a 50 ohm load resistor and ground to the output.

d. Modify the Pin/Wire (node) labels. Click the Name icon. Add Vcc as a label to both RC 
and the DC source. This will connect them electrically instead of a wire.

e. Add Vin and Vout as shown. Also, if you did any 
OPTIONAL steps in lab3, remove VC and VBE by 
clicking on those labels when the dialog is blank 
(shown here) or use the command: Edit > Wire/Pin 
Label > Remove Wire/Pin Label.

f. Verify that the circuit looks like the one shown here.
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3. Push and pop to verify the sub circuit.
a. Select the bjt_pkg and push into the sub-circuit (use the icons) to check                                

your sub circuit, and then pop out again.

4. Set up an AC simulation with Noise.

a. Insert an AC Simulation controller. Then edit the start, 
stop, and step frequencies: 100 MHz to 4 GHz in 100 MHz 
steps.

b. In the Noise tab, check the box for Calculate noise and 
add the Vout node. Set the Mode to Sort by Name for each 
noise contributor. Sort by value is good for large circuits to 
see the largest contributors first. Also, all noise values will 
be simulated if a Dynamic range (threshold) is not set.

c. Turn on the Display for each of the 
parameters as shown here.
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5. Simulate and list the noise data.
a. Simulate (F7).

b. In the data display, insert a list (icon) of name and vnc
(voltage noise contributors) using the Ctrl key to select them                                             
both. As shown here, at each frequency, Q1.BJT1 is the total    
noise voltage for the device and is composed of: Q1.BJT1.ibe    
and Q1.BJT1.ice. However, these are not correlated voltages     
but have been added as noise powers: (Vtotal)2=(Vibe)2+(Vice)2.                                              
The total vnc is the same as Vout noise.

c. Save the schematic and data display.
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6. Control the output of equations and node voltages.

a. In the ac_sim schematic, insert a MeasEqn from any simulation palette. Or, 
you can type in MeasEqn in component history.

b. Directly on the schematic screen, edit (type) the equation to compute voltage 
gain using the node (pin) labels Vin and Vout. Use the keyboard arrow key to 
move across the equal (=) sign.

c. Edit the AC simulation controller and go to the 
Output tab. The default is for all labeled node voltages 
(pin/wire labels) and all Measurement equations to be 
reported in the dataset. You will change this in the 
next steps.

d. Uncheck the box for Node Voltages and click on 
the Add/Remove button.
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e. Select Vin and Vout from the list of available outputs and Add them as shown here –
then click OK. Only those node voltages will be written into the dataset after simulation and 
Vcc will not. This works for measuremnt equations also.

d. Click OK to dismiss the dialog – you are now ready to simulate.

NOTE on node name display: You can display the node names (Display tab –
NodeName check box) but it is not necessary.
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7. Simulate without noise
a. In the schematic, turn off the noise calculation by changing    
(typing) yes to no as shown here. This will save simulation time                  
and memory, especially for large circuits. Of course, this will make                                            
your dataset list (name and vnc) invalid.

b. Save the schematic and Simulate (F7)

8. Write a data display equation using a measurement equation.
a. In the data display, delete the invalid noise listing.

b. Insert a data display equation (use the icon).

c. In the dialog, write an equation for the gain in dB as shown here. Notice that you are 
inserting the schematic measurement equation into your data display equation and click OK.

NOTE on equations – If the measurement equation for voltage gain was not already 
calculated, you would write the data display equation with all the required values, for example: 
gain_dB=20* log (mag(Vout)/mag(Vin)). However, because that voltage gain was already 
calculated, it is easier to simply insert it here.
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9. Work with measurement and data display equations.
a. Insert a list of the measurement equation gain_voltage and the DDS equation you     
just wrote gain_dB. Again, schematic measurement equations are automatcially written 
into the dataset as shown here. But equations you write in the data display are not – they 
are accessed in the data display Equations memory. To display your dataset equation, 
gain_dB, click on the arrow box (shown here) and then select it and add it. Click OK and 
both equations will appear in the list. 

Data Display equations listed here.Measurement Equations listed here.

b. Scroll down the list to values around 1900 MHz, 
using the arrow buttons as shown.
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c. Insert the cursor directly into the gain_voltage
column and type in the dB function as shown. 
Then add parentheses so that it reads: dB
(gain_voltage). This demonstrates the flexibility 
of the data display for operating (with ADS 
functions) directly on data and equations.

d. Click the data display Undo command to 
return to remove the dB function.

e. Edit the list (double click) and change it to a 
rectangular plot by selecting the icon.



872005 Aug

f. Insert the cursor directly onto the Y-axis label and change gain_voltage to 
dB(gain_voltage) similar to the way you did in the list. Then undo it. Again, this 
shows the power of functions and the data display.

NOTE on dB values – Converting the AC analysis voltage to dB is not the 
same as S-parameter analysis in dB that uses power (V and I) and also has a 
50 ohm source Z.
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10. Plot the phase and group delay for the ac analysis data.
a. Insert a rectangular plot of the phase of Vin and Vout – put markers on 1900 MHz 

(type in the value). The phase is not 180 degrees due to the bjt_pkg parasitics. Move the 
markers and see the phase closer to180 at lower frequencies. You may want to Hot Key
the new marker command using the DDS Options > Hot Key similar to schematic.

b. Insert a new equation to calculate group delay. As shown here, use the phase of Vout
and the diff function then plot the equation. The diff function calculates the difference 
between points on the slope. The minus sign gives the result in decreasing value. Place a 
marker on the trace and notice that it  will be on either side of 1900 MHz (+/- 50 MHz) 
because of the diff function.
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c. Go back to the schematic, change the step
size to 10 MHz, simulate again and watch the 
plot update.

d. Edit (double click) the marker. In the readout
tab, set Format to Engineering with 2 
significant digits as shown here. Notice the 
marker value changes to pico (pico-seconds) 
and the independent value resolves to 1.90 GHz.

e. OPTIONAL-Try grouping the group delay 
equation and the plot so they stay together 
when you move them. Use the Shift key and 
select the plot and the equation. Then click: Edit
> Group. They should now move together in the 
data display.
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Course Topics

1:Circuit Simulation Fundamentals
2:DC Simulation and Circuit Modeling
3:AC Simulation and Tuning
4:S-Parameter Simulation and Optimization  
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S-parameters

Usually given in dB as 20 log of the voltage ratios of 
the waves at the ports：incident, reflected, or 
transmitted
S11-Forward Reflection (input match – impedance)
S22-Reverse Reflection (output match –impedance)
S21-Forward Transmission (gain or loss)
S12-Reverse Transmission (leakage or isolation)
S11 and S22 are best viewed on a Smith chart
S21 and S12 are easier to understand and simply 
plotted
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The impedance Smith Chart

This is an impedance chart transformed from rectangular Z. Normalized 
to 50 ohms, the center=R50+J0 or Zo(perfect match).

Top Half：
Inductive 
Reactance (+jx)

Bottom Half：
Capacitive  
Reactance (-jx)

Circles of constant 
Resistance

Lines of constant 
Reactance (+jx above 
and –jx below)

Z0(characteristic impedance)=50+j0

1505016.7

25
50 100

OPENSHORT



932005 Aug

The Smith chart in ADS Data Display

Impedance ：Z
Z= real           /  imaginary

0 to +infinity /  -infinity to infinity

Reflection Coefficient：gamma

Z=0 +j0

or S11=1/180

Z=infinity + j infinity

or S11=1 / 0

S(1,1)：mag / phase

0 to 1 / 0 to +/- 180

Z=0-j2

Z=0-j1

Z=0+j1

Z=1+j0 

or Z=1 / 0
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S-Parameter Simulation Controller
Default sweep variable = freq

The simulator requires a 
port termination Num=__

Next slide
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Sweep Plan with S-parameter simulations
Sweep Plan is for sweeping 
FREQ. Otherwise, use a 
Parameter Sweep for 
variables(Vcc, pwr, etc.)

These are 
ignored if 
Sweepplan is 
selected

These are ignored 
if Sweep plan is 
selected

Here is a sweep within a sweep

Mixer designers：Here 
is a plan for an RF, 
LO ,and IF



962005 Aug

S-Parameter measurement equations
All simulation palettes have specific 
measurement equations – you set the 
arguments if necessary. Here, S is the matrix, 2
is the value in dB, and 51 point used to draw 
the circle

Stability circle

Noise circle
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Matching Networks

Series LParallel L

Parallel L
Series C

Series R
Parallel R

Matching means：Moving 
toward the center of the Smith 
Chart

Add Series of Parallel 
components

Adjust the value to move 
toward open , short , L , C , 
or center of chart
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Design Guide – Smith Chart Utility for matching
•Insert the component in 
schematic

•Bring up the utility

•Set source and load on chart 

•Select components：L,C,R etc

•View response and build circuit
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ADS Optimization Basics

Definition：Optimization is a simulation 
that tries to achieve a performance goal.
Start with a simulation that gives you 
results
Set up the optimization which includes：

An optimizer type and search method

A specific goal or specification to be met

Enable components or parameters to be adjusted
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Four elements for Optimization setup
1-Optim controller：set the type

2-Goal statement：use valid 
measurement equation or data 
set expression

3-Enable component
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Error Function Formulation(1)

Error Function Formulation Optimizers
Least-squares Gradient , Quasi-Newton , 

Random , Discrete , Genetic

Minimax Gradient Minimax , Minimax , 
Random Minimax

Least Pth Least Pth

Worst-case Random Maximizer

Optimizer Type determines Error Form
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Error Function Formulation(2)

Least Squares：Each residual is squared and all terms 
are then summed. The sum of the squares is averaged 
over frequency
Least Pth：The Least Pth EF formulation is similar to L2 , 
except that instead of squaring the residuals , it raises 
them to the Pth power with P=2 , 4 , 6 etc
Minimax：attempts to minimize the largest of the 
residuals . This tends to result in equal ripple responses
Worst case：minimizes the reciprocal of the least 
squares error function. This effectively maximizes the 
error function. The goal is to find a worst typical 
response for a given set of parameters
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Goals and Error Function

The goals are minimum or maxi mum target values
The error function is base on the goal
The weighting factor prioritizes multiple goals

Error function is defined as a summation of residuals. A residual ri
may be defined as：

ri = Wi |mi – Si|

Si is the simulated ith response

Mi is the desired response for the ith measurement

Wi is the weighting factor for multiple goals：higher number is greater

Simulations continue until the maximum iterations is reached or the 
reeor function(summation of the residuals)reaches zero (same as 10dB)
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Search Method examples
Random analysis often get 
you close to the 
goal(minimum error function)

Gradient analysis may get 
stuck in a local minimum(not
optimal error function)

Using both RANDOM and 
GRADIENT can reach the desired 
goal or in some cases , a hybrid 
type such as Genetic
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Optimization Controller setup
Setup tab：Select 

type and set iterations.
Parameters tab：type, 

iterations, etc. 

Final Analysis：
change to 
SimInstanceName(SP1)
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Enabling components for Opt or Stats (yield)
Edit (double click) – Enable and specify continuous or discrete (stepped) 
variation
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Lab 4：S-parameter Simulations and Optimization

Create a new project S_parameter_Simulation_and_Optimization
a. Open a new schematic window and save it with the name：bjt_pkg

Set up a generic BJT symbol and model card
a. In the schematic window , select the palette：Devices-BJT. Select the 

BJT- NPN device shown here and insert it onto the schematic.

b. Insert the BJT_Model (model card)shown here.

The circuit you build will be used as the lower  
level sub-circuit.

NOTE：The BJT_NPN symbol 
shows Model=BJTM1.This means 
the symbol will use that specific 
model (model card) for simulation
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Lab 4：S-parameter Simulations and Optimization

c. Next , in BJT_Model dialog , select the Bf parameter and type in the word 
beta as shown here. Also , click the small box：Display parameter on 
schematic for Bf only and then click Apply. Beta is now a parameter of this 
circuit – later on you will tune it like a variable.

d. Set Vaf (Forward Early 
Voltage) = 50 and display it

e. Set Ise (E-B leakage) = 
0.02e-12 , and display it also. 
Then close the dialog with 
OK. The device now has 
some more realistic 
parameters 

Click here to display an 
individual value

Use Component 
Options to clear all the 
displayed parameters
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Lab 4：S-parameter Simulations and Optimization

Add parasitic and connectors to the circuit 

a. Insert lumped L and C components：Insert three lead inductors of 
320 pH each and two junction capacitors of 120fF each. Besure to use 
the correct units (pico and femto) or your circuit will not have the correct 
response.

b. Add some resistance R=0.01 ohms to the base lead inductor and 
display the desired component values as shown 

c. Insert port connectors：Clock the port 
connector icon (shown here) and insert the 
connectors exactly in this order：1)collector, 
2)base, 3)emitter. You must do this so that the 
connectors have the exact same pin 
configuration as the ADS BJT symbol.

d. Edit the port names as show here：change 
P1 to C , P2 to B and P3 to E
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Lab 4：S-parameter Simulations and Optimization

This lab you will learn how to simulate S-parameter 
Set up the simulation and circuit with ideal components

a. Open a new schematic window and save it with the name：s_params

• Click the Component Library icon shown here

• When the dialog opens , click on the bjt_pkg sub-circuit. Insert in into   
the schematic.
• Insert terminations (Term) from the S-parameter palette
• From the Lumped Components palette , insert two ideal inductors：
DC_Feed to keep the RF out of the DC path
•Insert two ideal DC_Block capacitors

b. Insert an S-Parameter simulation controller and set：Start=100 MHz , 
Stop=4 GHz , and Step=100MHz

c. Save the design

Note：your circuit must like the next slide
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Lab 4：S-parameter Simulations and Optimization
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Lab 4：S-parameter Simulations and Optimization

Simulate and plot data with marker readout modifications

a. Be sure the name of the dataset is ：s_params and then simulate

b. When the simulation is finished , insert a rectangular plot of S21 (dB) . Insert 
a marker on 1900 MHz and verify that the gain is about 20 dB

c. Insert a Smith chart of S11 and place a marker on 1900 MHz. to move the 
marker , select the readout and use the arrow keys

d. Edit the marker readout (double click). Go to the Smith tab and change Zo
to 50 as shown. Click OK and the marker will now read the value in ohms , 
referenced to 50 ohms
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Lab 4：S-parameter Simulations and Optimization

Write an equation to vary the Term port impedance.

a. In schematic , write an equation for port 2 Term Z to be 35 ohms above 
400 MHz ：Z = if freq < 400 MHz then 50 else 35 endif.

b. Simulate and then insert a list of PortZ(2). Verify the Z is 35 Ohms 
above 400 MHz

c. Reset the value of port 2 Term to 50 ohms：Z = 50 Ohm
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Lab 4：S-parameter Simulations and Optimization

Calculate L and C values in the data display

a. In data display , write an equation , XC , for the capacitive reactance of 
10 pF at 1900 MHz. Then list equation XC as shown here. If desired , title 
the list using Plot Options. With this low reactance , 10pF will be the 
blocking capacitor values.

b. Change the value of the capacitor in the equation and verify that XC is 
automatically updated in the list.

The transmission and reflection characteristics of the biased 
circuit show about 20 dB of gain but with a mismatch to 50 ohms 
at the input. Also , the DC feeds and blocks are ideal and need to 
be replaced with real values.
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Lab 4：S-parameter Simulations and Optimization

d. Save the current data display and 
the schematic

c. Create a table for range of inductor values and reactances. L_val is a range 
of swept values form 1 nano to 200 in 10 nano steps. In ADS , the syntax of 
two colons is a wild card  (all values) and can also be used to indicatea range 
as shown here. The square brackets are used to generate the sweep. After 
writing the equations and listing them as shown here , scroll through the list. As 
the inductor value increases , the reactance at 1.9 GHz increases. Therefore , 
a value of 120 nH should be enough for the DC feed (RF choke)

NOTE：The XL equation will be red (invalid) until L_val is written
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Lab 4：S-parameter Simulations and Optimization

Replace L and C with calculated values and simulate

a. Save the schematic with a new name ：s_match

b. Change the component name (DC_Block) of both blocking capacitors to C
and they will automatically become lumped capacitors as shown here. 
Assign the value for each C=10pF

c. Change the ideal inductors (DC_Feed) in the same manner and set L= 
120 nH for each. According to the XL and L_val table , the reactance at 
1900 MHz is about 1.5k , which is reasonable at this point in the design.
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Lab 4：S-parameter Simulations and Optimization

d. The schematic should now look like the one shown here. Check you values 
and then Simulate
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Lab 4：S-parameter Simulations and Optimization

e. In the data display , plot the transmission (S12 and S21) and reflection (S11 
and S22) data with markers as shown here. Notice the gain stays relatively 
flat , step is to create an input matching network.
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Lab 4：S-parameter Simulations and Optimization
Use the Smith Chart utility to build a simple matching network.

a. In the current schematic , click on the commands：DesignGuide>Filter 
and then choose the Smith Chart Control Window.
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Lab 4：S-parameter Simulations and Optimization

b. Near the top of the Smith Chart control window , click 
the Palette icon shown here. This will bring up the Smith 
Chart palette on your schematic.

c. Insert the Smith Chart Matching 
Network component (also know as a 
Smart Component) onto the schematic 
near the input of the amplifier – no 
need to connect it – but it is required . 
Also , click OK when a message dialog 
appears.

d. Go back to the Smith Chart control 
window and click the Set Frequency 
/ Impedance button. Then set the 
frequency to 1.9 GHz and turn off the 
normalization. Click Ok
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Lab 4：S-parameter Simulations and Optimization
e. IN the lower right corner of the window , select the ZL component and 
type in the impedance looking into the amplifier from the last simulation 
(S11≈550-j*220)
f. Notice that the load symbol on the smith chart 
has relocated as shown here. Next , select the 
shunt capacitor form the palette and move the 
cursor on the Smith chart. When you get to the 
50Ohm circle of constant resistance , click to 
stop , as shown here

Load symbol is at 
550-j220. Source 
symbol is at 50+j0
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Lab 4：S-parameter Simulations and Optimization

g. Next , select the series inductor and move the cursor along the circle until 
you reach the center of the Smith chart.

match

h. Move the cursor into the lower right corner 
of the window and click on each of the 
components in the Schematic as shown here. 
You will see the value for the inductor and 
capacitor：approximately L≈14 nH and C 
≈ 400 fF or 0.4pF.
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Lab 4：S-parameter Simulations and Optimization

j. To have the DesignGuide build the circuit , click the button on the bottom of 
the window：Build ADS Circuit . Click OK to any messages that appear.

k. On the schematic , push into the Smith Chart component and you should 
see the network as shown below：
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Lab 4：S-parameter Simulations and Optimization
Now it is time to use the matching network with the amplifier. You 

could use the component by connecting it to the amplifier input.
However , because you will be using the optimizer , it is better to have 
the L-C components on the schematic.

l. Either copy / paste the L-C and ground onto the amplifier or simply insert 
and L and C on your schematic. Then set the values to L=14.3 nH and 
C=0.4PF. The amplifier input should now be as shown here.

m. Delete the Smith Chart 
component from the schematic 
and close the Smith Chart utility 
window

n. Simulate with the input 
network

p. Set the simulation step size 
to 10 MHz , and simulate
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Lab 4：S-parameter Simulations and Optimization

q. When the simulation is complete , add S-22 to the Smith chart. Place a 
marker on S-22 at 1.9 GHz. The result show S-11 is good but S-22 is not 
match as shown here
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Lab 4：S-parameter Simulations and Optimization

Because S-22 is similar to the unmatched impedance of the 
input , it is reasonable to put a similar topology on the output and 
simulate the response.

Add output matching components.
a. Select the input L-C network and use the copy icon (shown here) to 
make a copy to the components. Then place them near the output , with a 
ground on the capacitor. Delete the wires and insert them as shown at the 
output.
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b. Simulate and check the response. Your data should be similar to the 
results shown here where S22 is now closer to 50 ohms. However , S11 has 
shifted , as you should expect. Set the S-22 marker readout edited to Smith 
Zo=50

c. Save the design but 
do not close the window
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Set up an Optimization controller and Goals.

a. Save the s_match schematic design with a new name：s_opt

b. Go to the Optim / Stat / Yield palette and insert an optimization 
controller and one goal as shown here

c. Edit the goal by double clicking. In the dialog box , type in the following 
settings and clock Apply after each one and OK when done

Expr：dB (S(1,1))

SimInstanceName：SP1

Max= -10 (S11 must be at 
least -10 dB to achieve the 
goal)

RangeVar=freq Range 
Min=1850 MHz RangeMax：
1950 MHz
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d. Copy the S11 goal – select it and use the copy icon

e. On screen , change the goal expression to 
“dB(S(2,2))” as shown here. Now , you have two 
goals for the input and output match.

f. Set up the OPTIM controller. For this lab exercise , 
most of the default settings can remain , controller and 
set the MaxIter = 125 and set the FinalAnalysis = 
“SP1”. These settings mean that the optimizer will run 
for up to 125 iterations to achieve the goals. The 
Normalize goals setting means that all goals will have 
equal weighting. Also , a final analysis is automatically 
run with the last values so that you can plot the results 
without running another simulation.
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Enable the components to be optimized

a. Edit (double click) the inductor L_match_in. 
When the dialog appears , click the 
Optimization/Statistics/DOE Setup button. In 
the Optimization tab , set the inductor to be 
Enabled as shown and type in the continuous 
range from 1 nH to 40 nH as shown here. Click 
OK and the component text will show the opt 
function and range.
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b. Go ahead and Enable the other three matching components as shown. 
Edit each one using the dialog box or you can type directly on-screen using 
the opt function and curly braces for the range. Also , use the F5 key to move 
component text as need：
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c. Check the circuit as shown here and then Simulate and watch the status 
window.
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d. The status window reports progress. If the goals are met , the EF (error 
function) = 0. A successful iteration occurs if the EF moves closer to zero. 
With EF = 0 (or close in some cases) , the next step is to update component 
values and plot the results. If your EF is not zero , check the schematic and 
try it again.
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Plot the results

a. In the data display , insert a rectangular plot. Then , as shown here , add 
the complete S matrix in dB to see all four S parameters. This way you can 
quickly verify the results. Your values may differ but the goals from the 
optimization should be met
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b. Plot the impedance S11 and S22 on a Smith chart. Change the marker 
readout Smith tab to Z0=50. As you will see , the impedance is not close 
enough to 50 ohms. But first , you will update the schematic with the values 
from the optimization.
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Update optimized values and disable the opt fucntion.

a. Click the command：Simulate > Update Optimization Values. The 
enabled components should now have the final values as the nominal 
values. For example , the input inductor may look like the one shown here –
your values may vary a little because of the random mode and no seeding.

b. Disable a component. Edit L-match_in inductor. Then click the 
Optimization/Statistics/DOE Setup button. Select Disabled as shown here 
nad click OK. Notice that the component function changes from opt to noopt. 
This means the component will not be used in an optimization. You can also 
disable a component by inserting the cursor on – screen and typing no infront
of opt function to make it noopt – try it.

c. Save the s_opt schematic. In the next 
set of steps , you will set up a final 
matched circuit.
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a. Save the s_opt schematic as ：s_final.

b. Delete the optimization controller and goals.

c. modify the four L and C matching component values , adding resistance 
to the inductors as shown here. This will result in a good match and will be 
used for the remainder of the lab exercises. Go ahead and change the values 
the values by typing directly on –screen as shown here ：

L_match_in = 18.3 nH & R = 12 Ohm    L_match_out = 27.1 nH & R = 6 Ohm

C_match_in =  0.35pF                             C_match_out = 0.22 pF

d. With the new final component values and Simulate

e. When the data display opens , plot the entrie Smatrix by selecting S in 
the dataset. Also plot the S11 and S22 on the Smith chart to verify the match 
is close to 50 ohms at 1900 MHz. With these results.
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