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Getting Started with HFSS: A Probe Patch Feed Antenna
Conventions Used in this Guide
Please take a moment to review how instructions and other 
useful information are presented in this guide. 

•    Procedures are presented as numbered lists. A single bul-
let indicates that the procedure has only one step.

•    Bold type is used for the following:
- Keyboard entries that should be typed in their entirety 
exactly as shown. For example, “copy file1” means to 
type the word copy, to type a space, and then to type 
file1.

- On-screen prompts and messages, names of options and 
text boxes, and menu commands. Menu commands are 
often separated by carats. For example, click 
HFSS>Excitations>Assign>Wave Port.

- Labeled keys on the computer keyboard. For example, 
“Press Enter” means to press the key labeled Enter.

•    Italic type is used for the following:
- Emphasis.
- The titles of publications. 
- Keyboard entries when a name or a variable must be 
typed in place of the words in italics. For example, 
“copy file name” means to type the word copy, to type 
a space, and then to type a file name.

•    The plus sign (+) is used between keyboard keys to indi-
cate that you should press the keys at the same time. For 
example, “Press Shift+F1” means to press the Shift key 
and the F1 key at the same time.

•    Toolbar buttons serve as shortcuts for executing com-
mands. Toolbar buttons are displayed after the command 
they execute. For example,

“On the Draw menu, click Line ” means that you can 
click the Draw Line toolbar button to execute the Line 
command.
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Getting Started with HFSS: A Probe Patch Feed Antenna
Getting Help

Ansoft Technical Support
To contact Ansoft technical support staff in your geographical 
area, please log on to the Ansoft corporate website, http://
www.ansoft.com, click the Contact button, and then click 
Support. Phone numbers and e-mail addresses for the techni-
cal support staff are listed. You can also contact your Ansoft 
account manager in order to obtain this information.
All Ansoft software files are ASCII text and can be sent conve-
niently by e-mail. When reporting difficulties, it is extremely 
helpful to include very specific information about what steps 
were taken or what stages the simulation reached, including 
software files as applicable. This allows more rapid and effec-
tive debugging.

Help Menu
To access online help from the HFSS menu bar, click Help and 
select from the menu:
•    Contents - click here to open the contents of the online 

help.
•    Seach - click here to open the search function of the 

online help.
•    Index - click here to open the index of the online help.

Context-Sensitive Help
To access online help from the HFSS user interface, do one of 
the following:
•    To open a help topic about a specific HFSS menu com-

mand, press Shift+F1, and then click the command or 
toolbar icon.

•    To open a help topic about a specific HFSS dialog box, 
open the dialog box, and then press F1.
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Probe Feed Patch 
Antenna
This example is intended to show you how to create, sim-
ulate, and analyze a probe feed patch antenna using the 
Ansoft HFSS Design Environment.
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Getting Started with HFSS: Probe Feed Patch Antenna
Getting Started
Click the Microsoft Start button, select All Pro-
grams>Ansoft>HFSS 12>HFSS 12 or double click on the 
HFSS 12 icon on the Windows Desktop

Adding a Project and Design
To insert a design into an open project:
1  Click Project>Insert HFSS Design or on the Toolbar click 

the Insert HFSS Design icon.
The new HFSS design appears in the Project tree.

Setting Tool Options
To set the tool options:
Note: In order to follow the steps outlined in this example, 
verify that the following tool options are set :
1  Click Tools>Options>HFSS Options

2  In the HFSS Options dialog click the General tab
Check “Use Wizards for data input when creating new 
boundaries.”
Check “Duplicate boundaries/mesh operations with geom-
etry.”

3  Click OK to close the HFSS Options dialog.
4  Click Tools>Options>Modeler Options.
5  The Modeler Options dialog opens with the Operation 

tab.
6  Check “Automatically cover closed polyline.”
7  Click the Drawing tab

Check “Edit property of new primitives.” 
This causes the Properties window for new primitives to 
open automatically.

8  Click the OK button

Set Solution Type
To set the solution type:
1  Click HFSS>Solution Type

The Solution Type dialog opens.
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Getting Started with HFSS: Probe Feed Patch Antenna
2  Choose Driven Terminal
3  Click the OK button

Set Model Units
To set the units:
Click Modeler>Units
Set Model Units:
Select Units: cm

Click the OK button

Set Default Material
To set the default material:
1  Using the 3D Modeler Materials toolbar, choose Select...

2  This opens the Select Definition window with the Materi-
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Getting Started with HFSS: Probe Feed Patch Antenna
als tab.

3  1. In the Search by Name field, type Rogers RT/ duroid 
5880 (tm).

Click the OK button

Create Substrate
To create the substrate:
1  Click Draw>Box

2  Using the coordinate entry fields, enter the box position
X: -5.0 Y: -4.5, Z: 0.0, Press the Enter key

3  Using the coordinate entry fields, enter the opposite cor-
ner of the box
dX: 10.0, dY: 9.0, dZ: 0.32, Press the Enter key

To set the name:
1  In the Properties window Name field type: Sub1

2  Click the OK button
To fit the view:
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Getting Started with HFSS: Probe Feed Patch Antenna
Click View>Fit All>Active View, or press the CTRL+D.

Create Infinite Ground
To create the infinite ground:
1  Click Draw>Rectangle

2  Using the coordinate entry fields, enter the rectangle posi-
tion
X: -5.0, Y: -4.5, Z: 0.0, Press the Enter key

3  Using the coordinate entry fields, enter the opposite cor-
ner of the rectangle:
dX: 10.0, dY: 9.0, dZ: 0.0, Press the Enter key

To set the name:
1  In the Properties window Name field type: Inf_GND

2  Click the OK button
To fit the view:
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Getting Started with HFSS: Probe Feed Patch Antenna
Click View>Fit All>Active View.

Assign a Perfect E boundary to the Infinite Ground
To select the trace:
1  Click Edit>Select>By Name

The Select Object dialog opens.
-6 Probe Feed Patch Antenna 



Getting Started with HFSS: Probe Feed Patch Antenna
2  Select the objects named: Inf_GND

3  Click the OK button
To assign the Perfect E boundary
1  Click HFSS>Boundaries>Assign>Perfect E

The Perfect E Boundary dialog opens.
2  Specify the Name as: PerfE_Inf_GND
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Getting Started with HFSS: Probe Feed Patch Antenna
Check “Infinite Ground Plane.”

3  Click the OK button

Create Infinite Ground Cut Out
To create the cut out:
1  Click Draw>Circle

2  Using the coordinate entry fields, enter the center posi-
tion
X: -0.5, Y: 0.0, Z: 0.0, Press the Enter key

3  Using the coordinate entry fields, enter the radius:
dX: 0.16 , dY: 0.0, dZ: 0.0, Press the Enter key

To set the name:
1  In the Properties window Name field type: Cut_Out

2  Click the OK button
-8 Probe Feed Patch Antenna 
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Complete the Infinite Ground
To select the objects Inf_GND and Cut_Out:
1  Click Edit>Select>By Name

The Select Object dialog opens.
2  Select the objects named: Inf_GND, Cut_Out

3  Click the OK button

To complete the ring:
1  Click Modeler>Boolean>Subtract

The Subtract dialog opens:
2  Make the following assignments:

Blank Parts: Inf_GnD
Tool Parts: Cut_Out
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Getting Started with HFSS: Probe Feed Patch Antenna
 Clone tool objects before subtract:  Unchecked

3  Click the OK button

Create Patch
To create the patch:
1  Click Draw>Rectangle

2  Using the coordinate entry fields, enter the rectangle posi-
tion
X: -2.0, Y: -1.5, Z: 0.32, Press the Enter key

3  Using the coordinate entry fields, enter the opposite cor-
ner of the rectangle:
dX: 4.0, dY: 3.0, dZ: 0.0, Press the Enter key
-10 Probe Feed Patch Antenna 
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To set the name:
1  In the Properties window Name field type: Patch

2  Click the OK button

Assign a Perfect E boundary to the Trace
To select the trace:
1  Click Edit>Select>By Name

2. The Select Object dialog opens.
2  Select the objects named: Patch
3  Click the OK button

To assign the Perfect E boundary
1  Click HFSS>Boundaries>Assign>Perfect E

The Perfect E Boundary dialog opens.
2  Specify the Name: PerfE_Patch
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3  Click the OK button

Create the Coax
To set the default material:
1  Using the 3D Modeler Materials toolbar, choose vacuum.

To create the coax:
1  Click Draw>Cylinder

2  Using the coordinate entry fields, enter the cylinder posi-
tion
X: -0.5, Y: 0.0, Z: 0.0 Press the Enter key

3  Using the coordinate entry fields, enter the radius:
dX: 0.16, dY: 0.0, dZ: 0.0 Press the Enter key
-12 Probe Feed Patch Antenna 
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4  Using the coordinate entry fields, enter the height:
dX: 0.0, dY: 0.0, dZ: -0.5 Press the Enter key

To set the name:
1  In the Properties window Name field type: Coax

2  Click the OK button.

Set Default Material
To set the default material:
1  Using the 3D Modeler Materials toolbar, choose Select...

2  This opens the Select Definition window with the Materi-
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Getting Started with HFSS: Probe Feed Patch Antenna
als tab.

3  Type pec in the Search by Name field.

This highlights the pec material.
4  Click the OK button.

This sets the default material to pec 

Create the Coax Pin
To create the coax pin:
1  Click Draw>Cylinder

2  Using the coordinate entry fields, enter the cylinder posi-
tion
X: -0.5, Y: 0.0, Z: 0.0 Press the Enter key

3  Using the coordinate entry fields, enter the radius:
dX: 0.07, dY: 0.0, dZ: 0.0 Press the Enter key
-14 Probe Feed Patch Antenna 
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4  Using the coordinate entry fields, enter the height:
dX: 0.0, dY: 0.0, dZ: -0.5 Press the Enter key

To set the name:
1  In the Properties window Name field type: Coax_Pin

2  Click the OK button.

Create the Wave port
To create a circle that represents the port:
1  Click Draw>Circle

2  Using the coordinate entry fields, enter the center posi-
tion
X: -0.5, Y: 0.0, Z: -0.5 Press the Enter key

3  Using the coordinate entry fields, enter the radius of the 
circle:
dX: 0.16, dY: 0.0, dZ: 0.0 : Press the Enter key

To set the name:
1  In the Properties window Name field type: Port1

2  Click the OK button
Probe Feed Patch Antenna -15



Getting Started with HFSS: Probe Feed Patch Antenna
To select the object Port1:
1  Click Edit>Select>By Name

This opens the Select Object dialog,
2  Select the objects named: Port1

3  Click the OK button
To assign wave port excitation
1  Click HFSS>Excitations>Assign>Wave Port

The Reference Conductors for Terminals dialog opens.
2  Ispecify the Name: p1
-16 Probe Feed Patch Antenna 



Getting Started with HFSS: Probe Feed Patch Antenna
3  Select “Use port object name.”

4  Leave Use as Reference unchecked and Highlight selected 
conductors checked.

5  Click OK.
The terminal is created under Excitations for the p1 Port 
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in the Project tree.

Create the Probe
To create the probe:
1  Click Draw>Cylinder

2  Using the coordinate entry fields, enter the cylinder posi-
tion
X: -0.5, Y: 0.0, Z: 0.0 Press the Enter key

3  Using the coordinate entry fields, enter the radius:
dX: 0.07, dY: 0.0, dZ: 0.0 Press the Enter key

4  Using the coordinate entry fields, enter the height:
dX: 0.0, dY: 0.0, dZ: 0.32 Press the Enter key

To set the name:
1  In the Properties window Name field type: Probe

2  Click the OK button
-18 Probe Feed Patch Antenna 
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Set Default Material
To set the default material:
1  Using the 3D Modeler Materials toolbar, choose vacuum.

Create Air
To create the air:
1  Click Draw>Box

2  Using the coordinate entry fields, enter the box position
X: -5.0, Y: -4.5, Z: 0.0, Press the Enter key

3  Using the coordinate entry fields, enter the opposite cor-
ner of the box
dX: 10.0, dY: 9.0, dZ: 3.32, Press the Enter key

To set the name:
1  In the Properties window Name field type: Air

Click the OK button
To fit the view:
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Click View>Fit All>Active View.

Create Radiation Boundary
Pick the faces:
1  Click Edit>Select>Faces

2  Graphically select all of the faces of the Air object except 
the face at Z=0.0cm. (The bottom)
You can hold down the Alt key, and click the top face, and 
then hit the “b” key to select a “face behind.” After 
selecting the two faces behind, you can select the remain-
ing three surface faces.

To create a radiation boundary
1  Click HFSS>Boundaries>Assign>Radiation

The Radiation Boundary dialog opens.
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2  Name: Rad1
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3  Click the OK button.

Create a Radiation Setup
To define the radiation setup
1  Click HFSS>Radiation>Insert Far Field Setup>Infinite

1  Sphere

The Far Field Radiation Sphere Setup dialog opens.
2  Select the Infinite Sphere Tab

Name: ff_2d
Phi: (Start: 0, Stop: 90, Step Size: 90)
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Theta: (Start: -180, Stop: 180, Step Size: 2)

3  Click the OK button

Analysis Setup

Creating an Analysis Setup
To create an analysis setup:
1  Click HFSS>Analysis Setup>Add Solution Setup

The Solution Setup dialog opens.
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2  In the General tab:
Solution Frequency: 2.25 GHz
: Maximum Number of Passes: 20
Maximum Delta S per Pass: 0.02

3  Click the OK button
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Adding a Frequency Sweep
To add a frequency sweep:
1  Click HFSS>Analysis Setup>Add Sweep

The Add/Edit Sweep dialog opens.
2  Specify the following:

Sweep Type: Fast
Frequency Setup Type: Linear Count
Start: 1.0GHz
Stop: 3.5GHz
Count: 201
Save Fields:  Checked

3  Click the OK button

Save Project
To save the project:
1  In an Ansoft HFSS window, click File>Save As.

2  From the Save As window, type the Filename: 
hfss_probepatch

3  Click the Save button
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Analyze

Model Validation
To validate the model:
1  Click HFSS>Validation Check

2  Click the Close button
Note: To view any errors or warning messages, use the 
Message Manager.

To start the solution process:
1  Click HFSS>Analyze All

Solution Data
To view the Solution Data:
1  Click HFSS>Results>Solution Data

The Solution Data dialog opens.
To view the Profile:

Click the Profile Tab.
To view the Convergence:

Click the Convergence Tab
Note: The default view is for convergence is Table Table. 
Select the Plot radio button to view a graphical represen-
tations of the convergence data.

To view the Matrix Data:
Click the Matrix Data Tab
Note: To view a real-time update of the Matrix Data, set 
the Simulation to Setup1, Last Adaptive

2  Click the Close button

Create Reports

Create Terminal S S-Parameter Plot - Magnitude
To create a report:
1  Click HFSS>Results>Create Terminal Solution Data 

Report.

The Reports window opens.
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2  Make the following selections:
Solution: Setup1: Sweep1
Domain: Sweep
Category: Terminal S Parameter
Quantity: St(Port1_T1,Port1_T1),
Function: dB

3  Click the New Report button
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4  Click the Close button.

5  Select the trace on the plot.
6  Right click to display the shortcut menu and click 

Marker>Add Minimum.

A minimum marker (m1) appears on the trace, and a 
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marker table lists the x and y coordinate values.

Far Field Overlays

Create Far Field Overlay
To create a 2D polar far field plot :
1  Click HFSS>Results>Create Far Fields Report>Radiation 

Pattern.

The Reports dialog appears.
2  Specify the following:

Solution: Setup1: Sweep1
Geometry: ff_2d
In the Trace tab:
Select Theta the primary sweep.
Category: Gain
Quantity: GainTotal
Function: dB
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3  Click New Report.
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